problema: "Lunchpad VLC" not changed [RESOLVIDO]

1. problema: "Lunchpad VLC" not changed [RESOLVIDO]

Mário Borba
woody143a

(usa Linux Mint)

Enviado em 27/02/2015 - 20:41h

Olá amigos, utilizo o Linux Mint 17.1 Rebecca Mate 64-bit, e faz algum tempo que dá este erro quando executo alguns comandos no terminal (como apt-get update, ou para adicionar algum pacote):
http://imgur.com/xLwG6Oz
Nunca dei muita importância porque acabava conseguindo fazer o que tentava fazer. Mas venho tentando faz dois dias instalar o go-mtpfs e acredito que seja a falta de alguma "public key" que está me impedindo. Fiz um procedimento que consta neste forum http://ubuntuforums.org/showthread.php?t=1947273 e o erro do update parou. Mas sigo sem conseguir adicionar go-mtpfs na lista para instalá-lo.
Alguém saberia me dar uma luz quanto a isso?
(imagino que a categoria apropriada para esta questão seja "banco de dados" mas nem imagino que subcategoria, adianto minhas desculpas por provavelmente ter categorizado de forma equivocada)
Abraço


  


2. Re: problema: "Lunchpad VLC" not changed [RESOLVIDO]

edps
edps

(usa Slackware)

Enviado em 27/02/2015 - 21:45h


tente primeiramente:


$ sudo apt-get update
$ apt-cache search go-mtpfs
$ apt-cache show go-mtpfs


Eu no seu lugar (SE) é o caso de tentar plugar Androids, usaria o jmtpfs, melhor suportado nos Androids 4x, veja um exemplo:

https://gnutwoall.wordpress.com/2014/08/01/how-to-script-para-montar-celulares-com-android-4-x-no-de...

Se lhe interessar veja o que diz a Arch Wiki sobre MTP:

https://wiki.archlinux.org/index.php/MTP




3. Re: problema: "Lunchpad VLC" not changed [RESOLVIDO]

Mário Borba
woody143a

(usa Linux Mint)

Enviado em 27/02/2015 - 22:08h

h4rd3r escreveu:


tente primeiramente:


$ sudo apt-get update
$ apt-cache search go-mtpfs
$ apt-cache show go-mtpfs


Eu no seu lugar (SE) é o caso de tentar plugar Androids, usaria o jmtpfs, melhor suportado nos Androids 4x, veja um exemplo:

https://gnutwoall.wordpress.com/2014/08/01/how-to-script-para-montar-celulares-com-android-4-x-no-de...

Se lhe interessar veja o que diz a Arch Wiki sobre MTP:

https://wiki.archlinux.org/index.php/MTP



não encontra o pacote novamente: http://i.imgur.com/tKkoUAF.png
obrigado pela atenção!





4. Re: problema: "Lunchpad VLC" not changed [RESOLVIDO]

Mário Borba
woody143a

(usa Linux Mint)

Enviado em 27/02/2015 - 22:10h


ah, e é o caso sim de tentar plugar o android! venho tentando faz bastante tempo e até agora nada, li vários foruns, mas esse que me mandaste eu ainda não tinha visto, vinha tentando pe go-mtpfs mesmo


6. Re: problema: "Lunchpad VLC" not changed [RESOLVIDO]

edps
edps

(usa Slackware)

Enviado em 27/02/2015 - 22:20h

woody143a escreveu:

ah, e é o caso sim de tentar plugar o android! venho tentando faz bastante tempo e até agora nada, li vários foruns, mas esse que me mandaste eu ainda não tinha visto, vinha tentando pe go-mtpfs mesmo


É do blog de um tal de @edps rsrs.

Basta seguir o artigo e modificar no script as seguintes linhas

killall tumblerd && killall thunar
troque pelo nome do seu gerenciador de arquivos # se não usa o Thunar, se usa deixa assim mesmo!

thunar /media/MyAndroid
a mesma coisa, troque thunar pelo nome do seu gerenciador de arquivos # dolphin, nautilus, nemo, pcmanfm ou outro, se for o caso.

boa sorte, tô saindo.



7. Re: problema: "Lunchpad VLC" not changed [RESOLVIDO]

Mário Borba
woody143a

(usa Linux Mint)

Enviado em 27/02/2015 - 22:33h


amigo, mais uma vez obrigado pela atenção,
me sinto na cara do gol aqui hehe, o que me trava acredito que sejam duas coisas bem banais:
1- não entendi o que o cara quer dizer com "E a seguir, descomente a opção user_allow_other, no arquivo /etc/fuse.conf, segue um exemplo do meu:" naquele passo-a-passo do mundo gnu que me mandaste.
2-baixei o lib que faltou mas não consigo instalar http://imgur.com/h0946FB
abc


8. Re: problema: "Lunchpad VLC" not changed [RESOLVIDO]

Mário Borba
woody143a

(usa Linux Mint)

Enviado em 27/02/2015 - 23:25h

nem saberia que printscreen dar a essa altura do campeonato hehe, tentei o procedimento, criei o arquivo pelo gedit (antes instalei o gedit com os pacotes necessários...), uso o Mint Rebecca Mate, entendi que o gerenciador de arquivos é o caja, então coloquei caja respectivamente conforme me indicaste, mas não consigo fazer montar o aparelho. criei um arquivo galaxy.sh . não sei onde executo ele, no terminal da "command not found", talvez me falte apenas saber fazer esse esquema todo funcionar, talvez o buraco seja ainda mais embaixo... mas enfim, esse procedimento me parece muito mais promissor do que aquele go.mtpfs que tentei de todas as formas possíveis instalar e nada.
abraço


9. Re: problema: "Lunchpad VLC" not changed [RESOLVIDO]

edps
edps

(usa Slackware)

Enviado em 28/02/2015 - 09:23h

Baixe o correspondente à sua arquitetura:

i386.
https://launchpad.net/~webupd8team/+archive/ubuntu/unstable/+files/libmtp-common_1.1.5-42-g6e96316-0...
https://launchpad.net/~webupd8team/+archive/ubuntu/unstable/+files/libmtp-dev_1.1.5-42-g6e96316-0~pr...
https://launchpad.net/~webupd8team/+archive/ubuntu/unstable/+files/libmtp-doc_1.1.5-42-g6e96316-0~pr...
https://launchpad.net/~webupd8team/+archive/ubuntu/unstable/+files/libmtp-runtime_1.1.5-42-g6e96316-...
https://launchpad.net/~webupd8team/+archive/ubuntu/unstable/+files/libmtp9_1.1.5-42-g6e96316-0~preci...
https://launchpad.net/~webupd8team/+archive/ubuntu/unstable/+files/mtp-tools_1.1.5-42-g6e96316-0~pre...
https://launchpad.net/~webupd8team/+archive/ubuntu/unstable/+files/go-mtpfs-unity_0.1-1~20130108~web...
https://launchpad.net/~webupd8team/+archive/ubuntu/unstable/+files/go-mtpfs_0.1-1~20130108~webupd8~p...

amd64.
https://launchpad.net/~webupd8team/+archive/ubuntu/unstable/+files/libmtp-common_1.1.5-42-g6e96316-0...
https://launchpad.net/~webupd8team/+archive/ubuntu/unstable/+files/libmtp-dev_1.1.5-42-g6e96316-0~pr...
https://launchpad.net/~webupd8team/+archive/ubuntu/unstable/+files/libmtp-doc_1.1.5-42-g6e96316-0~pr...
https://launchpad.net/~webupd8team/+archive/ubuntu/unstable/+files/libmtp-runtime_1.1.5-42-g6e96316-...
https://launchpad.net/~webupd8team/+archive/ubuntu/unstable/+files/libmtp9_1.1.5-42-g6e96316-0~preci...
https://launchpad.net/~webupd8team/+archive/ubuntu/unstable/+files/mtp-tools_1.1.5-42-g6e96316-0~pre...
https://launchpad.net/~webupd8team/+archive/ubuntu/unstable/+files/go-mtpfs-unity_0.1-1~20130108~web...
https://launchpad.net/~webupd8team/+archive/ubuntu/unstable/+files/go-mtpfs_0.1-1~20130108~webupd8~p...

Depois instale com:


$ sudo dpkg -i *.deb
$ sudo apt-get -f install


Não tem porque compilar a libmtp, se já tem pacotes prontos.


10. E tem a forma elegante

edps
edps

(usa Slackware)

Enviado em 28/02/2015 - 09:52h

Siga os passos abaixo para compilar e empacotar todos os pacotes necessários para o go-mtpfs:

$ mkdir libmtp && cd libmtp/
$ wget https://launchpadlibrarian.net/131595764/libmtp_1.1.5-42-g6e96316.orig.tar.gz
$ wget https://launchpadlibrarian.net/131596005/libmtp_1.1.5-42-g6e96316-0~precise~1.dsc
$ wget https://launchpadlibrarian.net/131596004/libmtp_1.1.5-42-g6e96316-0~precise~1.debian.tar.gz
$ wget https://launchpadlibrarian.net/127890008/go-mtpfs_0.1-1~20130108~webupd8~precise.dsc
$ wget https://launchpadlibrarian.net/127890007/go-mtpfs_0.1-1~20130108~webupd8~precise.tar.gz


Descompacte tudo:

$ dpkg-source -x libmtp_1.1.5-42-g6e96316-0~precise~1.dsc
$ dpkg-source -x go-mtpfs_0.1-1~20130108~webupd8~precise.dsc


Instale os pacotes de desenvolvimento:

$ sudo apt-get install build-essential devscripts dpkg-dev equivs


Comece a brincadeira:

$ cd libmtp-1.1.5-42-g6e96316/
$ mk-build-deps
$ sudo dpkg -i libmtp-build-deps_*.deb
$ sudo apt-get --no-install-recommends -f install
$ dpkg-buildpackage -us -us -b -tc
$ cd ..
$ cd go-mtpfs-0.1/
$ mk-build-deps
$ sudo dpkg -i go-mtpfs-build-deps_*.deb
$ sudo apt-get --no-install-recommends -f install
$ dpkg-buildpackage -us -us -b -tc
$ cd ..


Limpe a sujeira:

$ rm -rf go-mtpfs-0.1 libmtp-1.1.5-42-g6e96316 *.dsc *.changes *.tar.gz


Instale os debs:
[/code]
$ sudo dpkg -i *.deb
$ sudo apt-get --no-install-recommends -f install
[/code]


11. Re: problema: "Lunchpad VLC" not changed [RESOLVIDO]

edps
edps

(usa Slackware)

Enviado em 28/02/2015 - 10:14h

woody143a escreveu:

amigo, mais uma vez obrigado pela atenção,
me sinto na cara do gol aqui hehe, o que me trava acredito que sejam duas coisas bem banais:
1- não entendi o que o cara quer dizer com "E a seguir, descomente a opção user_allow_other, no arquivo /etc/fuse.conf, segue um exemplo do meu:" naquele passo-a-passo do mundo gnu que me mandaste.
2-baixei o lib que faltou mas não consigo instalar http://imgur.com/h0946FB
abc


É para remover o jogo-da-velha|tralha ( # ) na linha user_allow_other no arquivo /etc/fuse.conf, veja o exemplo do meu:

# Set the maximum number of FUSE mounts allowed to non-root users.
# The default is 1000.
#
#mount_max = 1000

# Allow non-root users to specify the 'allow_other' or 'allow_root'
# mount options.
#
user_allow_other


Já o script que você criou, dê-lhe permissão de execução:

$ chmod +x script


E mova-o para /usr/local/bin ou /usr/bin:

$ sudo mv script /usr/local/bin/


Quanto ao Caja, acho que basta alterar thunar por caja


12. Re: problema: "Lunchpad VLC" not changed [RESOLVIDO]

Mário Borba
woody143a

(usa Linux Mint)

Enviado em 28/02/2015 - 11:02h


caral...
bom, fiz a brincadeira toda agora de manhã e acredito que faltaram alguns pacotes http://imgur.com/U0cHKjH http://imgur.com/9ftLrPE http://imgur.com/tDaNlM5
não sei se devia ter seguido, pensei em abrir o gerenciador de aplicativos e procurar esses que faltaram, mas enfim, dei continuidade e de tanto em tanto acusava algum erro por falta de pacotes,
dá pra pegar um por um daquela lista e procurar no gerenciador de aplicativos? se eu fizer isso tenho que começar do zero o procedimento todo?



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts