Problemas com GEM no Fedora [RESOLVIDO]

1. Problemas com GEM no Fedora [RESOLVIDO]

Paulo Henrique Santiago Goes
lordwadder

(usa Fedora)

Enviado em 29/05/2011 - 18:02h

Recentemente eu mudei do Ubuntu pro Fedora 15 e instalei o Ruby 1.9.2 compilando-o. Tudo funfa legal, exceto pelo rubygems. Só consigo atualizar ou instalar uma gem usando o comando:

# /usr/local/bin/gem install <nome_da_gem>

Já chequei a variável env e o PATH procura por binários na pasta /usr/local/bin.

Alguém faz idéai do que está havendo?



  


2. Re: Problemas com GEM no Fedora [RESOLVIDO]

PotHix
PotHix

(usa Arch Linux)

Enviado em 29/05/2011 - 22:33h

Æ!!

Recomento você a usar o RVM (https://rvm.beginrescueend.com/) e ele cuida dos PATHs para você ;)

Há braços


3. Re: Problemas com GEM no Fedora [RESOLVIDO]

Elder Marco
eldermarco

(usa Fedora)

Enviado em 29/05/2011 - 22:38h

Sim, a princípio deveria funcionar sem problemas, se o /usr/local/bin estiver mesmo no PATH. O binário parece estar com permissão de execução e tudo mais.

Seja como for, te dou a dica de desinstalar ele e instalar através do yum que é melhor:

# yum install rubygems

Não é muita vantagem instalar pacotes a partir dos fontes, visto que existem detalhes que se precisa cuidar logo após a instalação e não dar apenas um make install após a compilação, embora alguns pacotes sejam apenas isso. Os softwares empacotados cuidam dessa parte pra você e ainda terá um gerenciamento de software mais completo em sua máquina.

Caso insista mesmo assim, poste aqui o erro que aparece, se aparece. E se o gem está aparecendo como opção quando você tenta dar um 'gem' pelo terminal.


4. Re: Problemas com GEM no Fedora [RESOLVIDO]

Paulo Henrique Santiago Goes
lordwadder

(usa Fedora)

Enviado em 30/05/2011 - 08:43h

ElderMarco, valeu a dica, meu irmão mas o maior problema é que os repositórios do Fedora, RPMFusion e outros não possuem Ruby 1.9.2 empacotado. Eu resolvi o problema simplesmente fazendo um link simbólico para /usr/bin/gem aí funfou legal. Vai entender...

PotHix, eu uso muito ferramentas gráficas com FXRuby, WXRuby e Glade3. Será que o RVM pode cuidar das dependências (wxBase, libfox) e de seus paths pra que eu possa trabalhar da mesma forma? Minha experiência com o RVM no Ubuntu foi decepcionante nesse ponto. Shoes também não funfou legal usando o ruby1.8 do RVM. Se puder me ajudar com isso, eu dou um make uninstall e um make clean agora na pasta do Ruby.

Valeu a ajuda, galera...


5. Re: Problemas com GEM no Fedora [RESOLVIDO]

PotHix
PotHix

(usa Arch Linux)

Enviado em 30/05/2011 - 10:15h

Æ!!

Cara, eu uso RVM na minha maquina de desenvolvimento desde que ele foi lançado, e nunca tive problemas.
Das ferramentas que você citou eu só usei o shoes, e foi bem tranquilo.

Você quem sabe, eu uso e funciona bem :)

Há braços






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts