Instalação de Rubygems

1. Instalação de Rubygems

Yuri Stavale
Stavale_

(usa openSUSE)

Enviado em 26/07/2011 - 10:05h

Senhores, bom dia.

Estou atualizando o Redmine de um servidor Ubuntu, porém houve alguns erros de gems corrompidas, nesse caso refiz toda a instalação.

Consegui realizá-la normalmente, porém ao dar um # gem update --system, ele retorna o erro HTTP Response 302, ou seja, movido temporariamente.

Alguma idéia do que posso fazer? Já li até fóruns em frânces, porém nada tão específico para essa solução.

Abaixo segue algumas informações:



root@server:~# gem env
RubyGems Environment:
- RUBYGEMS VERSION: 1.1.1
- RUBY VERSION: 1.8.6 (2007-03-13 patchlevel 0) [x86_64-linux]
- INSTALLATION DIRECTORY: /usr/local/lib/ruby/gems/1.8
- RUBY EXECUTABLE: /usr/local/bin/ruby
- RUBYGEMS PLATFORMS:
- ruby
- x86_64-linux
- GEM PATHS:
- /usr/local/lib/ruby/gems/1.8
- GEM CONFIGURATION:
- :update_sources => true
- :verbose => true
- :benchmark => false
- :backtrace => false
- :bulk_threshold => 1000
- :sources => ["http://rubygems.org"]
- REMOTE SOURCES:
- http://rubygems.org



---

root@server:~# ruby -v
ruby 1.8.6 (2007-03-13 patchlevel 0) [x86_64-linux]

---

root@server:~# gem list

*** LOCAL GEMS ***

---


Ficarei MUITO agradecido se alguém puder ajudar.
Obrigado.


  


2. Re: Instalação de Rubygems

PotHix
PotHix

(usa Arch Linux)

Enviado em 26/07/2011 - 11:01h

Æ!!

Se possível use 1.9. Ta bem melhor que 1.8.

Mas de qualquer forma, tenta um gem sources -a "http://gemcutter.org"

Há braços


3. Re: Instalação de Rubygems

Yuri Stavale
Stavale_

(usa openSUSE)

Enviado em 26/07/2011 - 11:05h

E ae cara, obrigado pela resposta.

Então, infelizmente não posso usar a versão 1.9, pq o Redmine 1.2.x tem algumas especificações:
- Ruby 1.8.6 ou 1.8.7
- Rails 2.3.11
- Rack 1.1.1

Mas segue a saída do comando que você passou:

root@server:~# gem sources -a "http://gemcutter.org"
ERROR: While executing gem ... (Gem::RemoteSourceException)
HTTP Response 302 fetching http://gemcutter.org/yaml


Alguma idéia?


4. Re: Instalação de Rubygems

PotHix
PotHix

(usa Arch Linux)

Enviado em 26/07/2011 - 11:08h

Æ!!

Tem algum proxy ou coisa parecida.
Vc chega normal nos lugares? Já fez um wget e tentou um telnet em outros sites (e no próprio rubygems/gemcutter)?

Há braços


5. Re: Instalação de Rubygems

Yuri Stavale
Stavale_

(usa openSUSE)

Enviado em 26/07/2011 - 11:11h

Sim, estou no trabalho e utilizamos proxy.

Já fiz um export http e ftp etc.

Wget normal, inclusive baixei o Ruby e o Rubygems por wget.


6. Re: Instalação de Rubygems

Yuri Stavale
Stavale_

(usa openSUSE)

Enviado em 27/07/2011 - 11:22h

Ninguém?






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts