qual IP utilizar? [RESOLVIDO]

1. qual IP utilizar? [RESOLVIDO]

Vinícius Pedra
viniciuspedra

(usa Debian)

Enviado em 11/01/2009 - 02:47h

bom dia pessoal!!!
estou montando uma rede aqui para mim em que eu possuo um modem roteador, um servidor linux com o debian , squid e proxy configurado e um access point que irá liberar sinal para os clientes que chegarem até aqui!

O que está acontecendo é o seguinte... eu não estou conseguindo fazer com que o micro que for conectar via wireless funcione...
em http://webstyle.com.br/Rede.jpg coloquei uma imagem explicando os IPs e td mais.
Lembrando que se eu ligar meu notebook no lugar do Access Point e setar o mesmo IP, o acesso a internet é feito normalmente, mas tenho que setar o proxy no navegador.

Então mais uma vez. O que ocorre, é que eu não sei que IP colocar na interface LAN (Wireless) para que o Access Point sete o IP e as demais configurações da máquina.
Usarei o proxy tmb no navegador?

Espero ter sido claro e conto muito com a ajuda de vcs... só falta isso para a rede funcionar!! Abs a todos!


  


2. configuração

Carlos Eduardo Fraga Ribeiro
eduardofraga

(usa Debian)

Enviado em 11/01/2009 - 10:22h

Segundo o exemplo que você passou, sugiro que faça o seguinte:

1) Desative o serviço DHCP do Access Point, caso esteja ativado;
2) Instale o dhcpd-server utilizando o apt-get;
3) Edite o arquivo /etc/dhcpd/dhcpd.conf (dentro deste arquivo já vai ter uns exemplos de como configurar a rede)

Você deve alterar as configurações de:
Faixa de endereços
Mascara
Gateway
DNS


Com relação ao proxy, você tem que configurar o navegador manualmente em cada máquina na rede, ou então você deve configurar como "proxy transparente", neste caso você não conseguirá autenticar os usuários que estão utilizando o proxy.





3. Olá!

Jeffeson Luiz Oliveira de Campos
foguinho.peruca

(usa Ubuntu)

Enviado em 11/01/2009 - 10:28h

Bom,

Instele o DHCP-server no seu server Debian que o resto resolve....

Jeff


4. Re: qual IP utilizar? [RESOLVIDO]

Vinícius Pedra
viniciuspedra

(usa Debian)

Enviado em 11/01/2009 - 22:53h

bah gurizada valeu pelas dicas... a rede já está funcionando...
peguei e desabilitei o dhcp do AP e mudei ele para bridge, agora por segunrança da rede, setei os ips de cada um manualmente e irei colocar na regra para que se eles mudem o ip, ao não irão navegar... passei o dia inteiro setando ip de cliente mas valeu a pena...
estou gostando mto do empenho de tds em me ajudar! valeu mesmo!!!!


5. Re: qual IP utilizar? [RESOLVIDO]

Vinícius Pedra
viniciuspedra

(usa Debian)

Enviado em 11/01/2009 - 22:56h

só para complementar...
na lan que estava faltando o ip, coloquei o seguinte:

Rede Lan
IP 192.168.0.3
Mas 255.255.255.0
Gat. 192.168.0.1
DNS 192.168.254.254

ai no navegador setei o proxy... ficou tudo na mesma faixa de ip e todos enchergam o servidor, mto bom mesmo.
Mas isso só foi possivel devido ao AP estar em bridge....
abs!!!!


6. Re: qual IP utilizar? [RESOLVIDO]

Marcos Roberto Wencelevski
ursynho

(usa Debian)

Enviado em 18/01/2009 - 20:27h

cara estou com a mesma dificuldade que voce teve.. ate coloquei um topico pra mim ser respondido..
seguinte..
como voce colocou seu AP em bridge.. tenho um AP linksys wrt54gs e nao achei essa opcao..
ele soh fica como router tenho ip linux eth1 192.168.0.50 quando mando pro ap.. ele recebe tudo certinho e funciona o squid.. o AP tem ip 192.168.1.1 quando mudo ele pra 192.168.0.51 nao funciona mais nada.. jah desativei dhcp dele e coloquei ip fixo nas maquinas tbm nao roda.. o proxy é transparente.. quando volto pro ip 1.1 ele roda tudo normal porem as diretivas de liberar acesso msn por ip e internet livre por mac nao funciona nada.. bloqueia tudo..
caso poder me dar uma ideia ai de como proceder.. fico no aguardo.
valeu