Zabbix-Server não roda [RESOLVIDO]

1. Zabbix-Server não roda [RESOLVIDO]

Ricardo Augusto de Carvalho
cadinhocarvalho

(usa Ubuntu)

Enviado em 19/05/2011 - 11:26h

Olá pessoal!

Instalei o Zabbix na rede aqui da empresa, primeiramente para testes. Configurei tudo, seguindo o tutorial, mas o zabbix-server simplesmente não executa. Quando abro a interface web, aparece Zabbix is running = NO. Quando vejo no htop, somente o zabbix-agentd está rodando. Quando tento iniciar manualmente o zabbix-server, aparece: No /usr/local/sbin/zabbix_server found running; none killed. Não sei o que fazer.

Como é um ambiente de testes, estou usando o Ubuntu Server. Futuramente devo migrar pra um Debian.


  


2. MELHOR RESPOSTA

brunotec
brunotec

(usa Debian)

Enviado em 19/05/2011 - 11:52h

se vc instalou ele compilando acho que sei qual é o problema:

No /usr/local/sbin/zabbix_server

o script de inicialização do zabbix server depois de compilado se não me engano fica em: /usr/local/zabbix/sbin/zabbix_server

rode esse comando e veja se ele roda:

#/usr/local/zabbix/sbin/zabbix_server

caso não use o locate para procurar o script:

#updatedb
#locate zabbix_server


um abraço.

3. Re: Zabbix-Server não roda [RESOLVIDO]

Ricardo Augusto de Carvalho
cadinhocarvalho

(usa Ubuntu)

Enviado em 19/05/2011 - 12:59h

Eu encontrei o arquivo nesse endereço: /usr/local/sbin/zabbix_server. Eu executei mas nada ocorreu. Verifiquei se estava rodando alguma coisa e vi que estava. O problema foi solucionado.

Muito obrigado pela ajuda!!!!

Abração!


4. Zabbix nao roda

Romulo Rocha da Silva
romulorocha

(usa Ubuntu)

Enviado em 28/10/2011 - 11:17h

Bom dia canadinho, estou com o mesmo problema, o meu zabbix 1.8.8 esta marcado que nao esta rodando, ja chequei varios parametros, como voce resolver o seu caso, sou novo em zabbix.

1 editor /etc/zabbix/zabbix_server.conf
esta configurado corretamento.

2 O serviço esta dentro do /etc/init.d

[email protected]:/etc/init.d# cat zabbix-server
#! /bin/sh
#
# Zabbix daemon start/stop script.
#
# Written by Alexei Vladishev <[email protected]>.

NAME=zabbix_server
DAEMON=/usr/sbin/${NAME} ##### alterado conforme literatura estudada.
DESC="Zabbix server daemon"
PID=/tmp/$NAME.pid

test -f $DAEMON || exit 0

case "$1" in
start)
echo "Starting $DESC: $NAME"
start-stop-daemon --oknodo --start --pidfile $PID \
--exec $DAEMON
;;
stop)
echo "Stopping $DESC: $NAME"
start-stop-daemon --oknodo --stop --pidfile $PID \
--exec $DAEMON
;;
restart|force-reload)
$0 stop
$0 start
;;
*)
N=/etc/init.d/$NAME
echo "Usage: $N {start|stop|restart|force-reload}" >&2
exit 1
;;
esac

3 Quando executo os processos:

[email protected]:/etc/init.d# ps -aux |grep zabbix
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
zabbix 858 0.0 0.0 6348 864 ? SN 10:41 0:00 /usr/sbin/zabbix_agentd
zabbix 859 0.0 0.0 6348 956 ? SN 10:41 0:00 /usr/sbin/zabbix_agentd
zabbix 860 0.0 0.0 6348 532 ? SN 10:41 0:00 /usr/sbin/zabbix_agentd
zabbix 861 0.0 0.0 6348 532 ? SN 10:41 0:00 /usr/sbin/zabbix_agentd
zabbix 862 0.0 0.0 6348 532 ? SN 10:41 0:00 /usr/sbin/zabbix_agentd
zabbix 863 0.0 0.0 6348 776 ? SN 10:41 0:00 /usr/sbin/zabbix_agentd
root 1666 0.0 0.0 4188 824 pts/0 D+ 11:11 0:00 grep --color=auto zabbix
[email protected]:/etc/init.d#

Existe somente o Zabbix_agentd.

4 Subindo os servicos

[email protected]:/etc/init.d# sudo /etc/init.d/zabbix-agent start
Starting Zabbix agent daemon: zabbix_agentd
/usr/sbin/zabbix_agentd already running.
[email protected]:/etc/init.d# sudo /etc/init.d/zabbix-server start
Starting Zabbix server daemon: zabbix_server
[email protected]:/etc/init.d#


Se vcoce puder me ajudar.ficaria muito grato.

Obrigado

Romulo Rocha
msn: [email protected]
skype romulo.silva



5. Re: Zabbix-Server não roda [RESOLVIDO]

Ricardo Augusto de Carvalho
cadinhocarvalho

(usa Ubuntu)

Enviado em 28/10/2011 - 11:46h

romulorocha,

Execute o seguinte comando:

/usr/local/sbin/zabbix_server

Agora verifique se ele está rodando ou não.


6. Zabbix-Server não roda

Romulo Rocha da Silva
romulorocha

(usa Ubuntu)

Enviado em 28/10/2011 - 12:15h

[email protected]:~# /usr/local/sbin/zabbix_server
-bash: /usr/local/sbin/zabbix_server: Arquivo ou diretório não encontrado
[email protected]:~#

Acho que nao esta rodando.

Obrigado


7. Re: Zabbix-Server não roda [RESOLVIDO]

Ricardo Augusto de Carvalho
cadinhocarvalho

(usa Ubuntu)

Enviado em 28/10/2011 - 13:54h

romulorocha,

O arquivo zabbix_server, que fica no sbin, pode mudar de local a depender da distribuição. Se não encontrou, tente localizar o script. Se for Ubuntu ou Debian, é o local que te falei.

Caso o script realmente não esteja na máquina, considere reinstalar o Zabbix. Você pode fazer isso dentro do próprio Zabbix. Eu tenho um guia de instalação, que foi o que eu segui pra instalar o meu aqui. Se quiser, posso te passar.


8. Zabbix-Server nao Roda

Romulo Rocha da Silva
romulorocha

(usa Ubuntu)

Enviado em 28/10/2011 - 16:41h

Boa tarde,

Observer que existe o zabbix_server dentro do /usr e dentro do /etc.

[email protected]:~# find /usr |grep zabbix_server
/usr/sbin/zabbix_server
/usr/share/man/man8/zabbix_server.8.gz
/usr/share/zabbix-server-mysql/zabbix_server.conf

[email protected]:~# find /etc |grep zabbix_server
/etc/zabbix/zabbix_server.conf
/etc/zabbix/zabbix_server.conf.ucf-old
[email protected]:~#

se nao for estes teria como vc me enviar por e-mail ou skype

e-mail msn: [email protected] e skype: romulo.silva

obrigado


9. Zabbix-Server não roda

Romulo Rocha da Silva
romulorocha

(usa Ubuntu)

Enviado em 28/10/2011 - 17:41h

Boa tarde, Acabei de pegar um erro no log, será que é isso:

o que devo fazer:

zabbix_server [1089]: Cannot create PID file [/var/run/zabbix-server/zabbix_server.pid] [No such file or directory]
zabbix_server [1089]: ERROR: Cannot create PID file [/var/run/zabbix-server/zabbix_server.pid] [No such file or directory]
zabbix_server [1093]: Cannot create PID file [/var/run/zabbix-server/zabbix_server.pid] [No such file or directory]
zabbix_server [1093]: ERROR: Cannot create PID file [/var/run/zabbix-server/zabbix_server.pid] [No such file or directory]
zabbix_server [1133]: Cannot create PID file [/var/run/zabbix-server/zabbix_server.pid] [No such file or directory]
zabbix_server [1133]: ERROR: Cannot create PID file [/var/run/zabbix-server/zabbix_server.pid] [No such file or directory]
zabbix_server [1150]: Cannot create PID file [/var/run/zabbix-server/zabbix_server.pid] [No such file or directory]
zabbix_server [1150]: ERROR: Cannot create PID file [/var/run/zabbix-server/zabbix_server.pid] [No such file or directory]
zabbix_server [863]: Cannot create PID file [/var/run/zabbix-server/zabbix_server.pid] [No such file or directory]
zabbix_server [863]: ERROR: Cannot create PID file [/var/run/zabbix-server/zabbix_server.pid] [No such file or directory]
[email protected]:/var/log/zabbix-server# ^C


obrigado.


10. Zabbix-Server não roda [RESOLVIDO]

Romulo Rocha da Silva
romulorocha

(usa Ubuntu)

Enviado em 28/10/2011 - 18:14h

Observer que eu dei um ps -aux no zabbix-server e parece que ele esta rodando sim. olhe ai..

ou eu estou enganado.


obrigado.

[email protected]:/var/log/zabbix-server# ps -aux |grep zabbix-server
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
root 1117 0.0 0.0 4188 832 pts/0 D+ 18:11 0:00 grep --color=auto zabbix-server
[email protected]:/var/log/zabbix-server#


depois dei um somente com zabbix

[email protected]:/var/log/zabbix-server# ps -aux |grep zabbix-server
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
root 1123 0.0 0.0 4208 836 pts/0 S+ 18:13 0:00 grep --color=auto zabbix-server
[email protected]:/var/log/zabbix-server# ps -aux |grep zabbix
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
zabbix 774 0.0 0.0 6348 868 ? SN 17:58 0:00 /usr/local/sbin/zabbix_agentd
zabbix 775 0.0 0.0 6348 960 ? SN 17:58 0:00 /usr/local/sbin/zabbix_agentd
zabbix 777 0.0 0.0 6348 536 ? SN 17:58 0:00 /usr/local/sbin/zabbix_agentd
zabbix 778 0.0 0.0 6348 536 ? SN 17:58 0:00 /usr/local/sbin/zabbix_agentd
zabbix 779 0.0 0.0 6348 536 ? SN 17:58 0:00 /usr/local/sbin/zabbix_agentd
zabbix 780 0.0 0.0 6348 780 ? SN 17:58 0:00 /usr/local/sbin/zabbix_agentd
root 1125 0.0 0.0 4208 824 pts/0 S+ 18:13 0:00 grep --color=auto zabbix
[email protected]:/var/log/zabbix-server#


extranho.


11. ABBIX-SERVER NÃO RODA [RESOLVIDO]

Luckas Moreno Rodrigues dos Santos
luckasmoreno

(usa Debian)

Enviado em 11/04/2016 - 11:04h

Cara, aconteceu isso comigo também.
Ao analisar constatei que tinham algumas linhas duplicadas no arquivo zabbix_server.conf que em minha distribuição fica localizado em: usr/local/etc/zabbix_server.conf

Por exemplo:

Tinha uma linha no começo e outra no meio do arquivo com o seguinte conteúdo:
LogFile=/tmp/zabbix_server.log
LogFileSize=2

Isso ocorreu no copiar e colar de um tutorial que utilizei como referência.

Após comentar as linhas duplicadas, o serviço iniciou de forma correta.