Srv não pinga na internet. [RESOLVIDO]

1. Srv não pinga na internet. [RESOLVIDO]

Rafael Victor de Almeida Schiavo
Rafael.Schiavo

(usa Ubuntu)

Enviado em 27/09/2013 - 15:40h

Olá,
Acabei de instalar CentOS 6.3 e a internet é GVT.
Porém não consigo pingar nenhum site, este srv só pinga nele mesmo.

Alguém pode me dar uma dica.

Abraços.


  


2. Re: Srv não pinga na internet. [RESOLVIDO]

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 27/09/2013 - 15:44h

verificou se não é dns ?
mas não ping a internet ? como assim
de mais detalhes do seu problema



3. Re: Srv não pinga na internet. [RESOLVIDO]

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 27/09/2013 - 15:44h

verificou se a interface de rede esta ok com ip e tal ?



4. Re: Srv não pinga na internet. [RESOLVIDO]

Rafael Victor de Almeida Schiavo
Rafael.Schiavo

(usa Ubuntu)

Enviado em 27/09/2013 - 15:55h

danniel-lara escreveu:

verificou se a interface de rede esta ok com ip e tal ?


Boa tarde Daniel,
Neste momento minha conexão com a gvt é dhcp, não tenho ip fixo.

Outros computadores eu só conectei e a internet já funcionou...

Abraços.




5. Re: Srv não pinga na internet. [RESOLVIDO]

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 27/09/2013 - 15:57h

ja verificou os dns ,
verifica se o centos , pegou a mesma faixa tudo certo e tal
verifica as rotas




6. Re: Srv não pinga na internet. [RESOLVIDO]

Rafael Victor de Almeida Schiavo
Rafael.Schiavo

(usa Ubuntu)

Enviado em 27/09/2013 - 16:16h

danniel-lara escreveu:

ja verificou os dns ,
verifica se o centos , pegou a mesma faixa tudo certo e tal
verifica as rotas



Então Daniel,

Visto que o meu provedor não me forneceu nenhum ip fixo, o meu arquivo /etc/resolv.conf não contém nenhuma referencia a nenhum dns.
O comando Route não retorna nenhuma rota.

Usando a mesma conexão de internet, veja a diferença nos ifconfig deste srv e de um micro que funciona.

Servidor que não acessa a internet.
Ifconfig eth0
link encap:Ethernet Endereço de HW F8:1A:67:02:C3:D5
BROADCASTMULTICAST MTU:1500 Métrica:1
Rx packets:0 errors:0 dropped:0 overruns:0 frame:0
Tc packets:0 errors:0 dropped:0 overrruns:0 carrier:0
colisões:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
IRQ:29

Notebook que acessa a internet:
ifconfig eth0
Link encap:Ethernet Endereço de HW 44:87:fc:21:20:77
inet end.: 192.168.25.14 Bcast:192.168.25.255 Masc:255.255.255.0
endereço inet6: fe80::4687:fcff:fe21:2077/64 Escopo:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Métrica:1
pacotes RX:1972 erros:0 descartados:0 excesso:0 quadro:0
Pacotes TX:1881 erros:0 descartados:0 excesso:0 portadora:0
colisões:0 txqueuelen:1000
RX bytes:1626472 (1.6 MB) TX bytes:300564 (300.5 KB)



7. Re: Srv não pinga na internet. [RESOLVIDO]

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 27/09/2013 - 16:19h

então coloca os dns no /etc/resolv.conf
e adiciona a rota default
que vai funcinar não tem erro


add dns
# echo "nameserver 8.8.8.8" >> /etc/resolv.conf
# echo "nameserver 8.8.4.4" >> /etc/resolv.conf


add gateway


# route add default gw 192.168.25.1


bom eu acredito que se 192.168.25.1 o gateway


8. Re: Srv não pinga na internet. [RESOLVIDO]

Rafael Victor de Almeida Schiavo
Rafael.Schiavo

(usa Ubuntu)

Enviado em 27/09/2013 - 16:27h

Consegui usando o comando dhclient eth0

Muito Obrigado.


9. Re: Srv não pinga na internet. [RESOLVIDO]

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 27/09/2013 - 16:36h

Rafael.Schiavo escreveu:

Consegui usando o comando dhclient eth0

Muito Obrigado.


ok qualquer dúvida estamos ai


10. Re: Srv não pinga na internet. [RESOLVIDO]

Rafael Victor de Almeida Schiavo
Rafael.Schiavo

(usa Ubuntu)

Enviado em 27/09/2013 - 16:37h

Rafael.Schiavo escreveu:

Consegui usando o comando dhclient eth0

Muito Obrigado.




rsrsrssss,

Porém reiniciei o server e o problema voltou...
Como eu coloco o dhclient eth0 na inicialização, alguém sabe.

A respeito dos dns do google eu já havia colocado, mas continuou na mesma.

Obrigado.


11. Re: Srv não pinga na internet. [RESOLVIDO]

Allan Paes Porto
sk4d1nh4

(usa Gentoo)

Enviado em 27/09/2013 - 16:45h

O arquivo /etc/sysconfig/network-scripts/ifcfg-eth0 tem que conter as seguintes linhas:

DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes

Espero que ajude. abraço!


12. Re: Srv não pinga na internet. [RESOLVIDO]

Rafael Victor de Almeida Schiavo
Rafael.Schiavo

(usa Ubuntu)

Enviado em 27/09/2013 - 16:46h

Rafael.Schiavo escreveu:

Rafael.Schiavo escreveu:

Consegui usando o comando dhclient eth0

Muito Obrigado.




rsrsrssss,

Porém reiniciei o server e o problema voltou...
Como eu coloco o dhclient eth0 na inicialização, alguém sabe.

A respeito dos dns do google eu já havia colocado, mas continuou na mesma.

Obrigado.



Resolvi colocando o comando em /etc/rc.d/rc.local.

Muito Obrigado.

.



01 02