SAMBA + DOSEMU + CLIPPER

1. SAMBA + DOSEMU + CLIPPER

Thiago Peluque
peluque

(usa Ubuntu)

Enviado em 17/02/2009 - 10:50h

e ai rapaziada, vo meio que direto no assunto, tenho dois grandes problemas, que me tiram o sono:

1 - coloquei um sistema em clipper num servidor linux com Ubuntu 8.10 Server, até ai tudu bem, o sistema roda legal nos terminais windows, mais o bendito sistema, precisa gerar um arquivo .TXT por causa da Nota Fiscal Paulista, (foi adaptado pra isso), quando o servidor é windows e os temrinais tbm, gera o arquivo em cerca de 5 à 10 segundos, no SAMBA com terminais Windows demora 1, 2 minutos, e não pode demorar tanto, pois é feito no ato da compra e o cliente não pode esperar

2 - meu segundo problema, é o seguinte, quando coloca terminais linux, preciso montar via SMBMOUNT com o comando "SMBMOUNT //192.168.x.x/sistema /mnt/sistema -o user=xxxxx,pass=xxxxx", monta normal mais quando vou usar, pra pelo menos fazer um teste no DOSEMU, ele abre e fecha bem rápido, não me dá nenhum erro

meu smb.conf:

###### Global Settings #######

[global]

workgroup = CPINTURA
socket options = TCP_NODELAY
netbios name = Servidor
server string = Servidor
; invalid users = root
encrypt passwords = yes
passdb backend = tdbsam
obey pam restrictions = yes
unix password sync = yes
; map to guest = bad user
oplocks = Yes
kernel oplocks = No
lock spin time = 25
level2 oplocks = No

read raw = Yes
write raw = Yes
max xmit = 65535
dead time = 15
getwd cache = Yes

####### Authentication #######

security = share
guest account = pavan

##### Compartilhamentos ######

[Sistema]
comment = Sistemas Pavan Tintas
path = /home/sistema
browseable = yes
writable = yes
public = yes
create mask = 0777
directory mask = 0777
force create mode = 0777
force directory mode = 0777
veto oplock files =/*.dbf/*.DBF/*.ntx/*.NTX/*.sgi/*.SGI/*.inx/*.INX/*.tmp/*.TMP
dos filemode = yes

espero que vocês possam nos ajudar
valeu galera

quando conseguirmos resolver, gostariamos de divulgar tudo que foi feito com ajuda de todos, pois com certeza alguém mais tem esse mesmo problema