Problema no dns ou na rede?

1. Problema no dns ou na rede?

Eder
ederpaulopereira

(usa CentOS)

Enviado em 30/06/2014 - 15:39h

Boa tarde pessoal;

Já estou perdendo os cabelos aqui, é o seguinte. Desde quarta-feira passada (eu estava de férias, voltei na sexta), a empresa está com dificuldades de acessar o webmail. Este webmail, está hospedado na locaweb, após vários testes, o problema não é lá, e sim aqui na minha rede interna. Tem mais ou menos uns 70 computadores, 95% deles rodando linux ubuntu. Não tem jeito, o webmail.locaweb.com.br as vezes abre, as vezes não abre, dá timeout. Fiz de tudo, inclusive, tirei o meu proxy da rede, deixei direto no modem, mesmo assim, sem muito sucesso. Capturei hoje pela manhã uns pacotes com o wireshark, vi que tem muitas requisições para o mDNS, fui atrás da RFC dele, pelo que vi ele é responsável pelo zeroconf no linux (usa o daemon do avahi), e fiquei pensando que poderia ser ele, já que 95% da rede tem o ubuntu, e vem nele por padrão. Para navegar em outros sites, funciona na boa, mas no webmail, não vai. Mas se eu tento de minha casa, aí acessa na boa tbm. Alguém tem alguma idéia?

at;

Eder


  


2. Re: Problema no dns ou na rede?

Carlos Alberto Mazzer
cmazzer

(usa Ubuntu)

Enviado em 01/07/2014 - 10:29h

Pode ser DNS sim.
Você utiliza um dns interno ou externo ? tente em uma máquina trocar o DNS para um provedor diferente e faça os testes.


3. Re: Problema no dns ou na rede?

Eder
ederpaulopereira

(usa CentOS)

Enviado em 01/07/2014 - 11:07h

Utilizo dns externo, normalmente da oi, 8.8.8.8 ou opendns, mas em todos o problema persiste.

cmazzer escreveu:

Pode ser DNS sim.
Você utiliza um dns interno ou externo ? tente em uma máquina trocar o DNS para um provedor diferente e faça os testes.





4. Re: Problema no dns ou na rede?

Edimar
dimasdaros

(usa Arch Linux)

Enviado em 01/07/2014 - 13:31h

Mas nesse período que você não consegue acessar, você consegue pingar o endereço?
Assim vamos ver se é do DNS ou não.
Quando estão passando direto pelo modem, tira o proxy também? Ou deixa como gw o modem mas navegação passando pelo proxy?


5. Re: Problema no dns ou na rede?

Eder
ederpaulopereira

(usa CentOS)

Enviado em 01/07/2014 - 15:12h

Consigo pingar normalmente, tanto pelo ip quanto pelo nome. Estou direto no modem, o proxy está desligado. Olha só o resultado do ping, começou a aparecer um DUP!:

64 bytes from maggie0007.email.locaweb.com.br (186.202.51.16): icmp_req=1 ttl=48 time=56.2 ms (DUP!)

Será mesmo que é aqui o problema? Meu modem? Há algum serviço no ubuntu que devo parar? Pq como eu disse, alguns computadores conseguem, outros não.

Obrigado;

Eder




dimasdaros escreveu:

Mas nesse período que você não consegue acessar, você consegue pingar o endereço?
Assim vamos ver se é do DNS ou não.
Quando estão passando direto pelo modem, tira o proxy também? Ou deixa como gw o modem mas navegação passando pelo proxy?





6. Re: Problema no dns ou na rede?

Eder
ederpaulopereira

(usa CentOS)

Enviado em 01/07/2014 - 15:28h

ederpaulopereira escreveu:

Consigo pingar normalmente, tanto pelo ip quanto pelo nome. Estou direto no modem, o proxy está desligado. Olha só o resultado do ping, começou a aparecer um DUP!:

64 bytes from maggie0007.email.locaweb.com.br (186.202.51.16): icmp_req=1 ttl=48 time=56.2 ms (DUP!)

**Achei o problema, era a porta do switch que mandei espelhar pra minha pra poder monitorar o tráfego com o wireshark, desfiz isso e parou de dar problema com o DUP!, mas ainda com problema no webmail, aff.**

Será mesmo que é aqui o problema? Meu modem? Há algum serviço no ubuntu que devo parar? Pq como eu disse, alguns computadores conseguem, outros não.

Obrigado;

Eder




dimasdaros escreveu:

Mas nesse período que você não consegue acessar, você consegue pingar o endereço?
Assim vamos ver se é do DNS ou não.
Quando estão passando direto pelo modem, tira o proxy também? Ou deixa como gw o modem mas navegação passando pelo proxy?







7. Re: Problema no dns ou na rede?

Buckminster
Buckminster

(usa Debian)

Enviado em 01/07/2014 - 16:39h

DUP

Do man do ping:

"Duplicate and Damaged Packets

ping will report duplicate and damaged packets. Duplicate packets should never occur, and seem to be caused by inappropriate link-level retransmissions. Duplicates may occur in many situations and are rarely (if ever) a good sign, although the presence of low levels of duplicates may not always be cause for alarm.

Damaged packets are obviously serious cause for alarm and often indicate broken hardware somewhere in the ping packet's path (in the network or in the hosts)."

"Pacotes duplicados e danificados
O ping irá relatar pacotes duplicados e pacotes danificados. A duplicação de pacotes nunca deve ocorrer e parece ser causada por retransmissões inadequadas do link. Duplicatas podem ocorrer em muitas situações e são raramente (ou nunca) um bom sinal, embora a presença de níveis baixos de duplicatas pode não ser sempre motivo para alarme.
Pacotes danificados são obviamente sério motivo de alarme e muitas vezes indicam hardware quebrado em algum lugar no caminho do pacote do ping (na rede ou nos hosts)."


Isso significa que o pacote de resposta é uma duplicata. Cada pacote ICMP enviado para um host tem um número de seqüência que é retornado com a resposta.
A duplicação de pacotes significa que a rede está defeituosa.

Verifique as configurações do teu modem/roteador.
Verifique também o cabeamento e se não tem alguma placa de rede funcionando em modo promíscuo.


8. Re: Problema no dns ou na rede?

Eder
ederpaulopereira

(usa CentOS)

Enviado em 02/07/2014 - 11:13h

Quanto aos pacotes duplicados, já havia achado o problema, estava espelhando a porta do modem para meu computador, com o port mirror do switch, desfiz e parou de dar problema com isso.


9. Re: Problema no dns ou na rede?

Buckminster
Buckminster

(usa Debian)

Enviado em 03/07/2014 - 00:55h

ederpaulopereira escreveu:

Quanto aos pacotes duplicados, já havia achado o problema, estava espelhando a porta do modem para meu computador, com o port mirror do switch, desfiz e parou de dar problema com isso.


Bom, se o problema acontece em algumas máquinas e outras não, então o problema provavelmente não é no Ubuntu.

Nas máquinas que não acessam, tu consegue acessar o webmail através do IP do servidor (em vez de www.webmail.dominio... digitando xxx.xxx.xxx...)?


10. Re: Problema no dns ou na rede?

Eder
ederpaulopereira

(usa CentOS)

Enviado em 03/07/2014 - 09:40h

Nas máquinas que não acessam, nem pelo ip não vai. Muito estranho. Peguei um pc velho aqui com 2 placas de rede, coloquei um endian firewall nele, e estou fazendo uns testes, a princípio tá funcionando, muito estranho. Ativei o snort e clamav, vamos ver o que eu acho de errado.

Buckminster escreveu:

ederpaulopereira escreveu:

Quanto aos pacotes duplicados, já havia achado o problema, estava espelhando a porta do modem para meu computador, com o port mirror do switch, desfiz e parou de dar problema com isso.


Bom, se o problema acontece em algumas máquinas e outras não, então o problema provavelmente não é no Ubuntu.

Nas máquinas que não acessam, tu consegue acessar o webmail através do IP do servidor (em vez de www.webmail.dominio... digitando xxx.xxx.xxx...)?





11. Re: Problema no dns ou na rede?

Buckminster
Buckminster

(usa Debian)

Enviado em 03/07/2014 - 16:49h

"Fiz de tudo, inclusive, tirei o meu proxy da rede, deixei direto no modem, mesmo assim, sem muito sucesso."

E se nem pelo IP do webmail não vai então provavelmente não é DNS.

Verifique as configurações do modem/roteador.

A título de curiosidade, o mDNS utliza a porta 5353 do UDP.


12. Re: Problema no dns ou na rede?

Eder
ederpaulopereira

(usa CentOS)

Enviado em 03/07/2014 - 16:52h

Buckminster, fiz um espelho da porta do switch onde está o modem para a minha máquina, e deixei o wireshark rodando, tem muito pacote de mdns, é normal isso? Li que o mdns é para autoconfigurar alguns serviços, que não tenha dns próprio na rede e tal, mas não suspeito o que pode ser.


Buckminster escreveu:

"Fiz de tudo, inclusive, tirei o meu proxy da rede, deixei direto no modem, mesmo assim, sem muito sucesso."

E se nem pelo IP do webmail não vai então provavelmente não é DNS.

Verifique as configurações do modem/roteador.

A título de curiosidade, o mDNS utliza a porta 5353 do UDP.






01 02