Mudou ip, pára a internet

1. Mudou ip, pára a internet

Fabio Santos
fabiomaua

(usa Debian)

Enviado em 06/01/2019 - 16:58h

Olá a todos
Estou com o seguinte ambiente:

Ubuntu 18.04 LTS que está usando o ip 192.168.0.100.
Roteador para a internet de ip 192.168.0.1.
Ambos os equipamentos estão usando a mesma máscara (255.255.0.0).

Até ai, o ubuntu pinga o roteador e sites externos normalmente, porem, se eu trocar o ip do Ubuntu para 192.168.1.100, ele pinga o roteador, mas não pinga mais na internet. Pra mim isso é estranho pois ambos os equipamentos estão na mesma mascara. Será que o meu caso é de adicionar alguma rota ou algo parecido? agradecido a todas as respostas!


  


2. Re: Mudou ip, pára a internet

João Paulo
princknoby

(usa Arch Linux)

Enviado em 07/01/2019 - 00:18h

fabiomaua escreveu:

Olá a todos
Estou com o seguinte ambiente:

Ubuntu 18.04 LTS que está usando o ip 192.168.0.100.
Roteador para a internet de ip 192.168.0.1.
Ambos os equipamentos estão usando a mesma máscara (255.255.0.0).

Até ai, o ubuntu pinga o roteador e sites externos normalmente, porem, se eu trocar o ip do Ubuntu para 192.168.1.100, ele pinga o roteador, mas não pinga mais na internet. Pra mim isso é estranho pois ambos os equipamentos estão na mesma mascara. Será que o meu caso é de adicionar alguma rota ou algo parecido? agradecido a todas as respostas!

Acho que o que está acontecendo é que você está setando um IP no Ubuntu fora da faixa de IP do seu roteador.
Seu roteador está em >> 192.168.'0'.1 e você está tentando colocar um IP na faixa 192.168.'1'.xxx (ignore as aspas, foi só pra você ver onde tá o erro).
Se quiser usar a faixa '1' teu roteador precisa estar nessa faixa.

Tenta alterar o IP no próprio roteador, pega o MAC do teu PC e colocar um IP fixo pra ele, **SE NAO ME ENGANO** os roteadores te impedem de setar um IP fora da faixa. (mas não tenho certeza disso)
Tenta ai, foi a única coisa que "pode ser" que veio na minha mente.



3. Re: Mudou ip, pára a internet

Carlos Alberto de Souza Barbosa
souzacarlos

(usa Outra)

Enviado em 07/01/2019 - 14:38h

Boa tarde.
Seu questionamento não está errado, vc pode sem problema nenhuma utilizar a rede como vc definiu. Agora quando vc diz que não pinga nada na Internet não pinga nome ex: ping www.google.com ou não ping nem IP tipo: ping 8.8.8.8

Agora caso não tenha necessidade e acho que não terá eu não utilizaria uma rede /16 para usuários finais, imagina a quantidade de broadcast vc teria com uam rede toda ocupada nessa faixa de IP.

fabiomaua escreveu:

Olá a todos
Estou com o seguinte ambiente:

Ubuntu 18.04 LTS que está usando o ip 192.168.0.100.
Roteador para a internet de ip 192.168.0.1.
Ambos os equipamentos estão usando a mesma máscara (255.255.0.0).

Até ai, o ubuntu pinga o roteador e sites externos normalmente, porem, se eu trocar o ip do Ubuntu para 192.168.1.100, ele pinga o roteador, mas não pinga mais na internet. Pra mim isso é estranho pois ambos os equipamentos estão na mesma mascara. Será que o meu caso é de adicionar alguma rota ou algo parecido? agradecido a todas as respostas!




Network Analyst - Consultor para empresas
contact skype: carlossouzainfo
21 99180-8165 (WhattsApp)


4. Re: Mudou ip, pára a internet

Fabio Santos
fabiomaua

(usa Debian)

Enviado em 15/01/2019 - 09:57h

Obrigado pelas respostas e desculpa pela demora
Eu não pigo nem por dominio e nem por ip.
Veja se meu conceito está correto: se eu coloco o ip 192.168.0.xxx no roteador, na maquina1 eu coloco 192.168.1.xxx,e na maquina 2 eu coloco 192.168.2.xxx, porem com as mesmas mascaras (255.255.0.0), não era pra funcionar a internet em todas as maquinas sem problemas?
Nos meus testes e usando essa configuração, as maquinas pingam entre si, sem problemas!


5. Re: Mudou ip, pára a internet

Perfil removido
removido

(usa Nenhuma)

Enviado em 16/01/2019 - 21:30h

fabiomaua escreveu:

Obrigado pelas respostas e desculpa pela demora
Eu não pigo nem por dominio e nem por ip.
Veja se meu conceito está correto: se eu coloco o ip 192.168.0.xxx no roteador, na maquina1 eu coloco 192.168.1.xxx,e na maquina 2 eu coloco 192.168.2.xxx, porem com as mesmas mascaras (255.255.0.0), não era pra funcionar a internet em todas as maquinas sem problemas?
Nos meus testes e usando essa configuração, as maquinas pingam entre si, sem problemas!


Olá,

Está correto o seu raciocínio, só uma dúvida, como você está fixando o ip nessas máquinas, ifconfig ou arquivo?
Tente verificar se a rota está certa com o comando: route -n
Caso não estiver definida tente: route add default gw 192.168.0.1


6. Configuração de IP

Luis Santos
bashshx

(usa Crunchbang)

Enviado em 05/02/2019 - 15:58h

fabiomaua escreveu:

Obrigado pelas respostas e desculpa pela demora
Eu não pigo nem por dominio e nem por ip.
Veja se meu conceito está correto: se eu coloco o ip 192.168.0.xxx no roteador, na maquina1 eu coloco 192.168.1.xxx,e na maquina 2 eu coloco 192.168.2.xxx, porem com as mesmas mascaras (255.255.0.0), não era pra funcionar a internet em todas as maquinas sem problemas?
Nos meus testes e usando essa configuração, as maquinas pingam entre si, sem problemas!


O correto seria:
ROTEADOR :192.168.0.1
MASCARA: 255.255.255.0
MÁQUINAS 192.168.0.XXX (Você só pode atribuir endereços dentro da faixa se você trocar o "0" vai jogar suas máquinas fora da range e por consequência tirá-las da rede)

Luis Santos






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts