Interface de rede não sobe [RESOLVIDO]

1. Interface de rede não sobe [RESOLVIDO]

Joaze de Oliveira
joaze

(usa Debian)

Enviado em 25/06/2010 - 15:54h

Olá Pessoal Gostaria de saber se alguém já passou por isso: Tenho um servidor com raid 1 rodando Ubuntu 9.04 server. este foi clonado usando a hd secundária do servidor principal para funcionar como principal no outro servidor e usar uma segunda hd como secundária para sincronizar com o raidhotadd.O esquema funcionou corretamente, todos os serviços do servidor clonado subiu ok, porém não subiu as 3 interfaces de rede. quando tento o ifconfig não aparece nenhuma interface
Observação tenho certeza que o ubuntu reconhece as placas de rede pois quando fui recuperar o grub no mbr usei o cd de instalação no modo recovery e e antes de chegar na opção de executar o shell teve algumas perguntas de configuração entre elas idiomas configurar endereço de ip. Neste ponto ele exibiu as 3 interfaces de rede para mim escolher definir o ip.
Alguém me disse que este tipo de problema é comum quando você tenta adicionar um novo hardware nesse tipo de servidor ubuntu 9.04 server. Dai ele me disse alguma coisa sobre UID da placa de rede que tenho que descobrir e linkar com a interface de rede. Mas não faço idéia de como fazer isso e na net não encontrei nada e aqui no forum também não espero que alguém já tenha passado por isso e possa me ajudar um bom fds a todos...


Até este ponto não teve muitos problemas o maior problema que estou tendo é o seguinte


  


2. Re: Interface de rede não sobe [RESOLVIDO]

irado furioso com tudo
irado

(usa XUbuntu)

Enviado em 25/06/2010 - 15:59h

é provável que existam diferenças de hardware. Primeiro descubra se as interfaces existem:

# lspci | grep -i ethernet

depois procure os módulos correspondentes (google) e ative-os (modprobe nome.do.modulo)


3. RE: Interface de rede não sobe

Gustavo Henrique
gustavohsr

(usa Debian)

Enviado em 25/06/2010 - 16:02h

Amigo, tente renomear o arquivo "70-persistent-net.rules" que fica em "/etc/udev/rules.d/" e reinicie o Ubuntu...

O Ubuntu vai identificar novamente suas placas de rede e criar outro arquivo com as configurações das suas ETHs.

Verifique o conteúdo deste arquivo - "70-persistent-net.rules" - e veja se as placas realmente foram identificadas. Caso contrário tente levanta-las com "ifup ethX", etc... pra ver se ocorre algum erro.


4. Re: Interface de rede não sobe [RESOLVIDO]

Joaze de Oliveira
joaze

(usa Debian)

Enviado em 25/06/2010 - 16:44h

rodei o comando que o primeiro amigo sugeriu e ele identificou as 3 interfaces "lspci | grep -i ethernet"

depois segui as intruções do segundo colega
renomeando o arquivo "70-persistent-net.rules" e reiniciando na mosca. Valeu galéra fiquei impressionado com a velocidade na resposta do topico



5. Interface não apareece

Valdir Tenório Gonçalves
valdir17

(usa Suse)

Enviado em 14/02/2013 - 16:40h

Estou com este problema no suse enterprise server 10.
Não aparece a interface n0 if config. mas no lspci | grep -i ethernet aparece as placas....

Procurei o arquivo falado acima para poder editar..mas on suse não achei...o mais parecido que encontrei foi o 31-network.rules....será que devoi renomear??


6. interface de rede não sobe

Mizael Clistion Souza Elias
clistion

(usa Ubuntu)

Enviado em 13/09/2017 - 15:51h


No terminal veja a listagem do seu hardware de rede:
#lshw -C network


Verás um campo com nome LOGICAL NAME: eth2 /*pode ser ethx, ens3x, etc*/

Veja a saída do sistema com dados do nome da sua interface de rede. Normalmente eth0 pode ser trocada para outro nome, por exemplo ens33, etc.
#dmesg | grep eth /*pode ser ethx, ens3x, etc*/


Mude no arquivo de interfaces o nome correto da interface:
# vim /etc/network/interfaces


iface inet static eth?

Por fim:
sudo ifup eth? - **** ? = o nome da interface descoberta****









Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts