Erro com o OpenVPN

1. Erro com o OpenVPN

Fernando Maciel
lfsmaciel

(usa Debian)

Enviado em 20/08/2007 - 16:41h

Ola. Estou seguindo o tutorial http://www.vivaolinux.com.br/artigos/verArtigo.php?codigo=2602&pagina=1 tentando montar minha VPN porém não estou conseguindo fazer funcionar a parte do TUN/TAP. Estou usando o Debian 4 e inclusive ele aceita o comando "modprobe tun" porém quando executo ifconfig tun0 ele retorna o erro: "tun0: error fetching interface information: Device not found".
Alguém poderia me ajudar?

Obrigado


  


2. Re: Erro com o OpenVPN

Hugo Alvarez
hugoalvarez

(usa Debian)

Enviado em 20/08/2007 - 16:58h

Oi amigo,

a instalaçãod escrita nesse artigo não funciona no Etch, para fazer sua VPN funcionar só é preciso uma alteração no método de instalação:

ao invés de compilar os pacotes baixados dessa url do artigo use o aptitude para instalar a lzo e o openvpn, eu usei o mirror ftp.br.debian.org, adicione-os no seu /etc/apt/sources.list, aptitude update, aptitude search openvpn, confira se está ok, aptitude install openvpn, aptitude search lzo, instale a lzo que quiser, a versão 2 é a atual esse artigo já está desatualizado. Fora a instalação os demais processos funcionam normalmente para o Etch.

deb http://ftp.br.debian.org/debian/ etch main
deb-src http://ftp.br.debian.org/debian/ etch main

deb http://security.debian.org/ etch/updates main contrib
deb-src http://security.debian.org/ etch/updates main contrib







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts