Erro Dansguardian e Squid

1. Erro Dansguardian e Squid

Alessandro Rocha Martins
sandrormm

(usa CentOS)

Enviado em 03/11/2014 - 10:53h

Pessoal preciso de certa urgencia nessa ajuda.
tenho um squid e Danasguardian trabalhando de forma normal, em um cliente.

só que hoje 03/11/2014 tanto squid quanto dansguardian deram "pau" e o serviço está parado.

o squid apenas gera o o erro de:
[[email protected] ~]# /etc/init.d/dansguardian start
Iniciando Web Content Filter (dansguardian): Error creating/opening pid file:/var/run/dansguardian.pid
Exiting with error


alguém ai para me ajudar por gentileza?




  


2. Re: Erro Dansguardian e Squid

Alessandro Rocha Martins
sandrormm

(usa CentOS)

Enviado em 03/11/2014 - 10:55h

gente não sei porque não saiu, mas o erro que o squid retorna é apenas
(FALHOU) em vermelho


3. Re: Erro Dansguardian e Squid

Andre Ribeiro da Costa
andr3ribeiro

(usa Arch Linux)

Enviado em 03/11/2014 - 11:09h

Quais passos vc ja fez pra tentar arrumar?
Qual distro, versao, e outros serviços rodam nessa maquina?

Tente matar alguns serviços secundarios e subi-los denovo,
de um "Killall squid" e tente starta-lo denovo.

Tente tambem limpar todo o cache e refazer o arquivo de log do squid.
Ja tive um problema parecido q era HD cheio. Nao vi a tempo e parou tudo. Refiz o cache e apaguei o access.log e, no meu caso, resolveu!




4. Re: Erro Dansguardian e Squid

Alessandro Rocha Martins
sandrormm

(usa CentOS)

Enviado em 19/11/2014 - 09:42h

Olá André, perdão pela demora.

[Resolvido]Consegui resolver o problema da seguinte maneira.
1º o conjunto squid/dansguardian está com problemas, portanto suas indicações não foram precisas, mas de qualquer forma muitíssimo obrigado.
2º foi preciso pegar alguns arquivos velhos(backups) e substitui-los para fazer o squid/dansguardian funcionar
3º será preciso formatar e instalar do zero o servidor, pois como disse o linux tá bixado.

mas uma vez obrigado, e desculpe pela demora


=======================================================================///////==============================

Quais passos vc ja fez pra tentar arrumar?
Qual distro, versao, e outros serviços rodam nessa maquina?

Tente matar alguns serviços secundarios e subi-los denovo,
de um "Killall squid" e tente starta-lo denovo.

Tente tambem limpar todo o cache e refazer o arquivo de log do squid.
Ja tive um problema parecido q era HD cheio. Nao vi a tempo e parou tudo. Refiz o cache e apaguei o access.log e, no meu caso, resolveu!