Debian Update

1. Debian Update

Juda Benhur
paulistinha

(usa Red Hat)

Enviado em 11/03/2010 - 05:51h

Pessoal,


Instalei o Debian 5.0.4, o último stable no site da Debian.

Mas quando fui instalar o virtualbox, tive mensagens de dependências, que precisam de atualizações.

Vejam:

----
apt-get install virtualbox-3.1
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
virtualbox-3.1: Depends: libpython2.6 (>= 2.6) but it is not installable
Depends: libqt4-network (>= 4.5.1) but 4.4.3-1+lenny1 is to be installed
Depends: libqt4-opengl (>= 4.5.1) but it is not going to be installed
Depends: libqtcore4 (>= 4.5.1) but 4.4.3-1+lenny1 is to be installed
Depends: libqtgui4 (>= 4.5.1) but 4.4.3-1+lenny1 is to be installed
Depends: libstdc++6 (>= 4.4.0) but 4.3.2-1.1 is to be installed
Depends: libxml2 (>= 2.7.4) but 2.6.32.dfsg-5+lenny1 is to be installed
Recommends: dkms but it is not installable
E: Broken packages
-----

Além do mais, o pacote dkms, não instala, diz que não está disponível (not available), ma é referencia para outro programa.


Como posso resolver essas questões?

Eu procurei atualizaro "source.list" mas não obtive sucesso.


Grato pela ajuda!

Um grande abraço.
Obrigado.




  


2. Re: Debian Update

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 11/03/2010 - 08:36h

C já tentou instalar essas dependências?

- qt4-x11
- libxml2
- gcc
- python2.6

# apt-get install nomedopacote


3. Re: Debian Update

Ricardo Libanio
riesdra

(usa Debian)

Enviado em 11/03/2010 - 08:38h

o vmware não serve?
estes dias vi um cara com back track tendo este mesmo problema com virtual-box.



4. Re: Debian Update

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 11/03/2010 - 08:40h

O vmware é mais lento q o virtualbox (vmware workstation) e o vmware server tem bugs muito chatos.


5. Re: Debian Update

Ricardo Libanio
riesdra

(usa Debian)

Enviado em 11/03/2010 - 08:58h

desta do vmware ser pior que o virtual-box eu não sabia.



6. Re: Debian Update

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 11/03/2010 - 09:02h

Bom, em questão d desempenho o virtualbox é mais rápido msm (testei várias vezes aki), mas o vmware possui mais opções q o virtualbox.


7. Re: Debian Update

Juda Benhur
paulistinha

(usa Red Hat)

Enviado em 11/03/2010 - 09:08h

Pessoal,


Eu já uso o vmware, na solução do ESX Server. Ele é bom sim.

Mas quero aprender e testar o virtualbox, pois o vmware, é crítico demais com relação à hardware. Então, preciso de soluções alternativas.

Precisamos estar sintonizados com os recursos oferecidos.


Grato.


8. Faça:

Perfil removido
removido

(usa Nenhuma)

Enviado em 11/03/2010 - 09:14h

apt-get -f install
Isso instalara as dependencias citadas. e logo apos instalara o virtualbox.
Depois que instalar, voce vai ter problema com o vboxdrv , ai eu te ajudo denovo. té mais.
mande um email para [email protected]


Edite o source.lst e adicione:
#virtualbox
deb http://download.virtualbox.org/virtualbox/debian lenny non-free

faça o apt-get update.
e faça o que eu disse acima.



9. Estou apanhando mais que na época da Ditadura

Juda Benhur
paulistinha

(usa Red Hat)

Enviado em 11/03/2010 - 09:45h

Camarada,



Eu fiz o que você falou, mas ele reclama das dependências e das versões, que não são as que ele quer.

O que faço?

Grande abraço.


10. Re: Debian Update

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 11/03/2010 - 09:52h

Vc pode localizá-las, dessa forma:

# apt-cache search libqt4-network

Dae faça isso pra kda dependência, q ele listará o pacote necessário. Se não localizar, é melhor vc baixar em separado ou acrescentar um repositório q contenha tais dependências.


11. Re: Debian Update

Ricardo Libanio
riesdra

(usa Debian)

Enviado em 11/03/2010 - 11:33h

mas acho que com aquela entrada no sources ele deve baixar as dependencias, na hora do almoço eu vou fazer um teste aqui.



12. Re: Debian Update

Felipe
felipeassuncaoj

(usa Debian)

Enviado em 11/03/2010 - 11:58h

procure no menu .conf



01 02