Arquivo de configuração da rede não foi criado automaticamente no Centos [RESOLVIDO]

1. Arquivo de configuração da rede não foi criado automaticamente no Centos [RESOLVIDO]

Rodrigo Mateus Finger
romafin

(usa Outra)

Enviado em 29/04/2015 - 14:46h

Saudações!

Pesquisei mas não consegui resolver, por isso resolvi fazer este post!

Instalei o centos minimal 7, porém ele não criou o arquivo de configuração da rede, criou apenas o ifcfg-lo, então criei o arquivo ifcfg-eth0 com as seguintes configurações
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=yes
IPADDR=192.168.1.155
NETMASK=255.255.255.0
GATEWAY=192.168.1.1
TYPE=Ethernet
configurei o dns com nameserver 8.8.8.8 no resolv.conf

porém não tive sucesso
para levantar a inteface tentei ifup eth0, service network restart mas não deu certo
e o ifconfig não responde provavelmente por que é uma versão minimal.

alguém sabe como posso resolver isso?grato pela ajuda





  


2. Re: Arquivo de configuração da rede não foi criado automaticamente no Centos

Eris Ribeiro Junior
erisrjr

(usa Outra)

Enviado em 29/04/2015 - 17:39h

Ola,
Varias coisas mudaram nesta versão 7(Além do systemd), entre elas como gerenciar a rede e a forma que as interfaces são nomeadas.

De uma olhada nisto para configurar:
http://ask.xmodulo.com/configure-static-ip-address-centos7.html

Caso precise que a interface chame-se eth0 (Algum script), pode renomeá-la seguindo:
http://www.vivaolinux.com.br/dica/Alterando-device-name-do-CentOS-7-para-eth0


*Caso não queira utilizar o networkmanager para controlar a rede, tera que desabilita-lo (E configurar o arquivo da interface, como no primeiro link).
Outra, o comando ifconfig fou "depreciado", não vindo na instalação padrão, agora você desabilitar o NetworkManager, deve configurar as interfaces com o comando ip, ou instalar o pacote net-tools, para ter o ifconfig "de volta" .

------------------------------------------------------
¿? -> keyboard Error: No Keyboard Present, PRESS F1 to continue.



3. nmtui

Eris Ribeiro Junior
erisrjr

(usa Outra)

Enviado em 29/04/2015 - 18:13h

Lembrei de uma coisa que pode lhe ser útil, caso considere os links acima "complicados".

Dependendo do perfil que escolheu durante a instalação, pode ter instalado o aplicativo nmtui, que funciona de forma semelhante ao NetworkManager do "modo gráfico", bastando "navegar" nele, utilize as setas do teclado movimenta-se e enter para selecionar.

------------------------------------------------------
¿? -> keyboard Error: No Keyboard Present, PRESS F1 to continue.



4. Ainda não funcionou

Rodrigo Mateus Finger
romafin

(usa Outra)

Enviado em 30/04/2015 - 10:51h

Fiz o procedimento descrito em http://ask.xmodulo.com/configure-static-ip-address-centos7.html, porém na hora do nmcli dev status apareceu apenas o loopback, ai já não sei o que fazer, já havia instalado esta mesma versão nimimal(mesma media) e o aquivo de configuração sempre foi criado normalmente, não sei se tem alguma coisa haver mas não deixei o cabo de rede plugado na hora da instalação....



5. Re: Arquivo de configuração da rede não foi criado automaticamente no Centos [RESOLVIDO]

Eris Ribeiro Junior
erisrjr

(usa Outra)

Enviado em 30/04/2015 - 11:19h

romafin escreveu:

Fiz o procedimento descrito em http://ask.xmodulo.com/configure-static-ip-address-centos7.html, porém na hora do nmcli dev status apareceu apenas o loopback, ai já não sei o que fazer, já havia instalado esta mesma versão nimimal(mesma media) e o aquivo de configuração sempre foi criado normalmente, não sei se tem alguma coisa haver mas não deixei o cabo de rede plugado na hora da instalação....


Talvez o CentOS não tenha reconhecido a placa de rede, sabe o modelo dela?

Tente identificar com o comando lspci (Na duvida, poste o resultado dele aqui):

*Se não reconheceu, tera que olhar na pagina do fabricante do servidor o modelo, e confirmarmos sua compatibilidade com o RHEL/CentOS.

------------------------------------------------------
¿? -> keyboard Error: No Keyboard Present, PRESS F1 to continue.



6. Placa de rede não reconhecida

Rodrigo Mateus Finger
romafin

(usa Outra)

Enviado em 02/05/2015 - 21:33h

Consegui resolver, coloquei um placa de re off-board e reconheceu no ato, problema resolvido!
Valeu pela ajuda!







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts