Servidor de Virtualização (Vmware Server)

1. Servidor de Virtualização (Vmware Server)

Wellington Holanda
WHolanda

(usa Ubuntu)

Enviado em 23/09/2013 - 09:39h

Olá time,

Estou fazendo um servidor vmware e durante a instalação estou tendo problemas.

O principal problema é para encontrar o diretório do GCC, acredito que e não sei bem o que fazer depois de tentar inúmeras soluções.

"Setup is unable to find the "gcc" program on your machine. Please make sure it is installed. Do you want to specify the location of this program by hand?[yes] yes


What is the location of the "gcc" program on your machine? /usr/bin/gcc


The answer "/usr/bin/gcc" is invalid. It must be the complete name of a binary file".



Por favor, alguém pode me ajudar nesse problema?


  


2. Re: Servidor de Virtualização (Vmware Server)

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 23/09/2013 - 10:13h

Talvez ele não esteja aceitando link simbólico. Veja qual é o arquivo q o link simbólico aponta:


ls -l /usr/bin/gcc


Ae vc põe lá no script do VMWare. Veja se dá certo.


3. Re: Servidor de Virtualização (Vmware Server)

Wellington Holanda
WHolanda

(usa Ubuntu)

Enviado em 23/09/2013 - 10:32h

Na verdade, esse é o erro agora.

"Your kernel was built with "gcc" version "4.6.3", while you are trying to use
"/usr/bin/gcc" version "4.7". This configuration is not recommended and VMware
Server may crash if you'll continue. Please try to use exactly same compiler as
one used for building your kernel. Do you want to go with compiler
"/usr/bin/gcc" version "4.7" anyway?"


4. Re: Servidor de Virtualização (Vmware Server)

Mauro da fontoura
MauroFontoura

(usa CentOS)

Enviado em 23/09/2013 - 10:37h

No teu sistema tem o gcc instalado?


5. Re: Servidor de Virtualização (Vmware Server)

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 23/09/2013 - 10:40h

Não é recomendado compilar algo q diverge da versão q o aplicativo recomenda. Sugiro vc tentar pra v se realmente não dá zica. Se der, ae vc pode instalar o gcc da versão q ele pede e coloque-o em uma pasta separada pra não conflitar com o sistema.


6. Re: Servidor de Virtualização (Vmware Server)

Wellington Holanda
WHolanda

(usa Ubuntu)

Enviado em 23/09/2013 - 11:19h

Tenho sim.

Mas ao executar apt-get remove gcc e apt-get install gcc ele instala a versão 4.7 e o VMware está pedindo a versão 4.6.3.

O que eu devo fazer nessa situação? Começando a pensar na possibilidade de utilizar o Ubuntu 12.04 LTS para instalar o VMware Server. :(



7. Re: Servidor de Virtualização (Vmware Server)

Mauro da fontoura
MauroFontoura

(usa CentOS)

Enviado em 23/09/2013 - 11:34h

Acho que o negocio é baixar a versao solicitada e instalar ela.
E testar pra ver

# dpgk -i