OpenSuse - Rede cabeada não funciona

1. OpenSuse - Rede cabeada não funciona

Rafael
rmacario

(usa Linux Mint)

Enviado em 17/02/2017 - 21:41h

Olá amigos.

Estou enfrentando uma dificuldade imensa para fazer a internet funcionar com no cabo. Estou testando agora com o OpenSuse na versão mais recente mas tive o mesmo problema com o Linux Mint 18.
Estou usando dual boot com um Windows 8.1 e no Windows a rede funciona normalmente.

Se alguém puder me ajudar ficarei muito grato, já estou há dias tentando solucionar.

Algumas informações:

ifconfig -a

eth0 Link encap: Ethernet HWaddr 00:E0:4C:98:07:1A
UP BROADCAST MULTICAST MTU:1500 Metric: 1
RX packets:0 erros:0 dropped:0 overruns:0 frame:0
TX packets:0 erros:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0b) TX bytes:0 (0.0 b)

lo Link encap: Local Loopback
inet addr: 127.0.0.1 Mask 255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric: 1
RX packets:0 erros:0 dropped:0 overruns:0 frame:0
TX packets:0 erros:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:2432 (2.3 b) TX bytes:2432 (2.3 b)


netstat -rn fica tudo em branco.

lsmod | grep r8169

r8169 90112 0
mii 16384 1 r8169


lspci (ultima linha)

Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8169 PCI Gigabit Ethernet Controller (rev 10)


Ah, uma informação que talvez faça diferença. A placa de rede onboard queimou e uma outra placa offboard é que está ativa.


  


2. Re: OpenSuse - Rede cabeada não funciona

José da Silva
zenull

(usa Outra)

Enviado em 17/02/2017 - 21:45h

Poste a saída de ifconfig (sem o parâmetro -a) e lspci -k


3. Re: OpenSuse - Rede cabeada não funciona

Rafael
rmacario

(usa Linux Mint)

Enviado em 17/02/2017 - 21:55h

zenull escreveu:

Poste a saída de ifconfig (sem o parâmetro -a) e lspci -k


Seguem as saídas:


# lspci -k
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] RS780 Host Bridge
Subsystem: Advanced Micro Devices, Inc. [AMD] RS780 Host Bridge
00:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] RS780 PCI to PCI bridge (ext gfx port 0)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [IDE mode]
Subsystem: Gigabyte Technology Co., Ltd GA-MA770-DS3rev2.0 Motherboard
Kernel driver in use: ahci
Kernel modules: ahci
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
Subsystem: Gigabyte Technology Co., Ltd Device 5004
Kernel driver in use: ohci-pci
Kernel modules: ohci_pci
00:12.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0 USB OHCI1 Controller
Subsystem: Gigabyte Technology Co., Ltd Device 5004
Kernel driver in use: ohci-pci
Kernel modules: ohci_pci
00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
Subsystem: Gigabyte Technology Co., Ltd Device 5004
Kernel driver in use: ehci-pci
Kernel modules: ehci_pci
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
Subsystem: Gigabyte Technology Co., Ltd Device 5004
Kernel driver in use: ohci-pci
Kernel modules: ohci_pci
00:13.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0 USB OHCI1 Controller
Subsystem: Gigabyte Technology Co., Ltd Device 5004
Kernel driver in use: ohci-pci
Kernel modules: ohci_pci
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
Subsystem: Gigabyte Technology Co., Ltd Device 5004
Kernel driver in use: ehci-pci
Kernel modules: ehci_pci
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 3c)
Subsystem: Gigabyte Technology Co., Ltd GA-MA770-DS3rev2.0 Motherboard
Kernel modules: i2c_piix4, sp5100_tco
00:14.1 IDE interface: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 IDE Controller
Subsystem: Gigabyte Technology Co., Ltd Device 5002
Kernel driver in use: pata_atiixp
Kernel modules: pata_atiixp, pata_acpi, ata_generic
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
Subsystem: Gigabyte Technology Co., Ltd Device a002
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller
Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge
00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
Subsystem: Gigabyte Technology Co., Ltd Device 5004
Kernel driver in use: ohci-pci
Kernel modules: ohci_pci
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 2
Kernel modules: amd64_edac_mod
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 3
Kernel driver in use: k10temp
Kernel modules: k10temp
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 4
Kernel driver in use: fam15h_power
Kernel modules: fam15h_power
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 5
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series]
Subsystem: ASUSTeK Computer Inc. Device 03ca
Kernel driver in use: radeon
Kernel modules: radeon
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Cedar HDMI Audio [Radeon HD 5400/6300 Series]
Subsystem: ASUSTeK Computer Inc. Device aa68
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel
02:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8169 PCI Gigabit Ethernet Controller (rev 10)
Subsystem: Realtek Semiconductor Co., Ltd. RTL8169/8110 Family PCI Gigabit Ethernet NIC
Kernel driver in use: r8169
Kernel modules: r8169


==============================================================================

# ifconfig
eth0 Link encap:Ethernet HWaddr 00:E0:4C:98:07:1A
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:32 errors:0 dropped:0 overruns:0 frame:0
TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:2432 (2.3 Kb) TX bytes:2432 (2.3 Kb)






4. Re: OpenSuse - Rede cabeada não funciona

José da Silva
zenull

(usa Outra)

Enviado em 17/02/2017 - 22:02h

Aparentemente nenhum problema, a placa está sendo reconhecida.

No Mint você instalou o firmware da Realtek e mesmo assim não funcionou?

No opensuse, não tenho muito ideia como funciona, mas veja se isso te ajuda:
https://en.opensuse.org/SDB:Realtek_8169_driver_problem


5. Re: OpenSuse - Rede cabeada não funciona

Eduardo Campacci
Campacci

(usa Fedora)

Enviado em 17/02/2017 - 22:49h

Como o colega acima disse, sua placa foi reconhecida e o modulo foi carregado.
Já tentou inserir o IP manualmente?

Posta ai o seu /etc/sysconfig/network/ifcfg-eth0



6. Re: OpenSuse - Rede cabeada não funciona

Rafael
rmacario

(usa Linux Mint)

Enviado em 18/02/2017 - 16:12h

Campacci escreveu:

Como o colega acima disse, sua placa foi reconhecida e o modulo foi carregado.
Já tentou inserir o IP manualmente?

Posta ai o seu /etc/sysconfig/network/ifcfg-eth0


Este é o conteúdo do arquivo:


BOOTPROTO='dhcp4'
BROADCAST=''
DHCLIENT_SET_DEFAULT_ROUTE='yes'
ETHTOOL_OPTIONS=''
IPADDR=''
MTU=''
NAME='RTL8169 PCI Gigabit Ethernet Controller'
NETMASK=''
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='ifplugd'
IFPLUGD_PRIORITY='0'





7. Re: OpenSuse - Rede cabeada não funciona

Eduardo Campacci
Campacci

(usa Fedora)

Enviado em 19/02/2017 - 14:11h

rmacario escreveu:

Campacci escreveu:

Como o colega acima disse, sua placa foi reconhecida e o modulo foi carregado.
Já tentou inserir o IP manualmente?

Posta ai o seu /etc/sysconfig/network/ifcfg-eth0


Este é o conteúdo do arquivo:


BOOTPROTO='dhcp4'
BROADCAST=''
DHCLIENT_SET_DEFAULT_ROUTE='yes'
ETHTOOL_OPTIONS=''
IPADDR=''
MTU=''
NAME='RTL8169 PCI Gigabit Ethernet Controller'
NETMASK=''
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='ifplugd'
IFPLUGD_PRIORITY='0'




Não entendi o motivo do seu BOOTPROTO ser dhcp4. Foi vc que adicionou?

O meu esta para obter o IP via DHCP e esta assim. Veja se deixando igual resolve o problema.
BOOTPROTO='dhcp'
BROADCAST=''
ETHTOOL_OPTIONS=''
IPADDR=''
MTU=''
NAME=''
NETMASK=''
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
DHCLIENT_SET_DEFAULT_ROUTE='yes'


Obs.: Outra coisa, vc pode ir no YAST>Configurações de Rede e em método de configurações de rede deixar que o Network Manager seja responsável.










Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts