Não consigo ativar a placa de rede eth0 [RESOLVIDO]

1. Não consigo ativar a placa de rede eth0 [RESOLVIDO]

Lucyano Leal
lucyano_leal

(usa Ubuntu)

Enviado em 18/05/2012 - 10:45h

Senhores, bom dia.

Mexo com o Linux há alguns anos, mas não com tanta frequência, o que me faz perder alguns conhecimentos de tempos em tempos rss

Estou com a missão de criar um servidor de arquivos, e escolhi o OpenSuse para tal.

Instalei o OpenSuse 11.3 (com KDE) e ele está funcionando bem. Quando fui configurar a rede pelo Yast, percebi que a placa de rede não foi detectada automaticamente. O nome da placa de rede que aparece é "Intel Ethernet Controller" e seu endereço IP aparece "Não Configurado". Mais abaixo há a mensagem "Não foi possível configurar a placa de rede porque o módulo kernel (eth0, wlan0) não está presente. Isto normalmente ocorre quando está faltando o firmware (para dispositivos sem fio). Veja a saída do comando dmesg para obter mais detalhes".

Meu computador é um Dell Optiplex 790 e sua configuração é excelente.

Já tentei diversas formas de ativar a placa de rede, como por exemplo:

# ifconfig ======> Só aparece o lo

# ifconfig eth0 up (e fiz tb para eth1, eth2, eth3 e assim sucessivamente)

# lspci (apareceu a placa de rede) ==> Ethernet Controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)

- Fui até o site da Intel e baixei o arquivo e1000e-1.11.3.tar.gz e descompactei na "Pasta da Área de Trabalho". Sei que nesse caso tem mais alguma coisa a fazer, mas não sei o que é.. Eu tentei usar o make install, mas apareceram 3 linhas de mensagem:

Makefile:71: *** Kernel header files not in any of the expected locations.
Makefile:72: *** Install the apropriate kernel development package, e.g.
Makefile:73: *** Kernel-devel, for building kernel modules and try again. Pare.


Grato por toda a ajuda

:)


  


2. MELHOR RESPOSTA

Flavio Schurt
asterix-super

(usa Ubuntu)

Enviado em 18/05/2012 - 12:10h

tenho um Dell T-100, com ubuntu server nele.

Broadcom Corporation NetXtreme BCM5722 Gigabit Ethernet PCI Express.

foi reconhecido automaticamente, sem crise, mas não é o seu caso


Eu já evitei de compilar os fontes para fazer o driver, instalando o modconf.
No modconf, ele lista dezenas de drivers,
Há uma seção /kernel/drivers/net/
As vezes está em outras seções.


3. Re: Não consigo ativar a placa de rede eth0 [RESOLVIDO]

Francisco Ambrozio
fco

(usa Slackware)

Enviado em 18/05/2012 - 11:23h

lucyano_leal escreveu:

Makefile:71: *** Kernel header files not in any of the expected locations.
Makefile:72: *** Install the apropriate kernel development package, e.g.
Makefile:73: *** Kernel-devel, for building kernel modules and try again. Pare.



Instala os fontes do kernel (sinceramente não sei exatamente qual é o pacote especifico do openSUSE, mas dá uma procurada) e veja se resolve.



4. Re: Não consigo ativar a placa de rede eth0 [RESOLVIDO]

Lucyano Leal
lucyano_leal

(usa Ubuntu)

Enviado em 18/05/2012 - 14:44h

Caros Xico_Ambrozio e Fschurt, estou pesquisando as sugestões de vocês. Agradeço pelas dicas.

Se quiserem informar em detalhes como instalo os fontes do openSUSE ou como instalar o modconf ou se quiserem dar mais dicas, fico agradecido

=]


5. Re: Não consigo ativar a placa de rede eth0 [RESOLVIDO]

Flavio Schurt
asterix-super

(usa Ubuntu)

Enviado em 18/05/2012 - 18:12h

No Ubuntu, eu uso o sudo apt-get install modconf ou gerenciador de pacotes do ubuntu.

No Suse, não sei. Eu verificaria se tem o pacote modconf na lista de pacotes do Yast. Se não houver, verificaria se o Yast tem pacotes de terceiros e parceiros em sua lista do Yast. Não faço de idéia de como é o sistema Yast de pacotes e canais de software.


6. Re: Não consigo ativar a placa de rede eth0 [RESOLVIDO]

Josenildo Cardoso
dungamaster

(usa Debian)

Enviado em 19/05/2012 - 20:41h

Amigo, não sou muito bom em linux, (nem windows), caso você não consiga fazer a placa subir com os drives do linux, tente usar o programa ndiswrapper, ele emula os drives do windows no linux, já usei ele um tempo quando comprei um notebook cujo o driver para linux da placa sem fio não existia, procure tentar as soluções dos usuarios do forum mais experientes em linux, caso nao consiga nada, use a minha dica.


7. Re: Não consigo ativar a placa de rede eth0 [RESOLVIDO]

Adriano Rodrigues Balani
balani

(usa Slackware)

Enviado em 19/05/2012 - 22:18h


Makefile:71: *** Kernel header files not in any of the expected locations.
Makefile:72: *** Install the apropriate kernel development package, e.g.
Makefile:73: *** Kernel-devel, for building kernel modules and try again. Pare.




Amigo essa mensagem quer dizer que faltam os headers e o source do kernel, vc precisa instalar eles para poder instalar o driver, nunca usei o Opensuse mas pelo Yast vc deve conseguir isso.




8. Re: Não consigo ativar a placa de rede eth0 [RESOLVIDO]

Lucyano Leal
lucyano_leal

(usa Ubuntu)

Enviado em 23/05/2012 - 12:03h

Senhores, bom dia de novo.

Pesquisei e mexi muito no openSUSE, mas não consegui ativar a placa de rede, então desisti.

Baixei o Ubuntu e a placa de rede (e1000e) foi reconhecida automaticamente na instalação e esse problema acabou rs.

Esta postagem foi feita usando o Ubuntu \o/

Obrigado a todos pela ajuda =]