Slackware + Huawei E303C [RESOLVIDO]

1. Slackware + Huawei E303C [RESOLVIDO]

Edimar
dimasdaros

(usa Arch Linux)

Enviado em 07/10/2012 - 21:56h

Boa noite pessoal,

não queria posta mais uma duvida sobre isso, mas realmente não foi aqui.
Assinei 3G da vivo e "ganhei" um Huawei E303C, pluguei, instalei o software que vem com ele, mas quando vou usar o programa me mostra a seguinte mensagem:

O dispositivo foi desconectado ou não está disponível



Tentei várias opções, usando wvdial, kppp, etc.

Uma questão que notei, quando plugo o modem ele cria o /dev/ttyUSB[0,1,2], mas alguns segundos depois some.
Percebi que quando some ele monta o modem como um pendrive.

Bus 002 Device 006: ID 12d1:1506 Huawei Technologies Co., Ltd. E398 LTE/UMTS/GSM Modem/Networkcard


Tentei essa configuração, li que resolveria para mudar ele automaticamente de "pendrive" para modem



cat /etc/udev/rules.d/15-hauwei.rules

SUBSYSTEM=="block", ACTION=="add",
SYSFS{idVendor}=="12d1", SYSFS{idProduct}=="1506",
OPTIONS="ignore_device"

SUBSYSTEM=="usb", SYSFS{idVendor}=="12d1",
SYSFS{idProduct}=="1506",
RUN+="/sbin/modprobe usbserial vendor=0x12d1 product=0x1506"



tentei rodar o "/sbin/modprobe -v usbserial vendor=0x12d1 product=0x1506" direto também, mas não foi.


Isso é o que me mostra no /var/log/messages quando plugo o modem da vivo




Oct 7 21:48:25 mine kernel: [ 1969.136315] usb 2-1.2: new high-speed USB device number 7 using ehci_hcd
Oct 7 21:48:25 mine kernel: [ 1969.211970] usb 2-1.2: New USB device found, idVendor=12d1, idProduct=14fe
Oct 7 21:48:25 mine kernel: [ 1969.211973] usb 2-1.2: New USB device strings: Mfr=2, Product=1, SerialNumber=0
Oct 7 21:48:25 mine kernel: [ 1969.211975] usb 2-1.2: Product: HUAWEI Mobile
Oct 7 21:48:25 mine kernel: [ 1969.211977] usb 2-1.2: Manufacturer: HUAWEI
Oct 7 21:48:25 mine kernel: [ 1969.213696] scsi15 : usb-storage 2-1.2:1.0
Oct 7 21:48:25 mine kernel: [ 1969.213834] scsi16 : usb-storage 2-1.2:1.1
Oct 7 21:48:25 mine mtp-probe: checking bus 2, device 7: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2"
Oct 7 21:48:25 mine mtp-probe: bus: 2, device: 7 was not an MTP device
Oct 7 21:48:26 mine kernel: [ 1970.213372] scsi 15:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2
Oct 7 21:48:26 mine kernel: [ 1970.213390] scsi 16:0:0:0: Direct-Access HUAWEI SD Storage 2.31 PQ: 0 ANSI: 2
Oct 7 21:48:26 mine kernel: [ 1970.216440] sd 16:0:0:0: [sdd] Attached SCSI removable disk
Oct 7 21:48:28 mine kernel: [ 1972.282924] usb 2-1.2: USB disconnect, device number 7
Oct 7 21:48:35 mine kernel: [ 1979.361187] usb 2-1.2: new high-speed USB device number 8 using ehci_hcd
Oct 7 21:48:35 mine kernel: [ 1979.447453] usb 2-1.2: New USB device found, idVendor=12d1, idProduct=1506
Oct 7 21:48:35 mine kernel: [ 1979.447463] usb 2-1.2: New USB device strings: Mfr=2, Product=1, SerialNumber=0
Oct 7 21:48:35 mine kernel: [ 1979.447469] usb 2-1.2: Product: HUAWEI Mobile
Oct 7 21:48:35 mine kernel: [ 1979.447480] usb 2-1.2: Manufacturer: HUAWEI
Oct 7 21:48:35 mine kernel: [ 1979.449457] usbserial_generic 2-1.2:1.0: generic converter detected
Oct 7 21:48:35 mine kernel: [ 1979.449628] usb 2-1.2: generic converter now attached to ttyUSB0
Oct 7 21:48:35 mine kernel: [ 1979.449793] usbserial_generic 2-1.2:1.1: generic converter detected
Oct 7 21:48:35 mine kernel: [ 1979.450010] usb 2-1.2: generic converter now attached to ttyUSB1
Oct 7 21:48:35 mine kernel: [ 1979.450150] usbserial_generic 2-1.2:1.2: generic converter detected
Oct 7 21:48:35 mine kernel: [ 1979.450327] usb 2-1.2: generic converter now attached to ttyUSB2
Oct 7 21:48:35 mine kernel: [ 1979.450672] scsi17 : usb-storage 2-1.2:1.3
Oct 7 21:48:35 mine kernel: [ 1979.451406] scsi18 : usb-storage 2-1.2:1.4
Oct 7 21:48:35 mine mtp-probe: checking bus 2, device 8: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2"
Oct 7 21:48:35 mine mtp-probe: bus: 2, device: 8 was not an MTP device
Oct 7 21:48:36 mine kernel: [ 1980.452825] scsi 18:0:0:0: Direct-Access HUAWEI SD Storage 2.31 PQ: 0 ANSI: 2
Oct 7 21:48:36 mine kernel: [ 1980.453620] scsi 17:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2
Oct 7 21:48:36 mine kernel: [ 1980.456149] sd 18:0:0:0: [sdd] Attached SCSI removable disk
exec /sbin/startMobilePartner




Alguém passou por isso e consegue dar um help?

Muito obrigado.
Abraço


  


3. Re: Slackware + Huawei E303C [RESOLVIDO]

Edimar
dimasdaros

(usa Arch Linux)

Enviado em 14/10/2012 - 14:46h





Opa, desculpe a demora.
Mas teoricamente ele está trocando de storage para mobile, que o stage dele é 12d1:14fe, e altero para 12d1:1506
Os /dev/ttyUSB* aparecem e depois de alguns segundos somem.

A vivo dispõe de um software que vem nele, instalei para ver, mas ocorre isso, mesma coisa.

Mas obrigado pela mensagem.
abraço


4. Re: Slackware + Huawei E303C [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 14/10/2012 - 15:42h

Aqui, a versão do Network Manager (estou usando com Xfce) do Slack 14, configurou automaticamente o modem 3G da Claro (modelo E3131). Os pacotes citados pelo colega Edinaldo já vêm pré-instalados. Muito bom!

Já no openSUSE, Ubuntu e CruchBang, instalei o aplicativo que vem no modem específico para Linux e.. incrível!!! Funciona perfeitamente! O Mobile Partner instala o driver e fornece um aplicativo gráfico para conexão/verificação de velocidade e pré-configurado para iniciar no boot. Perfeito!



Só tem um inconveniente: o Mobile Partner estraga a capacidade no Network Manager de detectar qualquer modem 3G!!! Muito cuidado, pessoal!

E por que fui mexer com isso no Slack? O Network Manager estava funcionando perfeitamente com o modem.
Após instalar o Mobile Partner (até instala direitinho!), a rede não é detectada pelo aplicativo de conexão... E mesmo desinstalando o Mobile Partner do Slack, o Network Manager ficou corrompido. Baixei os pacotes do Network Manager do SlackBuilds e compilei todos relacionados a ele.

Até apliquei as configurações citadas pelo autor do tópico, mas nada de funcionar. Verifiquei logs, drivers, etc...

Mas não posso reclamar, a conexão ADSL vai na boa!


Vou reconfigurar tudo e se tiver sucesso, retorno!


5. Re: Slackware + Huawei E303C [RESOLVIDO]

Edimar
dimasdaros

(usa Arch Linux)

Enviado em 14/10/2012 - 17:13h

Opa, quem tenta um dia consegue hehe

Consegui fazer funcionar.
Acabei desinstalando tudo o sistema da vivo e utilizando o wvdial para fazer a conexão.
Estou trabalhando a base da gambiarra no momento, mas está funcionando.
(Fora um comentário do programador ao executar o wvdial, me quebrei rindo aqui auehauhe

--> Don't know what to do! Starting pppd and hoping for the best)


Nos arquivos da vivo encontrei um arquivo chamado "HWActivator", aqui ele ficava na pasta


/usr/local/VIVO_INTERNET/driver/64bit


esse arquivo é o que desativa o storage do equipamento e faz ele virar um modem.
Como com o usb_modeswitch não estava conseguindo fazer funcionar, fui procurar como a Vivo fazia isso e acabei caindo nele por acaso, vendo os arquivos da pasta.

Meu wvdial.conf ficou assim:


[Dialer Defaults]
init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2
Modem Type = Analog Modem
Phone = *99#
ISDN = 0
Modem Phone = *99#
Modem = /dev/ttyUSB0
Username = vivo
Password = vivo
Baud = 9600



Agora quando quero me conectar no 3G plugo o modem da Vivo, executo o HWActivator e em seguida o wvdial.
Um outro detalhe é o DNS, tive de editar o resolv.conf e adicionar "nameserver 8.8.8.8" manualmente, apesar de ele informar configurar o DNS, não funcionou.




wvdial
--> WvDial: Internet dialer version 1.61
--> Initializing modem.
--> Sending: ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2
OK
--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
CONNECT
--> Carrier detected. Waiting for prompt.
--> Don't know what to do! Starting pppd and hoping for the best.
--> Starting pppd at Sun Oct 14 17:05:38 2012
--> Pid of pppd: 3594
--> Using interface ppp0
--> pppd: ‘[7f]
--> pppd: ‘[7f]
--> pppd: ‘[7f]
--> pppd: ‘[7f]
--> pppd: ‘[7f]
--> pppd: ‘[7f]
--> local IP address 177.163.38.22
--> pppd: ‘[7f]
--> remote IP address 10.64.64.64
--> pppd: ‘[7f]
--> primary DNS address 200.142.132.32
--> pppd: ‘[7f]
--> secondary DNS address 200.220.227.57
--> pppd: ‘[7f]





Mas é isso ai, o importante é o que importa como dizem uns por ai hehe
Vlw pela atenção pessoal.
Esses detalhes agora me viro para arrumar, o importante é que está funcionando, e muito melhor que minha super banda larga da Oi de 300Kbps o/

Abraço
até mais


6. Re: Slackware + Huawei E303C [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 14/10/2012 - 17:24h

Se adiantar alguma coisa, veja esse minha dica:

http://gnutwoall.wordpress.com/2011/12/11/o-maravilhoso-discador-do-vivo-3g-no-debian/

Está meio zoneada, mas a dica original está em:

http://gnu2all.blogspot.com/2011/12/o-maravilhoso-discador-do-vivo-3g-no.html

Sobre métodos de conexão veja esse meu outro artigo:

http://www.vivaolinux.com.br/artigo/Configurando-o-modem-ZTE-MF626-com-Vivo3G-no-Debian

Meu wvdial.conf da época em que usava modem 3G era esse:


[Dialer Defaults]
Phone =
Username =
Password =
New PPPD = yes

[Dialer 3g]
Modem = /dev/ttyUSB2
Baud = 921600
DialCommand = ATDT
Check Def Route = on
FlowControl = Hardware(CRTSCTS)
Username = vivo
Password = vivo
Phone = *99#
Stupid mode = 1
Auto Reconnect = on
Auto DNS = on
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2
Init3 = AT+CGDCONT=1,"IP","zap.vivo.com.br"
ISDN = 0
Modem Type = Analog Modem



7. Re: Slackware + Huawei E303C [RESOLVIDO]

Edimar
dimasdaros

(usa Arch Linux)

Enviado em 14/10/2012 - 17:38h

edps escreveu:

Se adiantar alguma coisa, veja esse minha dica:

http://gnutwoall.wordpress.com/2011/12/11/o-maravilhoso-discador-do-vivo-3g-no-debian/

Está meio zoneada, mas a dica original está em:

http://gnu2all.blogspot.com/2011/12/o-maravilhoso-discador-do-vivo-3g-no.html

Sobre métodos de conexão veja esse meu outro artigo:

http://www.vivaolinux.com.br/artigo/Configurando-o-modem-ZTE-MF626-com-Vivo3G-no-Debian

Meu wvdial.conf da época em que usava modem 3G era esse:


[Dialer Defaults]
Phone =
Username =
Password =
New PPPD = yes

[Dialer 3g]
Modem = /dev/ttyUSB2
Baud = 921600
DialCommand = ATDT
Check Def Route = on
FlowControl = Hardware(CRTSCTS)
Username = vivo
Password = vivo
Phone = *99#
Stupid mode = 1
Auto Reconnect = on
Auto DNS = on
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2
Init3 = AT+CGDCONT=1,"IP","zap.vivo.com.br"
ISDN = 0
Modem Type = Analog Modem


Muito obrigado pelo interesse em ajudar edps, vlw mesmo, mas consegui resolver aqui faz uns 30 minutos, não sabe o quão bem estou agora uaheuhae
Vou ver se com essas suas dicas consigo resolver alguns probleminhas que ficaram, mas a conexão em sí está OK.

abraço
até mais