Modem E156 Claro no Ubuntu 9.04 [RESOLVIDO]

1. Modem E156 Claro no Ubuntu 9.04 [RESOLVIDO]

Luiz Eduardo
luizedrd

(usa Ubuntu)

Enviado em 29/08/2009 - 06:05h

Quando conectei o modem, o sistema o identificou e deu a opção de configuração para conexão. O mais estranho é que ele até conecta -pelo menos é o que parece-, porém nenhum dos serviços do Ubuntu dependente da internet não funcionam. Tem mais algumas coisa que eu deva fazer para o tráfego fluir ?


  


2. MELHOR RESPOSTA

Filippe
spolti

(usa Fedora)

Enviado em 01/09/2009 - 09:51h

verifique se o número do DNS está correto, se estiver errado seu tráfedo será 0 mesmo...


3. Re: Modem E156 Claro no Ubuntu 9.04 [RESOLVIDO]

Thiago Gomes Bento Ferreira
axpira

(usa Slackware)

Enviado em 29/08/2009 - 16:54h

Verifique se esta configurado a rota default:
$route

Veja se possui uma linha com a primeira coluna escrito default e a ultima escrito sua interface. (Deve ser ppp0)

Verifique se o DNS foi incluido:
$cat /etc/resolv.conf


Caso esteja tudo OK, passe o log:
$tail -f /var/log/messages > log
#Conecte o 3G mande discar e envie a saida acima
#Precisa dar um <Ctrl+C> para sair do comando acima




4. Re: Modem E156 Claro no Ubuntu 9.04 [RESOLVIDO]

Ednilton Santos de Oliveira
ednilton_so

(usa KUbuntu)

Enviado em 01/09/2009 - 09:46h

Olá amigo,

Você tem que remover o DNS que o networmanager (gerenciador de redes) dá pra sua rede.

Tente isso:
Clique com botão direito no ícone do networkmanager &#8594; editar conexões. Se pedir pra autorização,
clique em autorizar (sempre, eu acho). Vá na aba "banda larga móvel". Clique em adicionar,
escolha a operadora, avance, escolha e aceite o nome da conexão e clique em aplicar.

Depois disso, ainda na janela de edição da "banda larga móvel", marque "disponível para todos usuários".
Ainda na mesma janela, vá na aba "configuração ppp". Nos métodos permitidos, deixe selecionado
apenas "PAP". Na seção "Compactação" deixe marcado apenas "Usar compactação de cabeçalho TCP".
Na seção "Eco", marque "Enviar pacotes de eco PPP". Finalmente, na mesma janela, na aba
"Confiurações IPv4", na seção "Método", em vez de "Somente endereços (PPP) automáticos", deixe
"Automático (PPP)". Pronto. Tente conectar. Se pedir para algo ser instalado, instale. Se não
conectar da primeira vez, tente mais algumas.

Aqui funciona com Ubuntu 9.04, modem Hauwei e160 com a net da TIM.

Abraço.


5. Re: Modem E156 Claro no Ubuntu 9.04 [RESOLVIDO]

Luiz Eduardo
luizedrd

(usa Ubuntu)

Enviado em 01/09/2009 - 20:28h

Valeu mesmo!


6. Deu certo^^

João Luiz Dos Santos Junior
resetmba123

(usa Ubuntu)

Enviado em 15/10/2009 - 13:00h

aew sou novo no linux... e seguir a risca as dicas do amigo "ednilton" e deu tudo certin aqui a internet conectou e tenho uma leve impressão de que ela está mais rapida de que..quando eu usava no windows...vlws aew


7. ...ainda nada :(

ianny
iamo

(usa Ubuntu)

Enviado em 17/10/2009 - 15:37h

opa pessoal, infelizmente nao estou conseguindo me conectar com o modem 3g.
Meu OS é um EasyPeasy (ubuntu 9.04) kernel 2.6.30.5. O modem é um Huawei E156C da operadora OI.
Ao plugar, pela primeira vez, o modem no netbook, o sistema operacional o detecta e inicia o wizard de configuraçao automatica.
Seleciono OI entre as opçoes de operadoras.
Depois, nas configuraçoes do networkmanager, encontro algums dados ja preenchidos quais:
numero: *99#
nome usuario: em branco/vazio
senha: ****** #ocultada: oioioi
APN: gprs.oi.com.br

enfim configuro como o amigo EDNILTON manda fazer...mas sem nenhum sucesso.
Ja tentei varias opçoes de configuraçao...mas nada.
valeu!!!



8. Re: Modem E156 Claro no Ubuntu 9.04 [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 17/10/2009 - 16:33h

experimentou colocar os dns como tudo automatico??? no networkmanager


9. Re: Modem E156 Claro no Ubuntu 9.04 [RESOLVIDO]

ianny
iamo

(usa Ubuntu)

Enviado em 17/10/2009 - 16:44h

Opa VFS,
sim deixei os DNS em automatico

...na seção "Método", em vez de "Somente endereços (PPP) automáticos", deixe
"Automático (PPP)".....


10. Re: Modem E156 Claro no Ubuntu 9.04 [RESOLVIDO]

ianny
iamo

(usa Ubuntu)

Enviado em 17/10/2009 - 19:48h

lendo o resultado do meu /var/log/syslog, pode se ver que o modem consegue se conectar mas logo depois se desconecta!!!

...
Oct 17 19:34:45 simone-eee NetworkManager: <info> Activation (ttyUSB0) starting connection 'Oi_3g'
Oct 17 19:34:45 simone-eee NetworkManager: <info> (ttyUSB0): device state change: 3 -> 4
Oct 17 19:34:45 simone-eee NetworkManager: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) scheduled...
Oct 17 19:34:45 simone-eee NetworkManager: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) started...
Oct 17 19:34:45 simone-eee NetworkManager: <debug> [1255818885.940154] nm_serial_device_open(): (ttyUSB0) opening device...
Oct 17 19:34:45 simone-eee NetworkManager: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) complete.
Oct 17 19:34:46 simone-eee NetworkManager: <info> (ttyUSB0): powering up...
Oct 17 19:34:46 simone-eee NetworkManager: <info> Registered on Home network
Oct 17 19:34:46 simone-eee NetworkManager: <info> Associated with network: +COPS: 0,0,"OI 3G 48",2
Oct 17 19:34:46 simone-eee NetworkManager: <info> Connected, Woo!
Oct 17 19:34:46 simone-eee NetworkManager: <info> Activation (ttyUSB0) Stage 2 of 5 (Device Configure) scheduled...
Oct 17 19:34:46 simone-eee NetworkManager: <info> Activation (ttyUSB0) Stage 2 of 5 (Device Configure) starting...
Oct 17 19:34:46 simone-eee NetworkManager: <info> (ttyUSB0): device state change: 4 -> 5
Oct 17 19:34:46 simone-eee NetworkManager: <info> Starting pppd connection
Oct 17 19:34:46 simone-eee NetworkManager: <debug> [1255818886.414695] nm_ppp_manager_start(): Command line: /usr/sbin/pppd nodetach lock nodefaultroute ttyUSB0 noipdefault noauth usepeerdns lcp-echo-failure 0 lcp-echo-interval 0 ipparam /org/freedesktop/NetworkManager/PPP/5 plugin /usr/lib/pppd/2.4.4/nm-pppd-plugin.so
Oct 17 19:34:46 simone-eee NetworkManager: <debug> [1255818886.420439] nm_ppp_manager_start(): ppp started with pid 4635
Oct 17 19:34:46 simone-eee NetworkManager: <info> Activation (ttyUSB0) Stage 2 of 5 (Device Configure) complete.
Oct 17 19:34:46 simone-eee pppd[4635]: Plugin /usr/lib/pppd/2.4.4/nm-pppd-plugin.so loaded.
Oct 17 19:34:46 simone-eee pppd[4635]: pppd 2.4.5 started by root, uid 0
Oct 17 19:34:46 simone-eee pppd[4635]: Using interface ppp0
Oct 17 19:34:46 simone-eee pppd[4635]: Connect: ppp0 <--> /dev/ttyUSB0
Oct 17 19:34:46 simone-eee NetworkManager: <info> (ttyUSB0): device state change: 5 -> 6
Oct 17 19:34:46 simone-eee NetworkManager: <info> (ttyUSB0): device state change: 6 -> 7
Oct 17 19:34:47 simone-eee pppd[4635]: Modem hangup
Oct 17 19:34:47 simone-eee pppd[4635]: Connection terminated.
Oct 17 19:34:47 simone-eee NetworkManager: <info> (ttyUSB0): device state change: 7 -> 9
Oct 17 19:34:47 simone-eee NetworkManager: <debug> [1255818887.881530] nm_serial_device_close(): Closing device 'ttyUSB0'
Oct 17 19:34:47 simone-eee NetworkManager: <info> Marking connection 'Oi_3g' invalid.
Oct 17 19:34:47 simone-eee NetworkManager: <info> Activation (ttyUSB0) failed.
Oct 17 19:34:47 simone-eee NetworkManager: <info> (ttyUSB0): device state change: 9 -> 3
Oct 17 19:34:47 simone-eee NetworkManager: <info> (ttyUSB0): deactivating device (reason: 0).
Oct 17 19:34:47 simone-eee NetworkManager: nm_system_device_flush_ip4_routes_with_iface: assertion `iface_idx >= 0' failed
Oct 17 19:34:47 simone-eee NetworkManager: nm_system_device_flush_ip4_addresses_with_iface: assertion `iface_idx >= 0' failed
Oct 17 19:34:48 simone-eee pppd[4635]: Exit.
Oct 17 19:34:50 simone-eee NetworkManager: <debug> [1255818890.000572] ensure_killed(): waiting for ppp pid 4635 to exit
Oct 17 19:34:50 simone-eee NetworkManager: <debug> [1255818890.000970] ensure_killed(): ppp pid 4635 cleaned up
....


11. resolvido

Bruno Maia Serralheiro
brunix.java

(usa Fedora)

Enviado em 22/11/2009 - 20:07h

resposta de iamo está correta!
Obrigado pela dica,

Bruno Maia Serralheiro
Java Developer
http://brunoserralheiro.com




12. Re: Modem E156 Claro no Ubuntu 9.04 [RESOLVIDO]

j g meinhardt
meinhardt_jgbr

(usa Debian)

Enviado em 22/11/2009 - 21:56h

Bom conteudo para quem pretende usar internet 3G.



01 02