Debian 10.3 Non-Free com WIFI indisponível

1. Debian 10.3 Non-Free com WIFI indisponível

Ruann
ruannyury

(usa Debian)

Enviado em 26/03/2020 - 13:22h

Minha placa de rede: Network controller: Intel Corporation Dual Band Wireless-AC 3165 Plus Bluetooth
Pessoal, instalei o Debian non-free, pois, por usar notebook, o Debian oficial não reconhecia minha placa de rede. Na instalação ocorreu tudo conforme a normalidade; ele detectou minha placa de rede e instalou normalmente. Contudo, após a instalação, o WIFI não funciona. Nas configurações de WIFI diz: "WIFI Indisponível. Conecte um adaptador WIRELESS", mais ou menos isso. Eu realmente tenho que comprar o adaptador ou há alguma forma de consertar? Já tentei instalar os firmwares de WIFI manualmente pelo pen drive, mas não deu certo mesmo assim.


  


2. Re: Debian 10.3 Non-Free com WIFI indisponível

Dennis Lessa
dennislessa

(usa Debian)

Enviado em 10/04/2020 - 22:13h

Eu também estou com o mesmo problema. Desde que comprei o meu pc Lenovo eu não consigo fazer o wifi funcionar.


00:00.0 Host bridge: Intel Corporation Device 3e34 (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Device 3ea0 (rev 02)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 0c)
00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th Gen Core Processor Gaussian Mixture Model
00:12.0 Signal processing controller: Intel Corporation Device 9df9 (rev 30)
00:14.0 USB controller: Intel Corporation Device 9ded (rev 30)
00:14.2 RAM memory: Intel Corporation Device 9def (rev 30)
00:15.0 Serial bus controller [0c80]: Intel Corporation Device 9de8 (rev 30)
00:16.0 Communication controller: Intel Corporation Device 9de0 (rev 30)
00:17.0 SATA controller: Intel Corporation Device 9dd3 (rev 30)
00:1c.0 PCI bridge: Intel Corporation Device 9dbc (rev f0)
00:1d.0 PCI bridge: Intel Corporation Device 9db0 (rev f0)
00:1e.0 Communication controller: Intel Corporation Device 9da8 (rev 30)
00:1f.0 ISA bridge: Intel Corporation Device 9d84 (rev 30)
00:1f.3 Audio device: Intel Corporation Device 9dc8 (rev 30)
00:1f.4 SMBus: Intel Corporation Device 9da3 (rev 30)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Device 9da4 (rev 30)
01:00.0 3D controller: NVIDIA Corporation GM108M [GeForce MX110] (rev a2)
02:00.0 Network controller: Intel Corporation Dual Band Wireless-AC 3165 Plus Bluetooth (rev 99)


Esse foi o resultado mostrado pelo comando lspci.


3. Re: Debian 10.3 Non-Free com WIFI indisponível

Paulo Jr
Pebis

(usa Debian)

Enviado em 10/04/2020 - 22:24h

Ativa o repositório non-free e tenta aí!

sudo apt update && apt install firmware-iwlwifi
sudo modprobe -r iwlwifi ; modprobe iwlwifi


4. Re: Debian 10.3 Non-Free com WIFI indisponível

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 10/04/2020 - 22:40h

Instale driver:
firmware-iwlwifi



5. Não deu certo

Dennis Lessa
dennislessa

(usa Debian)

Enviado em 11/04/2020 - 12:49h

Editei o arquivo sources.list adicionando o contrib non-free, fiz o update e instalei o firmware.

# apt install firmware-iwlwifi 


Versão do kernel:

4.19.0-8-amd64


Ele instalou corretamente e agora está aparecendo o simbolo do WIFI. Porém, ele fica sempre desligado. Quando clico em LIGAR nada acontece. As minhas redes não aparecem para que eu possa me conectar.

Estou usando o GNOME como interface (não se isso vai ajudar, rs).

AH! E agora que eu percebi. Também não aparece o simbolo da bateria.


6. Re: Debian 10.3 Non-Free com WIFI indisponível

Paulo Jr
Pebis

(usa Debian)

Enviado em 11/04/2020 - 13:30h


dennislessa escreveu:

Editei o arquivo sources.list adicionando o contrib non-free, fiz o update e instalei o firmware.

# apt install firmware-iwlwifi 


Versão do kernel:

4.19.0-8-amd64


Ele instalou corretamente e agora está aparecendo o simbolo do WIFI. Porém, ele fica sempre desligado. Quando clico em LIGAR nada acontece. As minhas redes não aparecem para que eu possa me conectar.

Estou usando o GNOME como interface (não se isso vai ajudar, rs).

AH! E agora que eu percebi. Também não aparece o simbolo da bateria.



CArregou o módulo ou então reiniciou a máquina?



7. Carregamento dos módulos não funcionou

Dennis Lessa
dennislessa

(usa Debian)

Enviado em 11/04/2020 - 15:50h

Eu carreguei os modulos após a instalação do firmware e reiniciei a máquina.

 # /sbin/modprobe -r iwlwifi  


nada aconteceu.

Instalei o wicd; ele consegue visualizar as redes (SSID) porém não consegue ligar o wifi.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts