problemas MACRABO!!! me ajudem!!! [RESOLVIDO]

1. problemas MACRABO!!! me ajudem!!! [RESOLVIDO]

Andre Moreira
general_IP

(usa Fedora)

Enviado em 14/02/2009 - 18:47h

Boa Tarde colegas.. to com muita dificudades para sanar meu problema. Atualmente tenho um servidor linux (fedora 9) configurado como um roteador e duas maquinas ruindows (windows rsss).
Entao o linux compartilha a internet com + duas maquinas. Só que a internet fuciona parcialmente.
por exemplo, acesso o www.ig.com.br, as duas maquinas e as paginas abrem perfeitamente. Quando acesso o www.google.com.br, ambas maquinas nao abrem nada. entao chequei os item:
ping www.ig.com.br = ok, pinga.
ping www.google.com.br = ok também pinga.

entao mandei o comando nslookup www.ig.com.br 10.0.0.4 (ip local do meu servidor DNS (linux)) e aparece:

nslookup www.ig.com.br 10.0.0.4

DNS request timed out.
timeout was 2 seconds.
*** Can't find server name for address 10.0.0.4: Timed out
Server: UnKnown
Address: 10.0.0.4

Non-authoritative answer:
Name: www.ig.com.br
Address: 200.226.133.74

entao digito: nslookup www.google.com.br 10.0.0.4 e aparece:

DNS request timed out.
timeout was 2 seconds.
*** Can't find server name for address 10.0.0.4: Timed out
Server: UnKnown
Address: 10.0.0.4

DNS request timed out.
timeout was 2 seconds.
DNS request timed out.
timeout was 2 seconds.
*** Request to UnKnown timed-out



resumo: isso faz com que as duas maquinas naveguem parcialmente .. nao 100%, ou seja, tem algumas paginas que fuciona e outras nao. Algumas paginas o DNS resolve os nomes e outras nao.

o que fazer?? o arquivo named.conf tá assim:

//
// named.caching-nameserver.conf
//
// Provided by Red Hat caching-nameserver package to configure the
// ISC BIND named(8) DNS server as a caching only nameserver
// (as a localhost DNS resolver only).
//
// See /usr/share/doc/bind*/sample/ for example named configuration files.
//
// DO NOT EDIT THIS FILE - use system-config-bind or an editor
// to create named.conf - edits to this file will be lost on
// caching-nameserver package upgrade.
//

options {
// listen-on port 53 { 127.0.0.1; };
// listen-on-v6 port 53 { ::1; };
directory "/var/named";
dump-file "/var/named/data/cache_dump.db";
statistics-file "/var/named/data/named_stats.txt";
memstatistics-file "/var/named/data/named_mem_stats.txt";
// allow-query { localhost; };
// recursion yes;
};

logging {
channel default_debug {
file "data/named.run";
severity dynamic;
};
};

zone "." IN {
type hint;
file "named.ca";
};

include "/etc/named.rfc1912.zones";


alguém tem uma luz???????




  


2. Re: problemas MACRABO!!! me ajudem!!! [RESOLVIDO]

Diego Hernandes Soares Alves
diegohsa

(usa Arch Linux)

Enviado em 14/02/2009 - 19:28h

1) Vai uma dica, Fedora 9 de servidor eu não considero uma boa opção, se você tem pouca experiência (não sei se é o caso), utilize o Ubuntu-server edition, vai ser fácio fazer o que está tentando!

2) O problema aparentemente é seu servidor, você instalou um servidor de dns????
caso sim, nas maquinas clientes configure o DNS primario com o mesmo endereço que utiliza no getway.

se isso não resolver, explique melhor como fez a configuração, qual é a fonte da internet e como está o seu servidor.
às ordens!


3. Re: problemas MACRABO!!! me ajudem!!! [RESOLVIDO]

Pedro Pereira
pogo

(usa Fedora)

Enviado em 14/02/2009 - 23:12h

outra coisa que você pode fazer (q é o que faço aqui em casa) é configurar os dns's do seu provedor nas máquinas windows... aí vc não precisa de um servidor dns na sua rede...

[]'s

pogo


4. resolvido

Andre Moreira
general_IP

(usa Fedora)

Enviado em 14/02/2009 - 23:50h

colegas, resolvi meu problema. Muito obrigado pelas dicas...


5. Re: problemas MACRABO!!! me ajudem!!! [RESOLVIDO]

Marcus-RJ
Marcus-RJ

(usa Arch Linux)

Enviado em 15/02/2009 - 00:26h

" colegas, resolvi meu problema. Muito obrigado pelas dicas..."

Seria bom se pudesse postar a solução para servir de ajuda a quem, futuramente, venha ter um problema
semelhante.

Abs, fique com Deus!



6. resolvido

Andre Moreira
general_IP

(usa Fedora)

Enviado em 16/02/2009 - 07:32h

bom dia.. pois entao, resolvi o meu problema, seguindo as orientações do diego, instalei o ubuntu server, pois ao configura-lo como um roteador, funcionou sem problemas.... ja nao tive a mesma sorte com o fedora, na verdade nao sei ao certo porque o fedora nao fucionou, mas o ubuntu deu certo... mais uma vez, obrigado pela ajuda....