erro do kivy

1. erro do kivy

noah felix
noah_g4

(usa Ubuntu)

Enviado em 08/08/2020 - 16:12h

estou desenvolvendo um app com o python3 e o gui kivy no ubuntu 20LTS wls(windows sub-system linux) e me deparo com esse erro quando executo o script

script:

from kivy.app import App
from kivy.uix.button import Button

class inicio(App):
def build(self):
return Button(text = "ola mundo!!!")

inicio().run()


error:

error: XDG_RUNTIME_DIR not set in the environment.
[CRITICAL] [Window ] Unable to find any valuable Window provider.
egl_rpi - ImportError: cannot import name 'bcm' from 'kivy.lib.vidcore_lite' (/usr/lib/python3/dist-packages/kivy/lib/vidcore_lite/__init__.py)
File "/usr/lib/python3/dist-packages/kivy/core/__init__.py", line 55, in core_select_lib
mod = __import__(name='{2}.{0}.{1}'.format(
File "/usr/lib/python3/dist-packages/kivy/core/window/window_egl_rpi.py", line 12, in <module>
from kivy.lib.vidcore_lite import bcm, egl

sdl2 - RuntimeError: b'No available video device'
File "/usr/lib/python3/dist-packages/kivy/core/__init__.py", line 67, in core_select_lib
cls = cls()
File "/usr/lib/python3/dist-packages/kivy/core/window/window_sdl2.py", line 140, in __init__
super(WindowSDL, self).__init__()
File "/usr/lib/python3/dist-packages/kivy/core/window/__init__.py", line 968, in __init__
self.create_window()
File "/usr/lib/python3/dist-packages/kivy/core/window/window_sdl2.py", line 270, in create_window
self.system_size = _size = self._win.setup_window(
File "kivy/core/window/_window_sdl2.pyx", line 93, in kivy.core.window._window_sdl2._WindowSDL2Storage.setup_window
File "kivy/core/window/_window_sdl2.pyx", line 66, in kivy.core.window._window_sdl2._WindowSDL2Storage.die

x11 - ModuleNotFoundError: No module named 'kivy.core.window.window_x11'
File "/usr/lib/python3/dist-packages/kivy/core/__init__.py", line 55, in core_select_lib
mod = __import__(name='{2}.{0}.{1}'.format(

[CRITICAL] [App ] Unable to get a Window, abort.


não consegui identificar o erro poderiam me dizer o erro ou a solução do problema



  


2. Re: erro do kivy

Fábio Berbert de Paula
fabio

(usa Debian)

Enviado em 08/08/2020 - 16:32h

Amigo, provavelmente estão faltando dependências no teu Python. Executei o seu código aqui sem problemas... dei uma pesquisada e a sequência de comandos abaixo provavelmente irá resolver seu pepino:

pip install --upgrade pip wheel setuptools
pip install docutils pygments pypiwin32 kivy.deps.sdl2 kivy.deps.glew
pip install kivy.deps.gstreamer
pip install kivy.deps.angle
pip install kivy





3. Re: erro do kivy

noah felix
noah_g4

(usa Ubuntu)

Enviado em 08/08/2020 - 17:39h

fabio escreveu:

Amigo, provavelmente estão faltando dependências no teu Python. Executei o seu código aqui sem problemas... dei uma pesquisada e a sequência de comandos abaixo provavelmente irá resolver seu pepino:

pip install --upgrade pip wheel setuptools
pip install docutils pygments pypiwin32 kivy.deps.sdl2 kivy.deps.glew
pip install kivy.deps.gstreamer
pip install kivy.deps.angle
pip install kivy




olá, quando eu estava instalando e eu tive um problema na instalação do kivy-deps.<nome> e no pypiwin32
já procurei no python packeges mas nçã teve diferencia
aqui esta o erro

ERROR: Could not find a version that satisfies the requirement kivy-deps-glew (from versions: none)
ERROR: No matching distribution found for kivy-deps-glew

ERROR: Could not find a version that satisfies the requirement pywin32>=223 (from pypiwin32) (from versions: none)
ERROR: No matching distribution found for pywin32>=223 (from pypiwin32)

ERROR: Could not find a version that satisfies the requirement kivy-deps.sdl2==0.2.0 (from versions: none)
ERROR: No matching distribution found for kivy-deps.sdl2==0.2.0

ERROR: Could not find a version that satisfies the requirement kivy-deps.gstreamer (from versions: none)
ERROR: No matching distribution found for kivy-deps.gstreamer

ERROR: Could not find a version that satisfies the requirement kivy-deps.angle (from versions: none)
ERROR: No matching distribution found for kivy-deps.angle


4. Re: erro do kivy

Fábio Berbert de Paula
fabio

(usa Debian)

Enviado em 09/08/2020 - 10:57h

Sem conseguir instalar tais dependências o código não irá executar. Não sei como ajudar pq não consegui replicar o erro, aqui instalou tudo de boa.

Está usando que distribuição e versão do Python?






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts