Problemas ao rodar programa em python!

1. Problemas ao rodar programa em python!

Edson
brenno14

(usa Kali)

Enviado em 08/03/2021 - 17:11h

Boa tarde! Pessoal eu estou com um sério problema quanto ao python, pelo qual eu não estou conseguindo iniciar e nem instalar programas por conta de tal. O problema é o seguinte:
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Python path configuration:
PYTHONHOME = (not set)
PYTHONPATH = (not set)
program name = '/usr/bin/python3.9'
isolated = 0
environment = 1
user site = 1
import site = 1
sys._base_executable = '/usr/bin/python3.9'
sys.base_prefix = '/usr'
sys.base_exec_prefix = '/usr'
sys.platlibdir = 'lib'
sys.executable = '/usr/bin/python3.9'
sys.prefix = '/usr'
sys.exec_prefix = '/usr'
sys.path = [
'/usr/lib/python39.zip',
'/usr/lib/python3.9',
'/usr/lib/lib-dynload',
]
Fatal Python error: init_fs_encoding: failed to get the Python codec of the filesystem encoding
Python runtime state: core initialized
ModuleNotFoundError: No module named 'encodings'

Current thread 0x00007f8ffd412740 (most recent call first):
<no Python frame>

Ja tentei várias formas, porém não funcionaram.


  


2. Re: Problemas ao rodar programa em python!

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 08/03/2021 - 20:48h


chegou a fazer alguma atualização ou alteração e removeu algo relacionado ao python ?


3. Re: Problemas ao rodar programa em python!

Adriano Christi
ACMM

(usa Ubuntu)

Enviado em 11/03/2021 - 15:29h


Se for o caso de estarem faltando dependências do Python, tenta isso no terminal:

sudo apt install --upgrade dpkg-dev build-essential python3-dev libncursesw5-dev libsqlite3-dev libreadline-dev libbz2-dev libffi-dev libssl-dev libgdbm-dev zlib1g-dev libjpeg-dev libtiff-dev libpq-dev libxml2-dev libxslt1-dev libsdl2-dev libgstreamer-plugins-base1.0-dev libnotify-dev freeglut3-dev libsm-dev libgtk-3-dev libwebkitgtk-3.0-dev libxtst-dev -y
sudo apt install --upgrade build-essential checkinstall
sudo apt install --upgrade libreadline-gplv2-dev libncursesw5-dev libssl-dev libsqlite3-dev tk-dev libgdbm-dev libc6-dev libbz2-dev libffi-dev zlib1g-dev


Caso não resolva, tenta reinstalar o Python e eu creio que resolva tudo.

Guns don't kill people. People kill people.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts