Instalação do python-igraph via pip3

1. Instalação do python-igraph via pip3

Lucas Gabriel
LucasTAraujo

(usa Linux Mint)

Enviado em 21/07/2020 - 10:55h

Olá a todos,
Tenho o igraph instado via apt no zorin-Os, mas ele está na versão 0.7.1 e eu preciso atualizar para a 0.8.0. No apt ainda está na versão anterior e via pip3 não é possível atualizar, nem instalar (inclusive desinstalei o pacote do apt para instalar para tentar reinstalar pelo pip).


# pip3 install -q python-igraph
Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-tl_0n02k/python-igraph/setup.py';
f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))"
install --record /tmp/pip-wkfewb6s-record/install-record.txt --single-version-externally-managed --compile"
failed with error code 1 in /tmp/pip-build-tl_0n02k/python-igraph/


Sempre dá esse erro, já tentei instalar as dependências separadamente, mas mesmo assim não deu certo.
Já agradeço pela ajuda.


  






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts