Erro ao tentar atualizar o python

1. Erro ao tentar atualizar o python

Kcer Crazy
Kcer

(usa Linux Mint)

Enviado em 18/10/2017 - 02:17h

Segue o problema>> ~/Python-3.6.3 $ ./configure
./configure: line 2330: config.log: Permission denied
./configure: line 2340: config.log: Permission denied



  


2. Re: Erro ao tentar atualizar o python

Lisandro Guerra
Lisandro

(usa Linux Mint)

Enviado em 18/10/2017 - 10:08h

Olá. Não é uma boa ideia atualizar o Python do sistema, você pode quebrar seu sistema fazendo isso. O melhor é usar algum gerenciador de versões como o pyenv e usar o venv ou outro criador de ambientes de desenvolvimento para restringir a versão desejada ao seu diretório de estudo ou ao seu projeto .
Procure aqui no VOL, tenho artigos e dicas sobre isso.
Abraço


3. Re: Erro ao tentar atualizar o python

Kcer Crazy
Kcer

(usa Linux Mint)

Enviado em 19/10/2017 - 23:25h

Lisandro escreveu:

Olá. Não é uma boa ideia atualizar o Python do sistema, você pode quebrar seu sistema fazendo isso. O melhor é usar algum gerenciador de versões como o pyenv e usar o venv ou outro criador de ambientes de desenvolvimento para restringir a versão desejada ao seu diretório de estudo ou ao seu projeto .
Procure aqui no VOL, tenho artigos e dicas sobre isso.
Abraço


Cara eu tentei instalar o pyenv mais nao ta dando certo sempre tem um problema aqui ali. até tentei instalar pelo seu tutorial postado aqui no VOL mais nao deu certo


4. Re: Erro ao tentar atualizar o python

Lisandro Guerra
Lisandro

(usa Linux Mint)

Enviado em 20/10/2017 - 08:24h

Kcer escreveu:

Lisandro escreveu:

Olá. Não é uma boa ideia atualizar o Python do sistema, você pode quebrar seu sistema fazendo isso. O melhor é usar algum gerenciador de versões como o pyenv e usar o venv ou outro criador de ambientes de desenvolvimento para restringir a versão desejada ao seu diretório de estudo ou ao seu projeto .
Procure aqui no VOL, tenho artigos e dicas sobre isso.
Abraço


Cara eu tentei instalar o pyenv mais nao ta dando certo sempre tem um problema aqui ali. até tentei instalar pelo seu tutorial postado aqui no VOL mais nao deu certo


Qual versão do Mint está usando?
Qual erro dá?

Aguardo


5. Re: Erro ao tentar atualizar o python

Kcer Crazy
Kcer

(usa Linux Mint)

Enviado em 21/10/2017 - 14:24h

Lisandro escreveu:

Qual versão do Mint está usando?
Qual erro dá?


Aguardo[/quote]

A minha versão é a 18.1 Serena

Cara ao tentar da o segundo comando>>
$ sudo apt-get install -y make build-essential libssl-dev zlib1g-dev libbz2-dev libreadline-dev libsqlite3-dev wget curl llvm libncurses5-dev git
[sudo] senha para kcer:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
build-essential is already the newest version (12.1ubuntu2).
libbz2-dev is already the newest version (1.0.6-8).
libncurses5-dev is already the newest version (6.0+20160213-1ubuntu1).
libreadline-dev is already the newest version (6.3-8ubuntu2).
libsqlite3-dev is already the newest version (3.11.0-1ubuntu1).
make is already the newest version (4.1-6).
curl is already the newest version (7.47.0-1ubuntu2.3).
git is already the newest version (1:2.7.4-0ubuntu1.3).
libssl-dev is already the newest version (1.0.2g-1ubuntu4.8).
wget is already the newest version (1.17.1-1ubuntu1.2).
zlib1g-dev is already the newest version (1:1.2.8.dfsg-2ubuntu4.1).
llvm is already the newest version (1:3.8-33ubuntu3.1).
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 12 não atualizados.




6. Re: Erro ao tentar atualizar o python

Lisandro Guerra
Lisandro

(usa Linux Mint)

Enviado em 21/10/2017 - 23:52h

Kcer escreveu:

Lisandro escreveu:

Qual versão do Mint está usando?
Qual erro dá?


Aguardo


A minha versão é a 18.1 Serena

Cara ao tentar da o segundo comando>>
$ sudo apt-get install -y make build-essential libssl-dev zlib1g-dev libbz2-dev libreadline-dev libsqlite3-dev wget curl llvm libncurses5-dev git
[sudo] senha para kcer:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
build-essential is already the newest version (12.1ubuntu2).
libbz2-dev is already the newest version (1.0.6-8).
libncurses5-dev is already the newest version (6.0+20160213-1ubuntu1).
libreadline-dev is already the newest version (6.3-8ubuntu2).
libsqlite3-dev is already the newest version (3.11.0-1ubuntu1).
make is already the newest version (4.1-6).
curl is already the newest version (7.47.0-1ubuntu2.3).
git is already the newest version (1:2.7.4-0ubuntu1.3).
libssl-dev is already the newest version (1.0.2g-1ubuntu4.8).
wget is already the newest version (1.17.1-1ubuntu1.2).
zlib1g-dev is already the newest version (1:1.2.8.dfsg-2ubuntu4.1).
llvm is already the newest version (1:3.8-33ubuntu3.1).
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 12 não atualizados.

[/quote]

Mas não tem erro aqui! Só está dizendo que tudo já está instalado em uma versão mais nova.
Siga em frente que deve funcionar.
Abraço






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts