Erro ao executar a IDE Pycharm-Community-2018.2 [RESOLVIDO]

1. Erro ao executar a IDE Pycharm-Community-2018.2 [RESOLVIDO]

Ryu O Dragão
RyuUnix

(usa Ubuntu)

Enviado em 05/12/2018 - 17:10h

Sou iniciante em programação e estou começando com a linguagem Python. No curso que estou fazendo; o professor usará a IDE Pycharm-Professinal, então instalei a versão Community-2018.2 no meu sistema, porém ao executá-lo apareceu a seguinte janela com essa mensagem de erro!
Failed to Create Interpreter

/tmp/tmpmmzhwpdzpycharm-management/ setuptools-39.1.0/setup.py install
Error occurred:
ModuleNotFoundError: No module named 'distutils.core'
Command output:
Traceback (most recet call last):
File "/tmp/tmpmmzhwpdzpycharm-management/setuptools-39.1.0/setup.py", Line
import setuptools
File "/tmp/tmpmmzhwpdzpycharm-management/setuptools-39.1.0
import distutils.core

Alguém sabe como resolver?


  


2. MELHOR RESPOSTA

-
BiaMonteiro

(usa Arch Linux)

Enviado em 05/12/2018 - 18:03h

Segundo consta no seu perfil, sua distribuição é o Ubuntu. Supondo que seja isso mesmo,
rode o comando:

sudo apt install python-setuptools python-distutils-extra python3-setuptools python3-distutils-extra


Deverá consertar o problema!

3. Re: Erro ao executar a IDE Pycharm-Community-2018.2 [RESOLVIDO]

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 05/12/2018 - 17:47h

Olha, lendo suas mensagens, me parece, faltam os pacotes "distutils" e "setuptools"

¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


4. Re: Erro ao executar a IDE Pycharm-Community-2018.2

Ryu O Dragão
RyuUnix

(usa Ubuntu)

Enviado em 05/12/2018 - 18:04h

albfneto escreveu:

Olha, lendo suas mensagens, me parece, faltam os pacotes "distutils" e "setuptools"

¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


Eu instalei o Pycharm pelo novo repositório do Ubuntu o Snappy: snap install pycharm-community-2018.2. Devo usar snap install para instalar as pendencias ou apt-get ou tanto faz um outro?




5. Re: Erro ao executar a IDE Pycharm-Community-2018.2 [RESOLVIDO]

Ryu O Dragão
RyuUnix

(usa Ubuntu)

Enviado em 05/12/2018 - 18:06h

BiaMonteiro escreveu:

Segundo consta no seu perfil, sua distribuição é o Ubuntu. Supondo que seja isso mesmo,
rode o comando:

sudo apt install python-setuptools python-distutils-extra python3-setuptools python3-distutils-extra


Deverá consertar o problema!

É Ubuntu-Mate na verdade!

Eu instalei o Pycharm pelo novo repositório do Ubuntu o Snappy: snap install pycharm-community-2018.2. Devo usar snap install para instalar as pendencias ou apt-get ou tanto faz um outro?




6. Re: Erro ao executar a IDE Pycharm-Community-2018.2 [RESOLVIDO]

-
BiaMonteiro

(usa Arch Linux)

Enviado em 05/12/2018 - 18:58h

RyuUnix escreveu:

BiaMonteiro escreveu:

Segundo consta no seu perfil, sua distribuição é o Ubuntu. Supondo que seja isso mesmo,
rode o comando:

sudo apt install python-setuptools python-distutils-extra python3-setuptools python3-distutils-extra


Deverá consertar o problema!

É Ubuntu-Mate na verdade!

Eu instalei o Pycharm pelo novo repositório do Ubuntu o Snappy: snap install pycharm-community-2018.2. Devo usar snap install para instalar as pendencias ou apt-get ou tanto faz um outro?


Pra falar a verdade, nunca usei pacote Snap na vida nem pretendo usar, então não sei responder com certeza.
Mas acredito que você pode usar o apt sim. Se der problema, você apenas desfaz o que fez.


7. Re: Erro ao executar a IDE Pycharm-Community-2018.2 [RESOLVIDO]

Fábio Berbert de Paula
fabio

(usa Debian)

Enviado em 05/12/2018 - 19:27h

Pode instalar pelo apt sem medo. Esses pacotes na verdade são bem essenciais para a maioria das aplicações em Python, então fará até bem instalá-los via apt.

Antes de rodar o Pycharm novamente, teste se o módulo está ok com:

$ python3 -m distutils.core




8. Re: Erro ao executar a IDE Pycharm-Community-2018.2 [RESOLVIDO]

Ryu O Dragão
RyuUnix

(usa Ubuntu)

Enviado em 06/12/2018 - 09:20h

fabio escreveu:

Pode instalar pelo apt sem medo. Esses pacotes na verdade são bem essenciais para a maioria das aplicações em Python, então fará até bem instalá-los via apt.

Antes de rodar o Pycharm novamente, teste se o módulo está ok com:

$ python3 -m distutils.core



A mensagem que apareceu foi essa: /usr/bin/python3: No module named distutils.core




9. Re: Erro ao executar a IDE Pycharm-Community-2018.2 [RESOLVIDO]

Ryu O Dragão
RyuUnix

(usa Ubuntu)

Enviado em 06/12/2018 - 09:40h

fabio escreveu:

Pode instalar pelo apt sem medo. Esses pacotes na verdade são bem essenciais para a maioria das aplicações em Python, então fará até bem instalá-los via apt.

Antes de rodar o Pycharm novamente, teste se o módulo está ok com:

$ python3 -m distutils.core



Eu digitei: sudo apt-get install distutils, sudo apt-get install setuptools O terminal não encontra esses pacotes para instalar! E agora? Eu devo desinstalar o Pycharm e tentar instalar por um ppa ou eu tento buscar esses pacotes através de outros repositórios?



10. Re: Erro ao executar a IDE Pycharm-Community-2018.2 [RESOLVIDO]

Fábio Berbert de Paula
fabio

(usa Debian)

Enviado em 06/12/2018 - 09:43h

RyuUnix escreveu:

Eu digitei: sudo apt-get install distutils, sudo apt-get install setuptools O terminal não encontra esses pacotes para instalar! E agora? Eu devo desinstalar o Pycharm e tentar instalar por um ppa ou eu tento buscar esses pacotes através de outros repositórios?


O comando é este aqui que a Bia te passou:

$ sudo apt install python-setuptools python-distutils-extra python3-setuptools python3-distutils-extra


11. Valeu!

Ryu O Dragão
RyuUnix

(usa Ubuntu)

Enviado em 07/12/2018 - 15:42h

BiaMonteiro escreveu:

Segundo consta no seu perfil, sua distribuição é o Ubuntu. Supondo que seja isso mesmo,
rode o comando:

sudo apt install python-setuptools python-distutils-extra python3-setuptools python3-distutils-extra


Deverá consertar o problema!


Funcionou! Eram pendencias faltantes mesmo, vou marca a sua resposta como a melhor. Obrigado!


12. Re: Erro ao executar a IDE Pycharm-Community-2018.2 [RESOLVIDO]

Ryu O Dragão
RyuUnix

(usa Ubuntu)

Enviado em 07/12/2018 - 15:43h

fabio escreveu:

RyuUnix escreveu:

Eu digitei: sudo apt-get install distutils, sudo apt-get install setuptools O terminal não encontra esses pacotes para instalar! E agora? Eu devo desinstalar o Pycharm e tentar instalar por um ppa ou eu tento buscar esses pacotes através de outros repositórios?


O comando é este aqui que a Bia te passou:

$ sudo apt install python-setuptools python-distutils-extra python3-setuptools python3-distutils-extra


Valeu! Eram pendencias faltantes mesmo, agora está tudo certo!







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts