Erro ao instalar "warsaw" para Internet Banking da Caixa ou do Banco Safra, no Lubuntu 17.10

1. Erro ao instalar "warsaw" para Internet Banking da Caixa ou do Banco Safra, no Lubuntu 17.10

Rodrigo Cugnasca dos Santos
RodrigoCugnasca

(usa Lubuntu)

Enviado em 22/02/2018 - 13:52h

Depois de finalizado o processo de instalação pelo instalador de programas, mesmo constando como instalado, este não funciona.
Também fiz a instalação via terminal e ao final da "instalação" deu a seguinte mensagem:

Signature ok
subject=/CN=127.0.0.1
Getting CA Private Key
Installing on Firefox...
Notice: Trust flag u is set automatically if the private key is present.
Installing on system...
Cleaning files...
Ok!
[ ok ] Starting warsaw (via systemctl): warsaw.service.
-su: linha 0: export: `--nofork': não é um identificador válido
-su: linha 0: export: `--nopidfile': não é um identificador válido
-su: linha 0: export: `--systemd-activation': não é um identificador válido
Failed to open connection to "session" message bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")

Alguma solução para isso?

Grato
Rodrigo


  


2. Re: Erro ao instalar "warsaw" para Internet Banking da Caixa ou do Banco Safra, no Lubuntu 17.10

meianoite
meianoite

(usa Nenhuma)

Enviado em 22/02/2018 - 14:20h

RodrigoCugnasca escreveu:

Depois de finalizado o processo de instalação pelo instalador de programas, mesmo constando como instalado, este não funciona.
Também fiz a instalação via terminal e ao final da "instalação" deu a seguinte mensagem:

Signature ok
subject=/CN=127.0.0.1
Getting CA Private Key
Installing on Firefox...
Notice: Trust flag u is set automatically if the private key is present.
Installing on system...
Cleaning files...
Ok!
[ ok ] Starting warsaw (via systemctl): warsaw.service.
-su: linha 0: export: `--nofork': não é um identificador válido
-su: linha 0: export: `--nopidfile': não é um identificador válido
-su: linha 0: export: `--systemd-activation': não é um identificador válido
Failed to open connection to "session" message bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")

Alguma solução para isso?

Grato
Rodrigo



Aviso: O sinalizador de confiança é configurado automaticamente se a chave privada estiver presente.
Falha ao abrir a conexão no barramento de mensagens "sessão": Não foi possível analisar o endereço do servidor: tipo de endereço desconhecido (exemplos de tipos válidos são "tcp" e no UNIX "UNIX")

Pode ser:

firewall ativado no sistema
falta de chave
java não atualizado
firefox não atualizado
Problema no próprio ubuntu



3. Re: Erro ao instalar "warsaw" para Internet Banking da Caixa ou do Banco Safra, no Lubuntu 17.10

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 22/02/2018 - 14:26h

Faz tempo que parei de tentar instalar essa tranqueira, só consigo fazer funcionar no IE, então só estou acessando pelo app no celular !!

Boa sorte !!



------------------------------------------| Linux User #621728 |-----------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------| Linux User #621728 |-----------------------------------------



4. Re: Erro ao instalar

skjdeecedcnfncvnrfcnrncjvnjrnfvjcnjrjvcjrvcj
Londreslondres

(usa Ubuntu)

Enviado em 22/02/2018 - 15:21h

Abra o Synaptic e instale os pacotes: libnss3-tools e libcurl3

Tente instalar o warsaw.
--------------------------------------------------------------------
#voltalisteiro


5. Re: Erro ao instalar "warsaw" para Internet Banking da Caixa ou do Banco Safra, no Lubuntu 17.10

Rodrigo Cugnasca dos Santos
RodrigoCugnasca

(usa Lubuntu)

Enviado em 22/02/2018 - 19:13h

Londreslondres escreveu:

Abra o Synaptic e instale os pacotes: libnss3-tools e libcurl3

Tente instalar o warsaw.
--------------------------------------------------------------------
#voltalisteiro


Boa noite, refiz todo o processo reinstalei os pacotes, mas não funcionou, segui o tutorial do site da caixa e continua o erro:

rodrigo@PC2:~$ sudo apt-get install libnss3-tools libcurl3
[sudo] senha para rodrigo:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
libnss3-tools is already the newest version (2:3.32-1ubuntu3).
libcurl3 is already the newest version (7.55.1-1ubuntu2.3).
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 6 não atualizados.
rodrigo@PC2:~$ cd Downloads/
rodrigo@PC2:~/Downloads$ ls -la
total 36104
drwxr-xr-x 2 rodrigo rodrigo 4096 fev 22 18:45 .
drwxr-xr-x 20 rodrigo rodrigo 4096 fev 22 18:39 ..
-rw-rw-r-- 1 rodrigo rodrigo 18480092 fev 22 18:45 GBPCEFwr64.deb
-rwxrwxr-x 1 rodrigo rodrigo 18480092 fev 22 18:32 warsaw_setup_64.deb
rodrigo@PC2:~/Downloads$ sudo dpkg -i GBPCEFwr64.deb
(Lendo banco de dados ... 159829 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar GBPCEFwr64.deb ...
[ ok ] Stopping warsaw (via systemctl): warsaw.service.
wsatspi: nenhum processo localizado
rm: não foi possível remover '/tmp/wi*': Arquivo ou diretório não encontrado
rm: não foi possível remover '/var/run/shm/sem.wi*': Arquivo ou diretório não encontrado
A descompactar warsaw (1.12.5.1) sobre (1.12.3.11) ...
Configurando warsaw (1.12.5.1) ...
chmod: não foi possível acessar '/usr/local/bin/warsaw/uninstall_core': Arquivo ou diretório não encontrado
Verifying...
Configuring...
Generating certificate...
Generating RSA private key, 4096 bit long modulus
..................++
............................++
e is 65537 (0x10001)
Generating RSA private key, 4096 bit long modulus
....................++
.++
e is 65537 (0x10001)
Signature ok
subject=/CN=127.0.0.1
Getting CA Private Key
Installing on Firefox...
Notice: Trust flag u is set automatically if the private key is present.
Installing on system...
Cleaning files...
Ok!
[ ok ] Starting warsaw (via systemctl): warsaw.service.
-su: linha 0: export: `--nofork': não é um identificador válido
-su: linha 0: export: `--nopidfile': não é um identificador válido
-su: linha 0: export: `--systemd-activation': não é um identificador válido
Failed to open connection to "session" message bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")

(process:1980): dconf-WARNING **: failed to commit changes to dconf: Transporte desconhecido ou sem suporte “systemd” para o endereço “systemd:”
A processar 'triggers' para fontconfig (2.11.94-0ubuntu2) ...
A processar 'triggers' para ureadahead (0.100.0-20) ...
A processar 'triggers' para systemd (234-2ubuntu12.1) ...



6. Re: Erro ao instalar "warsaw" para Internet Banking da Caixa ou do Banco Safra, no Lubuntu 17.10

lainion
lainion

(usa Ubuntu)

Enviado em 22/02/2018 - 19:17h

O da caixa eu desisti de tentar no meu ubuntu, mas funciona no debian.
Hoje eu uso o app pra android.


7. Re: Erro ao instalar "warsaw" para Internet Banking da Caixa ou do Banco Safra, no Lubuntu 17.10

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 22/02/2018 - 19:20h

lainion escreveu:
Hoje eu uso o app pra android.


Eu também. Deixei de me estressar por isso e parece que os bancos também.

----------
Itautec-W7535 (Ci3 + 4 GB + Intel-HD)


8. Talvez isto ajude alguém

Jose Luis Da Matta Rivitti
jlrivitti

(usa Ubuntu)

Enviado em 08/03/2018 - 12:12h

Lidando com problema de módulo de segurança "warsaw" dos bancos no ubuntu 17.10.

Procedimentos realizados sob orientação do consultor Guilherme, da Diebold Nixdorf, a quem externo meus agradecimentos.

Aos melhores entendidos, desculpem-me se algo não está colocado com os termos corretos.

No terminal como usuário:
$ sudo dpkg -f warsaw

Informou arquivo não encontrado, eu já havia removido nas dezenas de tentativas (sudo dpkg -r warsaw, sudo dpkg –purge warsaw). Se tem, remova com purge.

$ sudo dpkg --purge diagbb (se tinha instalado do BBrasil)

$ sudo su

Como root:
apt-get update
apt-get install libnss3-tools libcurl3

Já tinha versões atuais.

Entre pelo Chrome em:
http://www.dieboldnixdorf.com.br/warsaw

Selecione BBrasil e baixe warsaw_setup_64.deb na versão Ubuntu

Novamente no terminal como su:
Vá para o local onde baixou o arquivo.
dpkg -i warsaw_setup_64.deb

Pacote procedeu à instalação, mas teve informações de erro de processo:
'--nofork': não é um identificador válido
'--nopidfile': não é um identificador válido
'--systemd-activation': não é um identificador válido
Failed to open connection to "session" message bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on Unix "unix")
dconf-WARNING **: failed to commit changes to dconf: Transporte desconhecido ou sem suporte "systemd" para o endereço "sustemd:"

Reiniciou sozinho a sessão.

No terminal como usuário $:
$ dpkg -s warsaw
Deve constar informações da versão instalada.

$ ps -aux | grep warsaw
Verificar se tem dois processos core, um como root e outro como seu usuário.

Agora comece com o Chrome.

Abrir o Chrome.

Acessar https://127.0.0.1:30900/
Deve dar: HTTP ERROR 426
O consultor disse que precisa gerar a excessão.

Acessar http://www.dieboldnixdorf.com.br/warsaw
Escolher BB, ele vai processar a verificação, configuração e instalação.

Acessar "Personalizar e controlar o Google Chrome" (três pontos na direita da barra).
Digite certificados na caixa "Pesquisar nas configurações"
Clique em "Gerenciar certificados"
Clique em "Autoridades", verificar que deve estar instalado lá no final (ordem alfabética):
org-Warsaw Personal CA
Warsaw Personal CA
Clicar nos 3 pontos e exporte o Warsaw Personal CA para Desktop (Área de Trabalho), pois vai usar para o Firefox.

O warsaw Chrome já deve estar funcionando para BB.

Neste ponto, se quiser também o Itaú:
Acessar http://www.dieboldnixdorf.com.br/warsaw
Escolher Itaú, ele vai processar a verificação, vai dizer que:
Warsaw está instalado, sem configurações do Banco Itaú.
Clique em "Clique aqui" para concluir as configurações da sua instituição.
Ele vai instalar arquivos e dar mensagem:
Configurações realizadas com sucesso.

O warsaw Chrome já deve estar funcionando para Itaú.

Abrir o Firefox.

Acessar https://127.0.0.1:30900/
Deve dar página em branco.

Clique no ícone "Abrir menu" do canto direito da barra (três barrinhas horizontais)
Clique em "Preferências"
Digite certificados na caixa "Pesquisar em preferências"
Clique em "Ver certificados"
Clique em "Autoridades"
Clique em "Importar", vá para o local onde salvou o certificado Warsaw Personal CA, que foi Desktop (Área de Trabalho), Clique em "Arquivos de certificados", escolha "Todos os arquivos", selecione Warsaw Personal CA , clique em "Abrir".
Na volta para a janela "Gerenciador de certificados", escolha "Autoridades",
verificar que deve estar instalado lá no final (ordem alfabética).

Acessar http://www.dieboldnixdorf.com.br/warsaw
Escolher BB, ele vai processar a verificação, configuração e instalação.
Mesma situação com outro banco.

O warsaw já deve funcionar com essas instituições.


9. Re: Erro ao instalar

Ricardo Ludwig
RIKEVERE

(usa Ubuntu)

Enviado em 03/04/2018 - 19:11h

jlrivitti escreveu:

Lidando com problema de módulo de segurança "warsaw" dos bancos no ubuntu 17.10.

Procedimentos realizados sob orientação do consultor Guilherme, da Diebold Nixdorf, a quem externo meus agradecimentos.

Aos melhores entendidos, desculpem-me se algo não está colocado com os termos corretos.

No terminal como usuário:
$ sudo dpkg -f warsaw

Informou arquivo não encontrado, eu já havia removido nas dezenas de tentativas (sudo dpkg -r warsaw, sudo dpkg –purge warsaw). Se tem, remova com purge.

$ sudo dpkg --purge diagbb (se tinha instalado do BBrasil)

$ sudo su

Como root:
apt-get update
apt-get install libnss3-tools libcurl3

Já tinha versões atuais.

Entre pelo Chrome em:
http://www.dieboldnixdorf.com.br/warsaw

Selecione BBrasil e baixe warsaw_setup_64.deb na versão Ubuntu

Novamente no terminal como su:
Vá para o local onde baixou o arquivo.
dpkg -i warsaw_setup_64.deb

Pacote procedeu à instalação, mas teve informações de erro de processo:
'--nofork': não é um identificador válido
'--nopidfile': não é um identificador válido
'--systemd-activation': não é um identificador válido
Failed to open connection to "session" message bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on Unix "unix")
dconf-WARNING **: failed to commit changes to dconf: Transporte desconhecido ou sem suporte "systemd" para o endereço "sustemd:"

Reiniciou sozinho a sessão.

No terminal como usuário $:
$ dpkg -s warsaw
Deve constar informações da versão instalada.

$ ps -aux | grep warsaw
Verificar se tem dois processos core, um como root e outro como seu usuário.

Agora comece com o Chrome.

Abrir o Chrome.

Acessar https://127.0.0.1:30900/
Deve dar: HTTP ERROR 426
O consultor disse que precisa gerar a excessão.

Acessar http://www.dieboldnixdorf.com.br/warsaw
Escolher BB, ele vai processar a verificação, configuração e instalação.

Acessar "Personalizar e controlar o Google Chrome" (três pontos na direita da barra).
Digite certificados na caixa "Pesquisar nas configurações"
Clique em "Gerenciar certificados"
Clique em "Autoridades", verificar que deve estar instalado lá no final (ordem alfabética):
org-Warsaw Personal CA
Warsaw Personal CA
Clicar nos 3 pontos e exporte o Warsaw Personal CA para Desktop (Área de Trabalho), pois vai usar para o Firefox.

O warsaw Chrome já deve estar funcionando para BB.

Neste ponto, se quiser também o Itaú:
Acessar http://www.dieboldnixdorf.com.br/warsaw
Escolher Itaú, ele vai processar a verificação, vai dizer que:
Warsaw está instalado, sem configurações do Banco Itaú.
Clique em "Clique aqui" para concluir as configurações da sua instituição.
Ele vai instalar arquivos e dar mensagem:
Configurações realizadas com sucesso.

O warsaw Chrome já deve estar funcionando para Itaú.

Abrir o Firefox.

Acessar https://127.0.0.1:30900/
Deve dar página em branco.

Clique no ícone "Abrir menu" do canto direito da barra (três barrinhas horizontais)
Clique em "Preferências"
Digite certificados na caixa "Pesquisar em preferências"
Clique em "Ver certificados"
Clique em "Autoridades"
Clique em "Importar", vá para o local onde salvou o certificado Warsaw Personal CA, que foi Desktop (Área de Trabalho), Clique em "Arquivos de certificados", escolha "Todos os arquivos", selecione Warsaw Personal CA , clique em "Abrir".
Na volta para a janela "Gerenciador de certificados", escolha "Autoridades",
verificar que deve estar instalado lá no final (ordem alfabética).

Acessar http://www.dieboldnixdorf.com.br/warsaw
Escolher BB, ele vai processar a verificação, configuração e instalação.
Mesma situação com outro banco.

O warsaw já deve funcionar com essas instituições.


Perfeita Solução jlrivitti. No meu caso uso o 16.04, mas sua contribuição é algo que realmente funciona! Da pra ver que não da pra desistir. Assim como os colegas acima eu já estava a ponto de madar pra pqp e somente utilizar no Android.
Enormemente Grato!


10. Tópico: Erro ao instalar "warsaw" para Internet Banking da Caixa ou do Banco Safra, no Lubuntu 17.10

francisco silva
silvadfrancisco

(usa XUbuntu)

Enviado em 05/04/2018 - 20:36h

A solução mais completa sobre warsaw que já achei está no site abaixo, espero ter ajudado.
https://ubuntuforum-br.org/index.php?topic=121558.msg667917#msg667917

ps. Uso xubuntu 16, como warsaw do banco itau, e funciona.


11. Re: Erro ao instalar

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 05/04/2018 - 22:57h

Acabei de dar mais uma chance para esse meliante... instalei no chromium, exportei e importei no FF o da CEF, constou instalado, tentei logar no site da CEF e deu "sistema temporariamente indisponível" .. kkkkk ... fazer o q .... tento depois de novo !!!

Debian 8.10 com Firefox 59.0.2

------------------------------------------| Linux User #621728 |-----------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------| Linux User #621728 |-----------------------------------------



12. Re: Erro ao instalar "warsaw" para Internet Banking da Caixa ou do Banco Safra, no Lubuntu 17.10

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 06/04/2018 - 00:20h

Mauriciodez escreveu:

Acabei de dar mais uma chance para esse meliante... instalei no chromium, exportei e importei no FF o da CEF, constou instalado, tentei logar no site da CEF e deu "sistema temporariamente indisponível" .. kkkkk ... fazer o q .... tento depois de novo !!!

Debian 8.10 com Firefox 59.0.2


Perfeito ... Funcionou aqui !!!! tão simples e os viados ficam embaçando para dar a informação !!!

------------------------------------------| Linux User #621728 |-----------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------| Linux User #621728 |-----------------------------------------




01 02



Patrocínio

Site hospedado pelo provedor HostGator.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Viva o Android

Tópicos

Top 10 do mês

Scripts