Acesso externo do Servidor Poftpd não funciona

1. Acesso externo do Servidor Poftpd não funciona

jonas reckziegel
JonasR

(usa Ubuntu)

Enviado em 01/06/2019 - 14:33h

Olá pessoal, sou meio que iniciante no linux, configurei o Proftpd no Ubuntu, na rede interna tudo funciona, quando tento acessar de fora até pede o usuário e a senha, depois de inserir as credenciais, recebo a seguinte mensagem...

Erro ao abrir esta pasta no servidor FTP. Certifique-se que você tem permissão para acessar a pasta.

Detalhes:
200 type set to A
227 Entering Passive Mode (192.168.100,234,100).

Considerações:
Meu provedor entrega IP fixo onde faço a autenticação direto no meu roteador.
Configurei o servidor para trabalhar fora da porta 21, alguns provedores bloqueiam esta porta.
Adicionei regras de redirecionamento no roteador para a porta do proftpd e as passive ports, todas apontando para o IP interno do servidor.

Regras que adicionei no iptables
iptables -A -INPUT -p tcp --dport 60000:65535 -j ACCEPT - liberado as passiveports.
iptables -A -INPUT -p tcp --dport 5152 -j ACCEPT - liberando a porta em que o FTP esta respondendo.

Vi que tem mais gente com esse problema, andei lendo vários tópicos aqui mesmo, mas nenhum deles deu uma solução exata, talvez eu tenha esquecido de mencionar algo, é eu primeiro tópico, caso precise de mais alguma informação estarei postando, por hora muito obrigado.












  


2. Vamos lá...

Adriano Santos Lima
mastergbi

(usa Slackware)

Enviado em 04/06/2019 - 13:44h

Bom vamos lá, preciso saber de umas coisas...

1 - Esse ip fixo que vc se refere é Válido? ip publico?
2 - Temos que saber se está escutando legal, quando digita "netstat -ant" o resultado da porta 5152(21) é: 0.0.0.0:5152, ou 127.0.0.1:5152, ou :::5152?
3 - Como está seu /etc/proftpd/proftpd.conf, ele tá o padrão de instalação?
4 - Qual cliente ftp vc está tentando entrar? FileZilla (no campo criptografia vc está usando "Usar somente FTP simples"?)
5 - Sobre as permissões, Já rodou um "chown -R nomedousuario.nomedousuario nomedapasta/"
6 - Criou o usuário no linux tudo certinho? vc ta usando a pasta home/ do usuário ou vc editou o diretório no "/etc/passwd"?(eu mudo o diretório, não deixo /home deixo o diretório do site)


No aguardo...