Erro instalação pgadmin4

1. Erro instalação pgadmin4

Diego Dias Pereira
diegodiasptc

(usa Deepin)

Enviado em 17/12/2018 - 14:45h

Olá, galera. Estou tentando instalar o pgadmin para gerenciar via interface meus bancos de dados. Estou tentando instalar o pgadmin versão 4 já configurei todos os repositórios necessários e já consegui instalar o servidor postgresql 10, porém na hora que vou dar o comando
IN:
sudo apt-get install pgadmin4 

OUT:
Os pacotes a seguir têm dependências desencontradas:
pgadmin4 : Depende: pgadmin4-common (= 3.5-1.pgdg90+1) mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.


Trilhando o caminho das dependências temos:
IN:
sudo apt-get install pgadmin4-common 

OUT:
Os pacotes a seguir têm dependências desencontradas:
pgadmin4-common : Depende: python3-psycopg2 (>= 2.7.4) mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.


Outro:
IN:
sudo apt-get install python3-psycopg2 


OUT:
Os pacotes a seguir têm dependências desencontradas:
python3-psycopg2 : Depende: python3 (< 3.6) mas 3.6.5-3 está para ser instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.


Já tentei instalar o python3.5 mas sem sucesso.

Agradeço a todos que disponibilizarem um tempo para me ajudar.
Desde já, Obrigado
Att, Diego Dias



  


2. Re: Erro instalação pgadmin4

Perfil removido
removido

(usa Nenhuma)

Enviado em 17/12/2018 - 17:59h

# man apt-mark
hold - esta opção usada para marcar um pacote como retido, o que impedirá que o pacote seja instalado, atualizado ou removido. 


Imprimir lista de pacotes em espera
# apt-mark showhold



3. Re: Erro instalação pgadmin4

Perfil removido
removido

(usa Nenhuma)

Enviado em 17/12/2018 - 18:15h

Chegou rodar o apt-get assim:

sudo apt-get -f install pgadmin4 


$ man apt-get
-f, --fix-broken
Fix. Attempt to correct a system with broken dependencies in place. This option, when used with install/remove, can omit any packages to permit APT to deduce a likely solution. Any package(s) that are specified must completely correct the problem. This option is sometimes necessary when running APT for the first time; APT itself does not allow broken package dependencies to exist on a system. It is possible that a system's dependency structure can be so corrupt as to require manual intervention. Use of this option together with -m may produce an error in some situations.
Configuration Item: APT::Get::Fix-Broken.




4. Re: Erro instalação pgadmin4

Diego Dias Pereira
diegodiasptc

(usa Deepin)

Enviado em 18/12/2018 - 09:56h

O comando
apt-mark showhold 
não me retorna nada

Tentei usando com a flag -f e sem sucesso, ocorreu o mesmo erro.

IN:
sudo apt-get -f install pgadmin4 


OUT:
Os pacotes a seguir têm dependências desencontradas:
pgadmin4 : Depende: pgadmin4-common (= 3.5-1.pgdg90+1) mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.




5. Re: Erro instalação pgadmin4

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 18/12/2018 - 10:27h

vc está seguindo algum tutorial ??

se está configurando na base da PPA é uma de vc configurar uma release anterior.

essa aí parece que não vai, corrige os quebrados aí
sudo apt -f install  


------------------------------------------| Linux User #621728 |-----------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------| Linux User #621728 |-----------------------------------------



6. Re: Erro instalação pgadmin4

Diego Dias Pereira
diegodiasptc

(usa Deepin)

Enviado em 18/12/2018 - 14:35h

Segui a própria documentação do pgadmin mesmo, segue o link:
https://wiki.postgresql.org/wiki/Apt

Então, estou usando o Deepin que é uma distro que não tem suporte ao PPA até onde eu sei. Estou usando via repositório apt mesmo.

Creio que o problema seja nas versões do python, não tenho certeza. Já pesquisei varias formas de corrigir e nenhuma satisfaz o meu problema
.


7. Re: Erro instalação pgadmin4

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 18/12/2018 - 15:00h

.
.
.
.
Velho ... aquele repositório que está dizendo como stretch ... coloca jessie e testa.

não esquece de corrigir os pacotes quebrados antes !!!

------------------------------------------| Linux User #621728 |-----------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------| Linux User #621728 |-----------------------------------------



8. Re: Erro instalação pgadmin4

Luter Altedral
LuterAltedral

(usa Deepin)

Enviado em 21/02/2019 - 08:25h

Passei por isso e consegui resolver fazendo o seguinte:

sudo aptitude install python3-psycopg2 


O aptitude irá sugerir apenas manter o pacote psycopg2 que já está instalado. A isso, responda 'n'. Em seguida, ele irá sugerir um pacote mais antigo, responda 'y'. Feito isso, tente instalar o pgadmin4 que deverá correr normalmente.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts