Erro ao atualizar Postgresql [RESOLVIDO]

1. Erro ao atualizar Postgresql [RESOLVIDO]

zaqueu pereira gomes
zaqueupg

(usa Kali)

Enviado em 01/10/2016 - 10:40h

Pessoa, ontem eu dei um apt-get upgrade no meu Kali, porém tive o azar de faltar luz no momento da atualização, e acabou ocorrendo um erro ao atualizar o Postgresql para a versão 9.6, acredito que seja pq o pacote do 9.5 não foi removido, então hj ao tentar da o upgrade novamente, apareceu a seguinte msg: (E: O dpkg foi interrompido, para corrigir o problema tem de correr manualmente 'dpkg --configure -a').
Usei o comando configure e dei isso: ( Versão principal 9.5 obsoleta
│
│ O PostgreSQL versão 9.5 está obsoleto, mas os pacotes servidor ou
│ cliente ainda estão instalados. Por favor, instale os últimos pacotes
│ (postgresql-9.6 e postgresql-client-9.6) e atualize seus clusters
│ existentes com o pg_upgradecluster (veja a página de manual).
│
│ Por favor, esteja ciente de que a instalação do postgresql-9.6 irá criar
│ automaticamente um cluster padrão 9.6/main. Se você quer atualizar o
│ cluster 9.5/main, você precisa remover o cluster 9.6 já existente
│ (pg_dropcluster --stop 9.6 main, veja a página de manual para detalhes).
│
│ Os antigos pacotes servidor e cliente não são mais suportados. Após os
│ clusters existentes terem sido atualizados, os pacotes postgresql-9.5 e postgresql-client-9.5 deveriam ser removidos.
│
│ Por favor, veja /usr/share/doc/postgresql-common/README.Debian.gz para
│ detalhes.
│
&#9474; <Ok> )

Alguém poderia me ajudar a resolver isso?



  


2. MELHOR RESPOSTA

Carlos A. P. Cunha
Carlos_Cunha

(usa Linux Mint)

Enviado em 01/10/2016 - 14:22h

Execute e depois tente upgrade novamente.

dpkg --configure -a

#-------------------------------------------------------------------------------------#

"Linux is cool"

3. Re: Erro ao atualizar Postgresql [RESOLVIDO]

zaqueu pereira gomes
zaqueupg

(usa Kali)

Enviado em 01/10/2016 - 18:56h

Carlos_Cunha escreveu:

Execute e depois tente upgrade novamente.

dpkg --configure -a

#-------------------------------------------------------------------------------------#

"Linux is cool"

Cara vlw por responder, mas acabei perdendo a paciência e formatei, até pq seria mais rápido, ja que eu tinha acabado de instalar o sistema e não havia necessidade de backup! obrigado!







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts