Problema que ninguém conseguiu me ajudar a resolver no Ubuntu 16.04

1. Problema que ninguém conseguiu me ajudar a resolver no Ubuntu 16.04

Lucas Silva
ubuntukid

(usa Debian)

Enviado em 25/01/2018 - 15:17h

Oi,

Já fiz algumas perguntas aqui sobre os problemas que aparecem no SO, mas até agora nunca resolveu nada.
Vou explicitar o problema mais uma vez e com o resultado de todos os testes que me pediram até agora:

Configuração do Notebook:
Processador: Intel Core i3-2370M CPU 2.40GHz
Memória: 4GB
Placa de vídeo: Intel Corporation 2nd Generation Core Processor Family Integrated Graphic Controller

O caso é que o sistema às vezes inicia e às vezes não.

No caso de iniciar, o sistema fica travando na maior parte do tempo por uns 20 segundos e depois volta, mas mesmo assim ainda trava com frequência em qualquer operação que eu faça no computador, seja usar o navegador ou até mesmo o terminal.

Quando não inicia aparece uma mensagem que diz:
"erro: tentativa de ler ou gravar fora do disco "hd0".
unaligned pointer 0x4
Aborted. Press any key to exit"

E quando eu pressiono qualquer botão a tela simplesmente trava, sendo assim necessário reiniciar mais uma vez e esperar em torno de 10 minutos ou mais pra o computador iniciar e ainda assim continua lento com o HD sendo usado em 100% mesmo se tiver apenas um processo aberto;
# smartctl diz que o estado do HD está ok, fora testes que fiz com # hdparm e outros.

Se eu inicio pelo modo avançado pra recuperar o dpkg, o sistema inicia um pouco mais rápido (mas ainda assim lento) mas com o vídeo bugado, a mensagem resultado de # xrandr é:

"xrandr: Failed to get size of gamma for output default
warning: output (null) not found; ignoring"

E daí se reiniciar mais uma vez, o problema continua da mesma forma.

É a segunda vez que instalo a mesma distro numa tentativa de corrigir o problema que está presente desde a primeira instalação.

Talvez eu precise baixar outra imagem ou quem sabe outra distro, mas queria muito conseguir resolver sem precisar baixar nada, minha internet é muito devagar.

Por favor, me ajudem!! Estou há um mês com esse problema e nada resolveu........



  


2. Re: Problema que ninguém conseguiu me ajudar a resolver no Ubuntu 16.04

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 25/01/2018 - 15:59h

Tenho notebook-2011 com mesma configuração rodando ubuntu + mint + fedora sem problemas de travamentos
Sugiro que faça uma avaliação do seu hardware como memoria, hd , etc




3. Re: Problema que ninguém conseguiu me ajudar a resolver no Ubuntu 16.04

Matheus
pylm

(usa Gentoo)

Enviado em 25/01/2018 - 16:02h

Roda um teste de memória só pra desencanar, deve ter a opção no grub.




4. Re: Problema que ninguém conseguiu me ajudar a resolver no Ubuntu 16.04

skjdeecedcnfncvnrfcnrncjvnjrnfvjcnjrjvcjrvcj
Londreslondres

(usa Slackware)

Enviado em 25/01/2018 - 16:33h

No Grub escolha a opção memtest86+

Essa opção verifica a memória ram.

Se o Grub estiver oculto, tecle Shift para ele aparecer.

Qualquer dúvida é só perguntar.
--------------------------------------------------------------------
#voltalisteiro


5. Re: Problema que ninguém conseguiu me ajudar a resolver no Ubuntu 16.04

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 25/01/2018 - 16:57h

me parece problema de hardware.
cheque pentes de memória, cabos, HD e fonte.
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


6. Re: Problema que ninguém conseguiu me ajudar a resolver no Ubuntu 16.04

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 25/01/2018 - 17:31h



me parece ISO bugada, não parece erro de hardware não ... no caso a unica solução seria outra ISO mesmo !!!


------------------------------------------| Linux User #621728 |-----------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------| Linux User #621728 |-----------------------------------------



7. Resultado dos testes.

Lucas Silva
ubuntukid

(usa Debian)

Enviado em 29/01/2018 - 11:48h

Mesmtest+86: Deu tudo certo, não apontou nenhum erro de memória.

 #hdparm -v /dev/sda  

/dev/sda:
multcount = 16 (on)
IO_support = 1 (32-bit)
readonly = 0 (off)
readahead = 256 (on)
geometry = 60801/255/63, sectors = 976773168, start = 0

# fdisk -l:  

Disk /dev/sda: 465,8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x6adbfb8b

Dispositivo Inicializar Start Fim Setores Size Id Tipo
/dev/sda1 * 2048 968587263 968585216 461,9G 83 Linux
/dev/sda2 968589310 976771071 8181762 3,9G 5 Estendida
/dev/sda5 968589312 976771071 8181760 3,9G 82 Linux swap / Solaris

Partition 2 does not start on physical sector boundary.

Li em alguns fóruns que é ok ignorar esse aviso de Partition 2 does not start on physical sector boundary e mesmo que eu quisesse resolver, não achei nenhum tópico que ensinasse como fazer.

 # htop  

https://imgur.com/menJSKu

 # smartctl -a /dev/sda  

smartctl 6.5 2016-01-24 r4214 [x86_64-linux-4.13.0-31-generic] (local build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Model Family: Toshiba 2.5" HDD MK..75GSX
Device Model: TOSHIBA MK5075GSX
Serial Number: 52IBY6POF
LU WWN Device Id: 5 000039 40d285742
Firmware Version: GT001U
User Capacity: 500.107.862.016 bytes [500 GB]
Sector Sizes: 512 bytes logical, 4096 bytes physical
Rotation Rate: 5400 rpm
Form Factor: 2.5 inches
Device is: In smartctl database [for details use: -P show]
ATA Version is: ATA8-ACS (minor revision not indicated)
SATA Version is: SATA 2.6, 3.0 Gb/s (current: 3.0 Gb/s)
Local Time is: Mon Jan 29 11:43:02 2018 -02
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status: (0x00) Offline data collection activity
was never started.
Auto Offline Data Collection: Disabled.
Self-test execution status: ( 0) The previous self-test routine completed
without error or no self-test has ever
been run.
Total time to complete Offline
data collection: ( 120) seconds.
Offline data collection
capabilities: (0x5b) SMART execute Offline immediate.
Auto Offline data collection on/off support.
Suspend Offline collection upon new
command.
Offline surface scan supported.
Self-test supported.
No Conveyance Self-test supported.
Selective Self-test supported.
SMART capabilities: (0x0003) Saves SMART data before entering
power-saving mode.
Supports SMART auto save timer.
Error logging capability: (0x01) Error logging supported.
General Purpose Logging supported.
Short self-test routine
recommended polling time: ( 2) minutes.
Extended self-test routine
recommended polling time: ( 194) minutes.
SCT capabilities: (0x003d) SCT Status supported.
SCT Error Recovery Control supported.
SCT Feature Control supported.
SCT Data Table supported.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
1 Raw_Read_Error_Rate 0x000b 100 100 050 Pre-fail Always - 0
2 Throughput_Performance 0x0005 100 100 050 Pre-fail Offline - 0
3 Spin_Up_Time 0x0027 100 100 001 Pre-fail Always - 2792
4 Start_Stop_Count 0x0032 100 100 000 Old_age Always - 174
5 Reallocated_Sector_Ct 0x0033 100 100 050 Pre-fail Always - 0
7 Seek_Error_Rate 0x000b 100 100 050 Pre-fail Always - 0
8 Seek_Time_Performance 0x0005 100 100 050 Pre-fail Offline - 0
9 Power_On_Hours 0x0032 100 100 000 Old_age Always - 324
10 Spin_Retry_Count 0x0033 103 100 030 Pre-fail Always - 0
12 Power_Cycle_Count 0x0032 100 100 000 Old_age Always - 96
191 G-Sense_Error_Rate 0x0032 100 100 000 Old_age Always - 18
192 Power-Off_Retract_Count 0x0032 100 100 000 Old_age Always - 32
193 Load_Cycle_Count 0x0032 100 100 000 Old_age Always - 245
194 Temperature_Celsius 0x0022 100 100 000 Old_age Always - 41 (Min/Max 16/48)
196 Reallocated_Event_Count 0x0032 100 100 000 Old_age Always - 0
197 Current_Pending_Sector 0x0032 100 100 000 Old_age Always - 0
198 Offline_Uncorrectable 0x0030 100 100 000 Old_age Offline - 0
199 UDMA_CRC_Error_Count 0x0032 200 200 000 Old_age Always - 0
220 Disk_Shift 0x0002 100 100 000 Old_age Always - 8296
222 Loaded_Hours 0x0032 100 100 000 Old_age Always - 199
223 Load_Retry_Count 0x0032 100 100 000 Old_age Always - 0
224 Load_Friction 0x0022 100 100 000 Old_age Always - 0
226 Load-in_Time 0x0026 100 100 000 Old_age Always - 299
240 Head_Flying_Hours 0x0001 100 100 001 Pre-fail Offline - 0

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
Num Test_Description Status Remaining LifeTime(hours) LBA_of_first_error
# 1 Short offline Completed without error 00% 296 -
# 2 Short offline Completed without error 00% 292 -
# 3 Short offline Completed without error 00% 107 -
# 4 Short offline Completed without error 00% 101 -

SMART Selective self-test log data structure revision number 1
SPAN MIN_LBA MAX_LBA CURRENT_TEST_STATUS
1 0 0 Not_testing
2 0 0 Not_testing
3 0 0 Not_testing
4 0 0 Not_testing
5 0 0 Not_testing
Selective self-test flags (0x0):
After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

E agora, qual será o problema? O PC continua do mesmo jeito. Às vezes melhora, mas ainda assim não está 80% satisfatório



8. Re: Problema que ninguém conseguiu me ajudar a resolver no Ubuntu 16.04

Piu
piu

(usa Arch Linux)

Enviado em 29/01/2018 - 13:21h

parece problema no hardware, mas, pra afastar qualquer suspeita, eu faria um backup usando um live cd, das minhas coisas importantes, limparia o hd, e começaria de novo, reinstalando qualquer outro sistema.
se, reinstalando, funcionar, o problema era o S.O., senão, é hardware
porém, seria interessante, antes, você baixar denovo a ISO do sistema que você quer instalar, verificar a soma md5sum, e queimar a imagem num dvd ou pendrive, em outra máquina


9. Re: Problema que ninguém conseguiu me ajudar a resolver no Ubuntu 16.04

Lucas Silva
ubuntukid

(usa Debian)

Enviado em 29/01/2018 - 15:49h

Beleza. Tô tentando baixar o Debian pelo jigdo, mas não consegui fazer com que baixasse os arquivos que faltam a partir ftp.us.debian pois o script tá baixando a partir de archive.ubuntu e daí tá me retornando umas mensagem como essa:

--2018-01-29 15:40:37-- http://archive.ubuntu.com/ubuntu/pool/main/libx/libxfce4ui/libxfce4ui-utils_4.12.1-2_amd64.deb
Reaproveitando a conexão existente para archive.ubuntu.com:80.
A requisição HTTP foi enviada, aguardando resposta... 404 Not Found
2018-01-29 15:40:37 ERRO 404: Not Found.

The jigdo file refers to files stored on Ubuntu mirrors. Please
choose a Ubuntu mirror as follows: Either enter a complete URL
pointing to a mirror (in the form
`ftp://ftp.debian.org/debian/'), or enter any regular expression
for searching through the list of mirrors: Try a two-letter
country code such as `de', or a country name like `United
States', or a server name like `sunsite'.
Ubuntu mirror [http://archive.ubuntu.com/ubuntu/]:

E aí se eu coloco o endereço do debian, aparece a mesma linha pra eu inserir um mirror válido e se eu dou enter pra baixar pelo ubuntu, não acha os arquivos que preciso...


10. Re: Problema que ninguém conseguiu me ajudar a resolver no Ubuntu 16.04

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 29/01/2018 - 15:54h

ubuntukid escreveu:

Beleza. Tô tentando baixar o Debian pelo jigdo, mas não consegui fazer com que baixasse os arquivos que faltam a partir ftp.us.debian pois o script tá baixando a partir de archive.ubuntu e daí tá me retornando umas mensagem como essa:


velho ... escolhe um sabor, baixa a ISO >> https://cdimage.debian.org/debian-cd/current-live/amd64/iso-hybrid/
Faz o pendrive com o "dd" >>> http://infotux.blogspot.com.br/2011/12/dica-rapida-criando-pendrive-bootavel.html

------------------------------------------| Linux User #621728 |-----------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------| Linux User #621728 |-----------------------------------------



11. Re: Problema que ninguém conseguiu me ajudar a resolver no Ubuntu 16.04

Gustavo Paulino
Skol

(usa Linux Mint)

Enviado em 29/01/2018 - 15:54h

Faz um backup e depois uma instalação limpa, creio que vai resolver. Não está parecendo problema de hardware e sim de sistema.


12. Re: Problema que ninguém conseguiu me ajudar a resolver no Ubuntu 16.04

Paulo Jr
Pebis

(usa Debian)

Enviado em 29/01/2018 - 16:25h

Se o sistema de arquivos estiver em ext4 tenta verficar com o fsck utilizando uma live (cd ou usb), parece problema no disco mesmo (físico ou lógico)

O que eu conheço é

sudo -c fdisk.ext4 /dev/sdX -> aonde X é a partição do seu sistema.

Não sei quando usar o e2fsck , e também não sei se é a mesma coisa... dá uma pesquisada .



01 02