Problemas com login

1. Problemas com login

Yuri
YuriAoto

(usa Debian)

Enviado em 20/02/2009 - 17:16h

Olá! Uso a distribuição Suse e tive alguns problemas com o login nesta última semana. Eu logava e automaticamente minha sessão deslogava. O que eu fiz, hoje, e n]ao sei porque deu certo, é que alterei o arquivo .cshrc (uso Cshell) adicionando uma linha

!teste

Agora ele loga normal. Alguém sabe me dizer oq deve ter acontecido e porque isso que eu fiz funcionou? Antes de dar o problema o que eu fiz no computador foi rodar um programa que eu escrevi em fortran e tá rodando já há dois dias e acessei via ssh de outro computador.

Valew!!


  


2. Re: Problemas com login

Mateus Leonardi
mateustads

(usa Debian)

Enviado em 20/02/2009 - 17:29h

to precisando aprender um pouco sobre scripts... vou acompanhar o tópico... algum voluntario pra resposta??


3. Re: Problemas com login

Kelvin Vicente
KelvinVicente

(usa Debian)

Enviado em 20/02/2009 - 18:42h

@YuriAoto:

fica meio complicado saber sem ver o script.

se possivel, por favor, poste o script.


@mateustads:

os scripts, basicamente falando, nada mais são do que comandos do shell.
recomendo a leitura dos mans para aprender mais.

No link abaixo há muita coisa:

http://linux.die.net/


[]s


4. Re: Problemas com login

Diego Hernandes Soares Alves
diegohsa

(usa Arch Linux)

Enviado em 20/02/2009 - 19:02h

Fortran é Deth Metal em cara!!!!!!

bem doido!!!!


posta seu arquivo de configuração aqui e informe mais sobre sua maquina, provavelmente não foi essa alteração que fez a situação normalizar


5. Re: Problemas com login

Yuri
YuriAoto

(usa Debian)

Enviado em 21/02/2009 - 09:48h

O script que alterei foi

source /usr/local/cshrc.all
source /usr/local/cshrc.mol
source /opt/intel/fce/10.0.025/bin/ifortvars.csh
source /opt/intel/idbe/10.0.025/bin/idbvars.csh

alias cls "clear"
alias lsl "ls -l"
alias lst "ls -lt"
alias lsa "ls -la"
!teste




6. Re: Problemas com login

Kelvin Vicente
KelvinVicente

(usa Debian)

Enviado em 23/02/2009 - 03:03h

e se ao inves do !teste colocar um #!/bin/bash

funciona?

(ainda nao entendi tmb o q ocorreu... estou pesquisando a respeito)