Configuração do modem claro 3g [RESOLVIDO]

1. Configuração do modem claro 3g [RESOLVIDO]

Alan Castter
castter

(usa Ubuntu)

Enviado em 11/08/2009 - 08:39h

Pessoal, tô numa fria, ajudem-me, por favor:
Tentei configura o wvdial no terminal com o comando sudo gedit /etc/wvdial.conf.
Daí abriu uma espécie de bloco de notas. Segui uma orientação que peguei na web e troquei todo o conteúdo pelo seguinte:

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = AT+CGDCONT=1,"IP","claro.com.br"
ISDN = 0
Modem Type = Analog Modem
New PPPD = yes
Phone = *99***1#
Modem = /dev/ttyACM0
Username = claro
Password = claro
#Baud = 460800
Baud = 614400

Daí, salvei, fechei o programa e voltei ao terminal, onde fiz: sudo wvdial

Daí retornou o seguinte uma mensagem longa e maluca que, em síntese, dizia que:
1-Section dealer defaults não existe
2-número do telefone, login e password não são válidos

Em síntes, continuo sem acessar a web pelo meu clago 3g e156b a não ser por meio do rwindows.
Obs: minha distro é
satux, mas lá no sítio da satux achar alguém que responda a uma pergunta é uma dificuldade...


  


2. Re: Configuração do modem claro 3g [RESOLVIDO]

Alan Castter
castter

(usa Ubuntu)

Enviado em 12/08/2009 - 18:33h

Alô, Terra! Tem alguém aí para me ajudar por favor?


3. Re: Configuração do modem claro 3g [RESOLVIDO]

adilson gomes
ratim_AM

(usa Big Linux)

Enviado em 12/08/2009 - 19:14h

Qual Distribuição você usa? Eu uso ubuntu, e quando inicio o pc com o modem plugado, ele ja recohece e abre uma interface grafica ai é so dar uns cliques e ja era. Funciona que é uma beleza.


4. Mudança para o gnome-ppp

Alan Castter
castter

(usa Ubuntu)

Enviado em 16/08/2009 - 19:47h

Tentei tudo isto, pessoal, nada funciona.
Então, ouvi falar do gnome-ppp, e tentei conectar por ele. Fiz toda a configuração, e ele diz que está enviando senha, demora um século e depois muda a mensagem para conectando, aí demora outro século e não conecta. É estranho, porque tenho usado o modem no rwindows e funciona com uma facilidade que, a princípio, desencanta os iniciante em linux, como eu. Tem saída para resolver este problema pelo gnome-ppp que me pareceu um caminho mais fácil? (distro=satux).


5. Resposta da tentativa

Alan Castter
castter

(usa Ubuntu)

Enviado em 18/08/2009 - 09:28h

Ocorreu o seguinte:
1-O terminal conseguiu salvar as seções dialer defauts e dialer 3g numa boa.
2-Mas, quando fui fazer as configurações adicionais que você orientou, aconteceu o seguinte:

$ sudo chmod 666 /etc/ppp/*crets
command not found

$ sudo gedit /etc/group
command not found

$ wvdial 3g
command not found



6. Tem alguém aí?

Alan Castter
castter

(usa Ubuntu)

Enviado em 25/08/2009 - 20:43h

Alô, terra! Socorram-me quem puder!


7. Re: Configuração do modem claro 3g [RESOLVIDO]

Thiago Gomes Bento Ferreira
axpira

(usa Slackware)

Enviado em 26/08/2009 - 00:22h

Eu uso Vivo, Claro e TIM com o wvdial, segue meu arquivo de configuracao:

[Dialer Defaults]
Carrier Check = off
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Password = claro
Ask Password = 0
Check Def Route = 1
Phone = *99***1#
Idle Seconds = 0
Modem Type = Analog Modem
Stupid Mode = 1
Compuserve = 0
Baud = 460800
Auto DNS = on
Dial Command = ATDT
Modem = /dev/ttyACM0
ISDN = 0
Username = claro

[Dialer Claro]
Modem = /dev/ttyACM0
Baud = 921600
DialCommand = ATDT
Check Def Route = on
FlowControl = Hardware(CRTSCTS)
Username = claro
Password = claro
Phone = *99#
Stupid mode = 1
Auto Reconnect = on
Auto DNS = on
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2
Init3 = AT+CGDCONT=1,"IP","claro.com.br"
ISDN = 0
Modem Type = Analog Modem

[Dialer TIM]
Modem = /dev/ttyUSB0
Baud = 921600
DialCommand = ATDT
Check Def Route = on
FlowControl = Hardware(CRTSCTS)
Username = tim
Password = tim
Phone = *99#
Stupid mode = 1
Auto Reconnect = on
Auto DNS = on
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2
Init3 = AT+CGDCONT=1,"IP","tim.com.br"
ISDN = 0
Modem Type = Analog Modem

[Dialer Vivo]
Modem = /dev/ttyUSB0
Baud = 921600
DialCommand = ATDT
Check Def Route = on
FlowControl = Hardware(CRTSCTS)
Username = vivo
Password = vivo
Phone = *99#
Stupid mode = 1
Auto Reconnect = on
Auto DNS = on
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2
Init3 = AT+CGDCONT=1,"IP","zap.vivo.com.br"
ISDN = 0
Modem Type = Analog Modem


Entao quando quero conectar vivo:
wvdial Vivo

Quando quero TIM:
wvdial TIM

Quando quero Claro:
wvdial Claro


Apenas uma observacao no claro é celular, os outros são modem mesmo, então no claro tem-se a seguinte linha:
Modem = /dev/ttyACM0

Se for modem ao invés de Celurar trocar para:
Modem = /dev/ttyUSB0


Quando vc digita wvdial Claro, aparece alguma mensagem de erro?



8. Nova tentativa

Alan Castter
castter

(usa Ubuntu)

Enviado em 26/08/2009 - 21:21h

Cara, tentei essa sua configuração, mas quando faço wvdial claro+enter no terminal, não há resposta alguma; tentei fazer então wvdial+enter, daí ele me respondeu o seguinte:
Cara, quando digitei wvdial no terminal e teclei enter, foi como se eu não tivesse feito nada: o terminal ignorou; aí fiz wvdial+enter, no que ele respondeu assim:
[email protected]:~$ wvdial
--> WvDial: Internet dialer version 1.56
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
OK
--> Sending: AT+CFUN=1
AT+CFUN=1
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: AT+CGDCONT=1,"IP","bandalarga.claro.com.br"
AT+CGDCONT=1,"IP","bandalarga.claro.com.br"
OK
--> Modem initialized.
--> Sending: ATM1L3DT*99***1#
--> Waiting for carrier.
ATM1L3DT*99***1#
CONNECT
--> Carrier detected. Waiting for prompt.
--> Don't know what to do! Starting pppd and hoping for the best.
--> Starting pppd at Wed Aug 26 17:49:13 2009
--> Pid of pppd: 12464
--> Using interface ppp0
--> pppd: H˜ø·P[1f][06][08]0[0f][06][08]
--> pppd: H˜ø·P[1f][06][08]0[0f][06][08]
--> pppd: H˜ø·P[1f][06][08]0[0f][06][08]
--> pppd: H˜ø·P[1f][06][08]0[0f][06][08]
--> pppd: H˜ø·P[1f][06][08]0[0f][06][08]
--> pppd: H˜ø·P[1f][06][08]0[0f][06][08]
--> pppd: H˜ø·P[1f][06][08]0[0f][06][08]
--> pppd: H˜ø·P[1f][06][08]0[0f][06][08]
--> local IP address 187.25.157.36
--> pppd: H˜ø·P[1f][06][08]0[0f][06][08]
--> remote IP address 10.64.64.64
--> pppd: H˜ø·P[1f][06][08]0[0f][06][08]
--> primary DNS address 200.169.118.22
--> pppd: H˜ø·P[1f][06][08]0[0f][06][08]
--> secondary DNS address 200.169.117.22
--> pppd: H˜ø·P[1f][06][08]0[0f][06][08]
Mas ficou só nisso, não fez mais nada, parece-me que ele teve problemas com o tal "serial port relatado acima" e não soube o que fazer depois do "waiting prompt"... tem solução?
De qualquer modo, obrigado pela tentativa de me ajudar.



9. Ubuntu 9.04

Alan Batista dos Santos
alanbatista

(usa CentOS)

Enviado em 27/08/2009 - 08:19h

Reconheceu de boa, no debian usei um discador grafico gnomeppp.


10. Re: Configuração do modem claro 3g [RESOLVIDO]

wilcliton sousa de oliveira
k1t0n

(usa Mandrake)

Enviado em 27/08/2009 - 15:54h

Caro amigo, eu atualmente estou usando o mandriva 2009.1 e conectando com o modem Huawei e226 3G da claro. A questão é que eu uso a porta /dev/ttyUSB0 e vc ta configurando para a porta /dev/ttyACM0, vc tá tentando conectar pelo celular?. Eu uso o Kppp como discador e funciona perfeitamente. o Satux é Gnome ou KDE? se for KDE num perde tempo e tenta com o Kppp. falous!


11. Re: Configuração do modem claro 3g [RESOLVIDO]

Thiago Gomes Bento Ferreira
axpira

(usa Slackware)

Enviado em 27/08/2009 - 16:06h

castter -> Para usar é case sensitive(Maiúscula e minuscula faz diferença) então precisa digitar
wvdial Claro

ao invés de:
wvdial claro




12. Re: Configuração do modem claro 3g [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 20/09/2009 - 23:52h

nao sei se ainda ta com problema, mas eu escrevi um script pra resolver isso, ta aqui no VoL, to usando o meu sussa (Claro Huawei E156) no Ubuntu e to usando o networkmanager (iconezim no topo da tela) pra conectar, em vez do wvdial.



01 02