dbase no etch 4

1. dbase no etch 4

Rafael E. Rissi
R4F43L*3SP

(usa Debian)

Enviado em 27/07/2007 - 14:17h

Ola Pessoal !

To com um problema aqui na empresa montei um servidor lamp no Debian Etch 4.0.r.0 más não consigo importar os bancos que estao em dbf para o MySql usando as aplicações em php, todas as configurações estão ok pois toda a pagina web funciona menos o link para importação de dados .dbf. Eu tenho o mesmo servidor rodado em FC-5 que esta rodando perfeitamente más preciso mudalo para Debian o quanto antes.

Obs: o mue servidor é um amd-64bit


  


2. Re: dbase no etch 4

Fábio Berbert de Paula
fabio

(usa Debian)

Enviado em 27/07/2007 - 14:29h

Você chegou a debugar seu script em PHP pra descobrir em que linha (comando/função) o sistema não funciona? Se enviar pra gente a linha que não funciona facilita.

Verifique também se o php-db está instalado no seu Debian:

# apt-get install php-db


3. Re: dbase no etch 4

Rafael E. Rissi
R4F43L*3SP

(usa Debian)

Enviado em 31/07/2007 - 14:28h

Boa Tarde!
Fabio

O meu php esta sem suporte a dbase quais os parametros nescessários para compilar o php com suporte a dbase?


4. Re: dbase no etch 4

Fábio Berbert de Paula
fabio

(usa Debian)

Enviado em 31/07/2007 - 14:33h

Ih, aí vai ser trabalho de Jó mesmo. Baixe o código-fonte do PHP e analise as opções do ./configure dele com:

$ ./configure --help | grep -i dbase

Provavelmente vá aparecer a opção --with-dbase. Só habilitar, verificar se as bibliotecas de desenvolvimento do dbase estão instaladas no seu Linux e mandar ver!

Bom, é caminho das pedras mesmo... pelo menos não conheço solução mais fácil, mas confesso que nunca trabalhei com dbase.

Um abraço.


5. Re: dbase no etch 4

Rafael E. Rissi
R4F43L*3SP

(usa Debian)

Enviado em 08/08/2007 - 15:17h

Boa tarde!

Me desculpe pela demora, más reinstalei todo o sistema, e coversei com alguns conhecidos para ver se descobria alguma coisa.
Descobri que faltava um parametro no php.ini o

extension=php_dbase.so

adicionei esta linha no final do php.ini, más nada adiantou continuei com o mesmo problema. Alguem saberia me informar alguma coisa?
Tudo está funcionando prefeitamente menos a importação do dbase para o mysql



6. Re: dbase no etch 4

Rafael E. Rissi
R4F43L*3SP

(usa Debian)

Enviado em 18/01/2008 - 12:28h

Bom Dia! Pessoal

Mais um problema resolvido.

Depois de muito tempo pesquisando sobre o dbase no etch li um post, já não me lembro mais em que site, que me indicava o grupo responsável pelo LAMP no debian o DOTDEB desbloquiei o site no squid e adicionei o repositório na minha source.list que ficou assim:

deb http://packages.dotdeb.org stable all
deb-src http://packages.dotdeb.org stable all

depois de salvar a source.list digitei o comando apt-get update e depois instalei os servidores

apt-get install apache2
apt-get install php php-mysql php-db
apt-get install mysql mysql-server

e tudo funcionou perfeitamente com o suporte ao dbase.

Muito Obrigado pela paciencia e atenção de todos do VOL


7. Re: dbase no etch 4

Aprendiz - CE
aprendiz_ce

(usa Debian)

Enviado em 17/06/2008 - 20:43h

Olá rafael-esp,

Estou passando pelo mesmo problema. E acho que a sua solução se aplica a mim também... Só queria saber qual a versão do PHP esse procedimento instalou. E sobre esse mirror, é confiavel?

Obrigado e se puder responder fico-lhe grato.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts