Servidor não compila codigo - APACHE 2

1. Servidor não compila codigo - APACHE 2

Franklin Costa Ferreira
franckcf

(usa Ubuntu)

Enviado em 18/09/2014 - 11:42h

Galera boa tarde!!

Estou com um problema sério!

Tenho o PHP - Apache 2 instalado no meu Ubuntu 14.04.

Quanto eu rodo a página, por exemplo localhost, a index que possui todo o código PHP, não é compilado, ou seja, aparece as linhas de código na página ao invés do resultado do que o código deve fazer.


Já reinstalei o apache e o PHP pelo at-get, instalei o php5, php-fpm, apache2, tudo pelo apt-get, e não resolveu.

Alguém pode me ajudar??


Valeu... :D


  


2. Re: Servidor não compila codigo - APACHE 2

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 18/09/2014 - 14:20h

posta ai o seu código em php

e o phpinfo funciona ?


3. Re: Servidor não compila codigo - APACHE 2

Franklin Costa Ferreira
franckcf

(usa Ubuntu)

Enviado em 18/09/2014 - 15:39h

danniel-lara escreveu:

posta ai o seu código em php

e o phpinfo funciona ?


Não funciona e tem um porém também, ele compila metade do código, por exemplo:
<?php

//conectando com o link do host e usuário e senha
$cx = odbc_connect($dsn,$user,$pass);
//FIM

//Verificando se conecta
if($cx){
echo "conectou <br>";
}else{
echo "deu [*****] <br>";
}
//FIM

//Busca o nome de todas as tabelas, como eu não sabia o nome, precisei fazer essa busca
$result = odbc_tables($cx);
echo "TABELAS";
while (odbc_fetch_row($result)){
if(odbc_result($result,"TABLE_TYPE")=="TABLE")

echo"<br>".odbc_result($result,"TABLE_NAME");

}
echo "<br>++++++++++++++++++<br><br>";

$query = "select * from Cliente";

$result = odbc_exec($cx, $query);


$conteudo = array();
//FIM

//Pega as informações dentro de ROW e retorna dentro da array CONTEUDO em forma de array com o nome da COLUNA e COTEUDO
while($row = odbc_fetch_array($result)){
foreach ($row as $key => $value) {
$conteudo[]=array($key => $value);
}
}

echo json_encode(array($conteudo));

?>
a partir da linha "echo "<br>++++++++++++++++++<br><br>";", ele começa a escrever o código na tela, as linhas de código, desta parte pra cima, ele não aparece nada e nem retorna resultado.

Se eu colocar phpinfo(); ele também não interpreta, no XAMPP do windows funciona perfeitamente...


4. Re: Servidor não compila codigo - APACHE 2

cr0n
_di0

(usa FreeBSD)

Enviado em 18/09/2014 - 16:00h

O PHP não é compilado, é interpretado. Você instalou o módulo do Apache, pacote comumente chamado de libapache2-mod-php5?


5. Re: Servidor não compila codigo - APACHE 2

Luis R. C. Silva
luisrcs

(usa Linux Mint)

Enviado em 18/09/2014 - 18:23h

Se quer montar um servidor decente e sem complicação, use lighttpd.


6. Re: Servidor não compila codigo - APACHE 2

Franklin Costa Ferreira
franckcf

(usa Ubuntu)

Enviado em 19/09/2014 - 16:25h

_di0 escreveu:

O PHP não é compilado, é interpretado. Você instalou o módulo do Apache, pacote comumente chamado de libapache2-mod-php5?


As únicas coisas que instalei foi o apache2 e o php5, vou verificar se está instalado e dou um retorno...


7. Re: Servidor não compila codigo - APACHE 2

Reginaldo de Matias
saitam

(usa Slackware)

Enviado em 19/09/2014 - 17:02h

Segue os passos do tutorial desse link:
http://www.vivaolinux.com.br/dica/Instalacao-do-PHP-+-MySQL-+-Apache-+-PHPMyAdmin-e-resolvendo-probl...


8. Re: Servidor não compila codigo - APACHE 2

Franklin Costa Ferreira
franckcf

(usa Ubuntu)

Enviado em 02/10/2014 - 18:49h



Cara nesse turorial me deu o seguinte erro...

Erros foram encontrados durante o processamento de:
libapache2-mod-php5
E: Sub-process /usr/bin/dpkg returned an error code (1)







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts