Phalcon DevTools (4.0.3) ERROR: could not find driver

1. Phalcon DevTools (4.0.3) ERROR: could not find driver

Fabiano de Souza Pereira
fabianospdev

(usa Ubuntu)

Enviado em 29/05/2020 - 17:01h

Ocorre o erro Phalcon DevTools (4.0.3) ERROR: could not find driver ao tentar usar o Phalcon no comando: Phalcon create-model

Tem instalado:

apache2
Phalcon DevTools (4.0.3)
php7.4/libapache2-mod-php7.4_7.4.6-1+ubuntu20.04.1+deb.sury.org+1_amd64.deb
php7.4/php7.4-cli_7.4.6-1+ubuntu20.04.1+deb.sury.org+1_amd64.deb
php7.4/php7.4-common_7.4.6-1+ubuntu20.04.1+deb.sury.org+1_amd64.deb
php7.4/php7.4-dev_7.4.6-1+ubuntu20.04.1+deb.sury.org+1_amd64.deb
php7.4/php7.4-json_7.4.6-1+ubuntu20.04.1+deb.sury.org+1_amd64.deb
php7.4/php7.4-mbstring_7.4.6-1+ubuntu20.04.1+deb.sury.org+1_amd64.deb
php7.4/php7.4-opcache_7.4.6-1+ubuntu20.04.1+deb.sury.org+1_amd64.deb
php7.4/php7.4-pgsql_7.4.6-1+ubuntu20.04.1+deb.sury.org+1_amd64.deb
php7.4/php7.4-phpdbg_7.4.6-1+ubuntu20.04.1+deb.sury.org+1_amd64.deb
php7.4/php7.4-readline_7.4.6-1+ubuntu20.04.1+deb.sury.org+1_amd64.deb
php7.4/php7.4-xml_7.4.6-1+ubuntu20.04.1+deb.sury.org+1_amd64.deb
php7.4/php7.4-zip_7.4.6-1+ubuntu20.04.1+deb.sury.org+1_amd64.deb

php-defaults/php-pgsql_7.4+76+ubuntu20.04.1+deb.sury.org+9_all.deb
php7.4/php7.4-pgsql_7.4.6-1+ubuntu20.04.1+deb.sury.org+1_amd64.deb

postgresql-12/libpq5_12.3-1.pgdg20.04+1_amd64.deb
pgadmin4/pgadmin4_4.21-1.pgdg20.04+1_amd64.deb
pgadmin4/pgadmin4-apache2_4.21-1.pgdg20.04+1_all.deb
pgadmin4/pgadmin4-common_4.21-1.pgdg20.04+1_all.deb
pgadmin4/pgadmin4-doc_4.21-1.pgdg20.04+1_all.deb
pgdg-keyring/pgdg-keyring_2018.2_all.deb
php-defaults/php-pgsql_7.4+76+ubuntu20.04.1+deb.sury.org+9_all.deb
php7.4/php7.4-pgsql_7.4.6-1+ubuntu20.04.1+deb.sury.org+1_amd64.deb
postgresql-common/postgresql_12+215.pgdg20.04+1_all.deb
postgresql-12/postgresql-12_12.3-1.pgdg20.04+1_amd64.deb
postgresql-12/postgresql-client-12_12.3-1.pgdg20.04+1_amd64.deb
postgresql-common/postgresql-client-common_215.pgdg20.04+1_all.deb
postgresql-common/postgresql-common_215.pgdg20.04+1_all.deb
postgresql-common/postgresql-contrib_12+215.pgdg20.04+1_all.deb
python3-psycopg2_2.8.5-1~pgdg20.04+1_amd64.deb

apache2_2.4.41-4ubuntu3_amd64.deb
nano_4.8-1ubuntu1_amd64.deb
apache2-bin_2.4.41-4ubuntu3_amd64.deb
apache2-data_2.4.41-4ubuntu3_all.deb
apache2-utils_2.4.41-4ubuntu3_amd64.deb
libapache2-mod-php_7.4+76+ubuntu20.04.1+deb.sury.org+9_all.deb
libapache2-mod-php7.4_7.4.6-1+ubuntu20.04.1+deb.sury.org+1_amd64.deb
libapache2-mod-wsgi-py3_4.6.8-1ubuntu3_amd64.deb
libaprutil1_1.6.1-4ubuntu2_amd64.deb
ibapr1_1.6.5-1ubuntu1_amd64.deb
libaprutil1-dbd-sqlite3_1.6.1-4ubuntu2_amd64.deb
libaprutil1-ldap_1.6.1-4ubuntu2_amd64.deb
libdotconf0_1.3-0.3fakesync1_amd64.deb
libfile-listing-perl_6.04-1_all.deb
pgadmin4/pgadmin4-apache2_4.21-1.pgdg20.04+1_all.deb


[ PHP.INI ]
;extension=pdo_oci
;extension=pdo_odbc
extension=pdo_pgsql
extension=pdo_sqlite
extension=pgsql
;extension=shmop


No fim do php.ini
extension=psr.so
extension=phalcon.so

O site fica online certinho mas não conecta com o banco.

$ php -m
[PHP Modules]
calendar
Core
ctype
date
dom
exif
FFI
fileinfo
filter
ftp
gettext
hash
iconv
json
libxml
mbstring
openssl
pcntl
pcre
PDO
pdo_pgsql
pgsql
phalcon
Phar
posix
psr
readline
Reflection
session
shmop
SimpleXML
sockets
sodium
SPL
standard
sysvmsg
sysvsem
sysvshm
tokenizer
xml
xmlreader
xmlwriter
xsl
Zend OPcache
zip
zlib

[Zend Modules]
Zend OPcache

Já tentei isso: sudo phpenmod pdo_pgsql

Parei o serviço
sudo /etc/init.d/apache2 stop
sudo /etc/init.d/postgresql stop
Reiniciei
sudo /etc/init.d/apache2 start
sudo /etc/init.d/postgresql start

Fiz muita coisa indo nos tutoriais pelo mundo. Ainda não sei por que o drive não é achado.
Está instalado e carregado.

Sobre permisões de pastas ? Talvez seja mas onde ? Quais pastas exatamente devem ter permissões mudadas?

Alguém sabe?











  






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts