Não exibe imagem no Internet explorer Urgente

1. Não exibe imagem no Internet explorer Urgente

Lucas de Andrade Silveira
lsilveira

(usa Debian)

Enviado em 02/07/2008 - 11:02h

Bom dia estou criando um catalogo de produtos e quando clica no item ele abre um pop up com a imagem do item so que so esta funcionando no firefox , não funciona em nem uma versão do IE !!
so que quando eu mando ele da um echo no id que passa por get ele aparece e so a vizualização da imagem !!
ai vai o codigo !!

<?php

include ('includes/conecta.php');

$id= $_GET['id'];

$sql = "select * FROM produto where cod_produto = $id ";

$resultado = pg_exec($sql) or die ("Não foi possível executar a consulta");

while ($dados= pg_fetch_array($resultado)){

$nome = $dados['desc_produto'];

?>

<title><? echo $nome; ?></title>

<?

}



?>



<table width="100%" border="0">

<tr>

<td align="center"<img src="http://10.10.0.2/fotos/<?=$id?>".JPG " border="0"/></td>

</tr>

</table>

<?



agradeço a ajuda !!


  


2. Re: Não exibe imagem no Internet explorer Urgente

Lucas de Andrade Silveira
lsilveira

(usa Debian)

Enviado em 02/07/2008 - 11:50h

alguem ajuda ??


3. Re: Não exibe imagem no Internet explorer Urgente

Célio de Jesus Santos
celiojs

(usa Suse)

Enviado em 02/07/2008 - 12:32h

Ajuste esta linha:
<td align="center"<img src="http://10.10.0.2/fotos/<?=$id?>". JPG " border="0"/></td>

para:

<td align="center">
<img src="http://10.10.0.2/fotos/<?=$id?>.JPG" border="0"/>
</td>

Creio que irá resolver.

Até mais,

Célio


4. Re: Não exibe imagem no Internet explorer Urgente

Daniel Gimenes
DanielGimenes

(usa Ubuntu)

Enviado em 02/07/2008 - 12:34h

Faltou o > no td..


tbm acho q é isso...


5. Solucao

M4iir1c10
M4iir1c10

(usa Arch Linux)

Enviado em 02/07/2008 - 12:42h

Primeiro a tag <td align="center"> nao estava completa, voce terminou na palavra center.

Segundo o ip e da sua rede interna, caso voce queira colocar isso online para outras pessoas verem voce tem que colocar o ip do seu router e direcionar todas as coneccoes da porta 80 ou qualquer outra http que voce esteja usando para o ip da sua maquina.

Terceiro tem uma dupla aspas antes de .jpg fechando o src antes do tempo, depois uma de sobra depois do JPG estragando tudo.

Quarto tem certeza que esse JPG e maiusculo? todos os seus arquivos estao com ele em maiusculo? eu aconselho usar tudo minusculo.

Quinto use echo $id invez de =$id

Ultima a tag de fechamento do php e ?> e nao >?

Resultado final dessa parte do seu codigo:

<td align="center"><img src="http://10.10.0.2/fotos/<?echo $id?>.JPG " border="0"/></td>

</tr>

</table>

?>


6. Re: Não exibe imagem no Internet explorer Urgente

Lucas de Andrade Silveira
lsilveira

(usa Debian)

Enviado em 02/07/2008 - 13:45h

funciono !!
vlw pela dica !!
e sobre as imagens eu coloquei esse caminho para testes internos , quando publicar na net vai ser local , e todas imagens estão em JPG maiusculo pq e padrão do sistema em delphi que roda aqui .
vlww






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts