Configuração de servidor PHP [RESOLVIDO]

1. Configuração de servidor PHP [RESOLVIDO]

Joaquim Martins Scavone
joaquimscavone

(usa Deepin)

Enviado em 13/02/2018 - 18:05h

Ola pessoal,

Estou enfrentando o seguinte problema,uso o Deepin 15.5 e meu servidor apache não está subindo sozinho, ou seja, quando eu inicializo o sistema o apache não da start sozinho. Assim que faço a autenticação dou um apache status e recebo o seguinte retorno:

sudo /etc/init.d/apache2 status
apache2.service - The Apache HTTP Server
Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
Active: failed (Result: timeout) since Tue 2018-02-13 16:48:24 -03; 1min 34s ago
Process: 507 ExecStart=/usr/sbin/apachectl start (code=killed, signal=TERM)

fev 13 16:48:14 JS-NOT systemd[1]: Starting The Apache HTTP Server...
fev 13 16:48:24 JS-NOT systemd[1]: apache2.service: Start operation timed out…ing.
fev 13 16:48:24 JS-NOT systemd[1]: Failed to start The Apache HTTP Server.
fev 13 16:48:24 JS-NOT systemd[1]: apache2.service: Unit entered failed state.
fev 13 16:48:24 JS-NOT systemd[1]: apache2.service: Failed with result 'timeout'.
Hint: Some lines were ellipsized, use -l to show in full.

o engraçado é que se eu digito o comando o apache sob de boa:
/etc/init.d/apache2 start

Alguém sabe o motivo?


  


2. Re: Configuração de servidor PHP [RESOLVIDO]

Fabiano
fpires

(usa Debian)

Enviado em 13/02/2018 - 19:21h

joaquimscavone escreveu:

Ola pessoal,

Estou enfrentando o seguinte problema,uso o Deepin 15.5 e meu servidor apache não está subindo sozinho, ou seja, quando eu inicializo o sistema o apache não da start sozinho. Assim que faço a autenticação dou um apache status e recebo o seguinte retorno:

sudo /etc/init.d/apache2 status
apache2.service - The Apache HTTP Server
Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
Active: failed (Result: timeout) since Tue 2018-02-13 16:48:24 -03; 1min 34s ago
Process: 507 ExecStart=/usr/sbin/apachectl start (code=killed, signal=TERM)

fev 13 16:48:14 JS-NOT systemd[1]: Starting The Apache HTTP Server...
fev 13 16:48:24 JS-NOT systemd[1]: apache2.service: Start operation timed out…ing.
fev 13 16:48:24 JS-NOT systemd[1]: Failed to start The Apache HTTP Server.
fev 13 16:48:24 JS-NOT systemd[1]: apache2.service: Unit entered failed state.
fev 13 16:48:24 JS-NOT systemd[1]: apache2.service: Failed with result 'timeout'.
Hint: Some lines were ellipsized, use -l to show in full.

o engraçado é que se eu digito o comando o apache sob de boa:
/etc/init.d/apache2 start

Alguém sabe o motivo?

Experimente executar
systemctl is-enabled apache2

Deve mostrar disabled
Então execute
systemctl enable apache2

E reinicie para testar.



3. Re: Configuração de servidor PHP [RESOLVIDO]

Joaquim Martins Scavone
joaquimscavone

(usa Deepin)

Enviado em 13/02/2018 - 19:42h

fpires escreveu:

joaquimscavone escreveu:

Ola pessoal,

Estou enfrentando o seguinte problema,uso o Deepin 15.5 e meu servidor apache não está subindo sozinho, ou seja, quando eu inicializo o sistema o apache não da start sozinho. Assim que faço a autenticação dou um apache status e recebo o seguinte retorno:

sudo /etc/init.d/apache2 status
apache2.service - The Apache HTTP Server
Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
Active: failed (Result: timeout) since Tue 2018-02-13 16:48:24 -03; 1min 34s ago
Process: 507 ExecStart=/usr/sbin/apachectl start (code=killed, signal=TERM)

fev 13 16:48:14 JS-NOT systemd[1]: Starting The Apache HTTP Server...
fev 13 16:48:24 JS-NOT systemd[1]: apache2.service: Start operation timed out…ing.
fev 13 16:48:24 JS-NOT systemd[1]: Failed to start The Apache HTTP Server.
fev 13 16:48:24 JS-NOT systemd[1]: apache2.service: Unit entered failed state.
fev 13 16:48:24 JS-NOT systemd[1]: apache2.service: Failed with result 'timeout'.
Hint: Some lines were ellipsized, use -l to show in full.

o engraçado é que se eu digito o comando o apache sob de boa:
/etc/init.d/apache2 start

Alguém sabe o motivo?

Experimente executar
systemctl is-enabled apache2

Deve mostrar disabled
Então execute
systemctl enable apache2

E reinicie para testar.


Não deu certo já estava ativado. ele tenta iniciar porem da falha.


4. Re: Configuração de servidor PHP [RESOLVIDO]

Fabiano
fpires

(usa Debian)

Enviado em 13/02/2018 - 22:41h

Então tem que ver os detalhes do erro. Provavelmente o conteúdo de /var/log/apache2/error.log e/ou service apache2 status devem te dar a solução ou ao menos uma pista,


5. Logs

Joaquim Martins Scavone
joaquimscavone

(usa Deepin)

Enviado em 15/02/2018 - 17:57h

Então pessoal, eu tenho a impressão que é alguma coisa com permissão quando eu dou o comando pra subir com o sudo funciona blz, quando mando o comando direto ele da o mesmo erro da inicialização. Isso me faz crer que a inicialização está tentando subir o servidor com meu usuário não com o root.


6. Re: Configuração de servidor PHP [RESOLVIDO]

Fabiano
fpires

(usa Debian)

Enviado em 15/02/2018 - 19:09h

fpires escreveu:

Então tem que ver os detalhes do erro. Provavelmente o conteúdo de /var/log/apache2/error.log e/ou service apache2 status devem te dar a solução ou ao menos uma pista





7. Re: Configuração de servidor PHP [RESOLVIDO]

Joaquim Martins Scavone
joaquimscavone

(usa Deepin)

Enviado em 15/02/2018 - 19:18h

fpires escreveu:

fpires escreveu:

Então tem que ver os detalhes do erro. Provavelmente o conteúdo de /var/log/apache2/error.log e/ou service apache2 status devem te dar a solução ou ao menos uma pista



a unica coisa que o arquivo de log armazena é isso:

[Thu Feb 15 16:47:33.843887 2018] [core:notice] [pid 3232:tid 139786796266688] AH00094: Command line: '/usr/sbin/apache2'
[Thu Feb 15 16:58:50.475720 2018] [mpm_event:notice] [pid 3232:tid 139786796266688] AH00491: caught SIGTERM, shutting down



8. Re: Configuração de servidor PHP [RESOLVIDO]

Rodrigo
omag0

(usa CentOS)

Enviado em 16/02/2018 - 14:20h

Quer uma dica? use Docker com Laradock, e diga adeus a horas de configuracao e perda de tempo.


9. Problema resolvido

Joaquim Martins Scavone
joaquimscavone

(usa Deepin)

Enviado em 16/02/2018 - 14:38h

Um amigo meu resolveu a treta aqui adicionou o comando de start no rc.local







Patrocínio

Site hospedado pelo provedor HostGator.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Viva o Android

Tópicos

Top 10 do mês

Scripts