Dpkg com erro [RESOLVIDO]

1. Dpkg com erro [RESOLVIDO]

Edson Celestino Alves da Silva
Edson_silva

(usa Linux Mint)

Enviado em 31/08/2019 - 17:23h

Depende: libpython3.6 (>= 3.6.0~b2) mas não será instalado
Depende: bluez (>= 4.61)
Depende: obexd-client (>= 0.47) mas não é instalável ou
bluez-obexd mas não será instalado
Depende: obexd-server (>= 0.47) mas não é instalável ou
bluez-obexd mas não será instalado
Depende: notification-daemon
Depende: gnome-icon-theme
Depende: libpulse-mainloop-glib0 mas não será instalado
Depende: gir1.2-notify-0.7 mas não será instalado
Depende: python3-cairo mas não será instalado
Depende: python3-gi-cairo mas não será instalado
Depende: gir1.2-appindicator3-0.1 mas não será instalado
libtool : Depende: libc6-dev mas não será instalado ou
libc-dev

E: Não foi possível abrir arquivo de trava /var/lib/dpkg/lock-frontend - open (13: Permission denied)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?


O meu dpkg e o meu phynton esta praticamente acabado sempre que tento baixar alguma coisa da erro no libtool e no phynton por estar varios pacotes faltando


  


2. Re: Dpkg com erro [RESOLVIDO]

niquelnausea
niquelnausea

(usa Arch Linux)

Enviado em 31/08/2019 - 17:26h

e por que não usa o apt? de preferencia como root ou mesmo com o sudo.


3. Re: Dpkg com erro [RESOLVIDO]

Edson Celestino Alves da Silva
Edson_silva

(usa Linux Mint)

Enviado em 31/08/2019 - 17:41h

niquelnausea escreveu:

e por que não usa o apt? de preferencia como root ou mesmo com o sudo.


Deu o mesmo erro apt install bluetooth bluez bluez-tools rfkill -y
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você pode querer executar 'apt --fix-broken install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
ar3011-dkms : Depende: dkms (>= 1.95) mas não será instalado
libtool : Depende: libc6-dev mas não será instalado ou
libc-dev
lutris : Depende: python3-evdev mas não será instalado
Depende: python3-requests mas não será instalado
Depende: python3-yaml mas não será instalado
Depende: python3-pil mas não será instalado
Depende: gir1.2-gnomedesktop-3.0 mas não será instalado
Depende: gir1.2-webkit2-4.0 mas não será instalado
Depende: gir1.2-notify-0.7 mas não será instalado
Depende: fluid-soundfont-gs mas não será instalado
Depende: x11-xserver-utils mas não será instalado
E: Dependências desencontradas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).
no apt e no apt-get


4. Re: Dpkg com erro [RESOLVIDO]

Paulo Jr
Pebis

(usa Debian)

Enviado em 31/08/2019 - 18:03h


Primeiro, tentou o apt --fix-broken? Colocou repositório no seu sistema?


5. Re: Dpkg com erro [RESOLVIDO]

niquelnausea
niquelnausea

(usa Arch Linux)

Enviado em 31/08/2019 - 18:09h

tente o que o amigo falou (e o próprio gerenciador de pacotes também), o "apt --fix-broken".

segundo, esse pacote que esta tentando instalar, é um .deb qualquer que você baixou de algum site que não seja os repositórios oficiais? ou o erro acontece quando tenta instalar esse três "bluetooth bluez bluez-tools rfkill"?
terceiro, tua source.list esta certinha? configurada para a versão que esta usando?


6. Re: Dpkg com erro

Edson Celestino Alves da Silva
Edson_silva

(usa Linux Mint)

Enviado em 31/08/2019 - 18:13h

niquelnausea escreveu:

tente o que o amigo falou (e o próprio gerenciador de pacotes também), o "apt --fix-broken".

segundo, esse pacote que esta tentando instalar, é um .deb qualquer que você baixou de algum site que não seja os repositórios oficiais? ou o erro acontece quando tenta instalar esse três "bluetooth bluez bluez-tools rfkill"?
terceiro, tua source.list esta certinha? configurada para a versão que esta usando?


Minha source.list tem isso

deb http://archive.canonical.com/ubuntu tara partner



e a .save tem isso
Experimental/unstable (sid) repositories
deb http://ftp.debian.org/debian experimental main
deb http://ftp.debian.org/debian sid main
deb http://archive.canonical.com/ubuntu tara partner


E:The repository 'http://archive.canonical.com/ubuntu tara Release' does not have a Release file.


7. Re: Dpkg com erro [RESOLVIDO]

niquelnausea
niquelnausea

(usa Arch Linux)

Enviado em 31/08/2019 - 18:25h

então você esta usando o mint, eu não tenho experiencia com esse sistema, mas sei que ele tem um gerenciador de atualizações.
veja nesta ferramenta quais repositórios estão habilitados, tudo de forma gráfica.


8. Re: Dpkg com erro [RESOLVIDO]

Edson Celestino Alves da Silva
Edson_silva

(usa Linux Mint)

Enviado em 31/08/2019 - 18:28h

niquelnausea escreveu:

então você esta usando o mint, eu não tenho experiencia com esse sistema, mas sei que ele tem um gerenciador de atualizações.
veja nesta ferramenta quais repositórios estão habilitados, tudo de forma gráfica.


niquelnausea
dpkg: erro: falhou ao abrir arquivo de informações do pacote '/var/lib/dpkg/available' para leitura: No such file or directory
E: Sub-processo dpkg --set-selections retornou um código de erro (2)
E: Couldn't record the approved state changes as dpkg selection states

Esse erro da ao tentar rodar o comando sudo apt-get install -f
Se eu conseguir remover esse erro consiguirei instalar todos os pacotes que estao faltando assim estara tudo normal meu sistema


9. Dpkg com erro

Edson Celestino Alves da Silva
Edson_silva

(usa Linux Mint)

Enviado em 31/08/2019 - 18:35h

AEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE MUITO OBRIGADO PELA AJUDA POIS RODEI O COMANDO dpkg --clear-avail
E DEPOIS apt-get update
AI RODEI SUDO APT-GET INSTALL -F
E DEU CERTO

OBRIGADOOOOO







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts