OpenOffice no Fedora 30

1. OpenOffice no Fedora 30

Thiago Silva
pain-sama

(usa Arch Linux)

Enviado em 02/05/2019 - 10:29h

Saudações!
Há um bom tempo dei preferência ao uso do OpenOffice em lugar do LibreOffice, pelo simples fato de se adaptar melhor às minhas dificuldades visuais ao usar algum tema escuro, no caso, o Adwaita Dark. Em todo caso, atualizei o Fedora para a versão recém-lançada, a 30, e realizei o mesmo processo de instalação do OpenOffice que utilizava no 29, porém ele simplesmente não funciona. Nenhum dos aplicativos da suite sequer abre.

Alguém já teve tempo de tentar utilizar esse pacote na nova versão do Fedora? Se sim, funcionou? Agradeço desde já!

Instalei deste modo:
Baixei o arquivo .tar.gz do site oficial, descompactei e instalei os rpms com
# rpm -ivh *.rpm 

Depois entrei na pasta "desktop-integration" e instalei o rpm relativo a Red Hat.
Naturalmente, antes tinha instalado a última versão do Java, com o comando:
# dnf install java-11-openjdk-devel java-11-openjdk gdk-pixbuf2-xlib -y 



  


2. Re: OpenOffice no Fedora 30

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 02/05/2019 - 10:49h


abre ele via linha de comando e passa o erro ai para podemos de ajudar


3. Re: OpenOffice no Fedora 30

Thiago Silva
pain-sama

(usa Arch Linux)

Enviado em 02/05/2019 - 11:07h

danniel-lara escreveu:


abre ele via linha de comando e passa o erro ai para podemos de ajudar


Ao tentar abrir pelo terminal ele retorna os seguintes erros:
[root@pain pain]# soffice
/opt/openoffice4/program/javaldx: error while loading shared libraries: libcrypt.so.1: cannot open shared object file: No such file or directory
/opt/openoffice4/program/soffice.bin: error while loading shared libraries: libcrypt.so.1: cannot open shared object file: No such file or directory


Obrigado!


4. Mesmo problema

Marcelo Hamati
mhamati

(usa Fedora)

Enviado em 05/08/2019 - 20:02h

Pessoal, estou com o mesmo problema quando tento executar o openoffice4:

[user_name@hostname ~]$ openoffice4
/opt/openoffice4/program/javaldx: error while loading shared libraries: libcrypt.so.1: cannot open shared object file: No such file or directory
/opt/openoffice4/program/soffice.bin: error while loading shared libraries: libcrypt.so.1: cannot open shared object file: No such file or directory

Eu executei esse comando e apareceu o seguinte:

[user_name@hostname ~]$ ldd /opt/openoffice4/program/soffice.bin
linux-vdso.so.1 (0x00007ffded3b3000)
libuno_sal.so.3 => /opt/openoffice4/program/libuno_sal.so.3 (0x00007ff4602af000)
libsofficeapp.so => /opt/openoffice4/program/libsofficeapp.so (0x00007ff460022000)
libXext.so.6 => /lib64/libXext.so.6 (0x00007ff45ffed000)
libX11.so.6 => /lib64/libX11.so.6 (0x00007ff45fea8000)
libstdc++.so.6 => /lib64/libstdc++.so.6 (0x00007ff45fcaf000)
libm.so.6 => /lib64/libm.so.6 (0x00007ff45fb69000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007ff45fb4d000)
libc.so.6 => /lib64/libc.so.6 (0x00007ff45f987000)
libcrypt.so.1 => not found
libdl.so.2 => /lib64/libdl.so.2 (0x00007ff45f981000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007ff45f960000)
libcomphelpgcc3.so => /opt/openoffice4/program/libcomphelpgcc3.so (0x00007ff45f60c000)
libuno_cppuhelpergcc3.so.3 => /opt/openoffice4/program/libuno_cppuhelpergcc3.so.3 (0x00007ff45f312000)
libuno_cppu.so.3 => /opt/openoffice4/program/libuno_cppu.so.3 (0x00007ff45f0dd000)
libdeploymentmisc.so => /opt/openoffice4/program/libdeploymentmisc.so (0x00007ff45eeb5000)
libdeploymentgui.uno.so => /opt/openoffice4/program/libdeploymentgui.uno.so (0x00007ff45ec36000)
libi18nisolang1gcc3.so => /opt/openoffice4/program/libi18nisolang1gcc3.so (0x00007ff45ea30000)
libsfx.so => /opt/openoffice4/program/libsfx.so (0x00007ff45e3e3000)
libsvl.so => /opt/openoffice4/program/libsvl.so (0x00007ff45e0d4000)
libsvt.so => /opt/openoffice4/program/libsvt.so (0x00007ff45da4b000)
libootk.so => /opt/openoffice4/program/libootk.so (0x00007ff45d48b000)
libtl.so => /opt/openoffice4/program/libtl.so (0x00007ff45d1d1000)
libucbhelper4gcc3.so => /opt/openoffice4/program/libucbhelper4gcc3.so (0x00007ff45cf50000)
libutl.so => /opt/openoffice4/program/libutl.so (0x00007ff45cbe0000)
libvcl.so => /opt/openoffice4/program/libvcl.so (0x00007ff45c4bd000)
libvos3gcc3.so => /opt/openoffice4/program/libvos3gcc3.so (0x00007ff45c295000)
libxcb.so.1 => /lib64/libxcb.so.1 (0x00007ff45c26a000)
/lib64/ld-linux-x86-64.so.2 (0x00007ff4606ad000)
libuno_salhelpergcc3.so.3 => /opt/openoffice4/program/libuno_salhelpergcc3.so.3 (0x00007ff45c066000)
libxcr.so => /opt/openoffice4/program/libxcr.so (0x00007ff45bdb9000)
libsvx.so => /opt/openoffice4/program/libsvx.so (0x00007ff45b7d9000)
libsvxcore.so => /opt/openoffice4/program/libsvxcore.so (0x00007ff45ae47000)
libfwe.so => /opt/openoffice4/program/libfwe.so (0x00007ff45ab98000)
libsax.so => /opt/openoffice4/program/libsax.so (0x00007ff45a97f000)
libsb.so => /opt/openoffice4/program/libsb.so (0x00007ff45a571000)
libsot.so => /opt/openoffice4/program/libsot.so (0x00007ff45a312000)
libxml2.so.2 => /opt/openoffice4/program/libxml2.so.2 (0x00007ff459fc9000)
libbasegfx.so => /opt/openoffice4/program/libbasegfx.so (0x00007ff459cfc000)
libi18nutilgcc3.so => /opt/openoffice4/program/libi18nutilgcc3.so (0x00007ff459ae9000)
libjvmfwk.so.3 => /opt/openoffice4/program/libjvmfwk.so.3 (0x00007ff4598ce000)
libicuuc.so.40 => /opt/openoffice4/program/libicuuc.so.40 (0x00007ff45958e000)
libicule.so.40 => /opt/openoffice4/program/libicule.so.40 (0x00007ff459359000)
libi18npaper.so => /opt/openoffice4/program/libi18npaper.so (0x00007ff459153000)
libjvmaccessgcc3.so.3 => /opt/openoffice4/program/libjvmaccessgcc3.so.3 (0x00007ff458f4d000)
libfreetype.so.6 => /lib64/libfreetype.so.6 (0x00007ff458e90000)
libXau.so.6 => /lib64/libXau.so.6 (0x00007ff458e88000)
libdrawinglayer.so => /opt/openoffice4/program/libdrawinglayer.so (0x00007ff458b7b000)
libediteng.so => /opt/openoffice4/program/libediteng.so (0x00007ff458773000)
libfwk.so => /opt/openoffice4/program/libfwk.so (0x00007ff458321000)
libxo.so => /opt/openoffice4/program/libxo.so (0x00007ff457d6c000)
libavmedia.so => /opt/openoffice4/program/libavmedia.so (0x00007ff457b33000)
liblng.so => /opt/openoffice4/program/liblng.so (0x00007ff45787c000)
libfwi.so => /opt/openoffice4/program/libfwi.so (0x00007ff45764c000)
libicudata.so.40 => /opt/openoffice4/program/libicudata.so.40 (0x00007ff456707000)
libbz2.so.1 => /lib64/libbz2.so.1 (0x00007ff4566f1000)
libpng16.so.16 => /lib64/libpng16.so.16 (0x00007ff4566bb000)
libz.so.1 => /lib64/libz.so.1 (0x00007ff4566a1000)
libcanvastools.so => /opt/openoffice4/program/libcanvastools.so (0x00007ff456467000)
libcppcanvas.so => /opt/openoffice4/program/libcppcanvas.so (0x00007ff456201000)

Só para constar, eu tenho instalado o pacote:

[user_name@hostname ~]$ sudo dnf provides libcrypt.so.1
Last metadata expiration check: 1:09:38 ago on Mon 05 Aug 2019 02:55:54 PM PDT.
libxcrypt-compat-4.4.4-2.fc30.i686 : Compatibility library providing legacy API functions
Repo : @System
Matched from:
Provide : libcrypt.so.1

Alguém conseguiu resolver?

Obrigado,

Marcelo Hamati



5. Re: OpenOffice no Fedora 30

Thiago Silva
pain-sama

(usa Arch Linux)

Enviado em 05/08/2019 - 20:17h

mhamati escreveu:

Pessoal, estou com o mesmo problema quando tento executar o openoffice4:
...
Só para constar, eu tenho instalado o pacote:

[user_name@hostname ~]$ sudo dnf provides libcrypt.so.1
...
Alguém conseguiu resolver?

Obrigado,

Marcelo Hamati


Essa libcrypt.so.1 foi a primeira coisa que eu verifiquei se estava nos conformes quando tive o problema, não ajudou nada. Ele sinaliza problemas em "bibliotecas compartilhadas", e parece mesmo que tem alguma dependência quebrada. Muito provavelmente alguma coisa necessária foi atualizada do F29 para o F30 e o pessoal do Apache ainda vai tentar dar um jeito. Talvez desse para fazer downgrade dessa biblioteca, mas poderia quebrar outros pacotes que precisam dela atualizada...
Eu achei mais simples mudar para o Arch Linux. O Gnome é igual e os pacotes bem atualizados também.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts