Shellshock, falha segurança no Bash

1. Shellshock, falha segurança no Bash

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 26/09/2014 - 08:54h

Shellshock: falha de segurança grave no Bash afeta máquinas com Linux e OS X

https://tecnoblog.net/166271/shellshock-falha-grave-bash/

Seu linux está protegido ?



  


2. Re: Shellshock, falha segurança no Bash

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 26/09/2014 - 08:55h

sim , já atualizei o meu bash




3. Re: Shellshock, falha segurança no Bash

Eduardo Paim Silveira
eduardo

(usa CentOS)

Enviado em 26/09/2014 - 09:03h

Pra quem usa RH Like, já lançaram update.

# yum update bash -y


4. Re: Shellshock, falha segurança no Bash

Perfil removido
removido

(usa Nenhuma)

Enviado em 26/09/2014 - 10:03h

Bom dia a todos.

Para verificar se sua versão do Bash está vulnerável, execute os testes do link a seguir:

https://shellshocker.net/#systemtest


5. Re: Shellshock, falha segurança no Bash

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 26/09/2014 - 20:51h

Meu LinuxMint estava protegido.
Meu Xubuntu estava vulnerável, após rodar " sudo apt-get update && sudo apt-get upgrade " ficou protegido!

Eu rodei este comando para testar:
env x='() { :;}; echo vulnerável' bash -c "echo teste"

Se aparecer "vulnerável" atualize seu bash imediatamente!


6. Re: Shellshock, falha segurança no Bash

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 26/09/2014 - 21:34h

eduardo escreveu:
Pra quem usa RH Like, já lançaram update.
# yum update bash -y


Meu F20-MATE estava vulnerável mas foi corrigido facilmente com essa dica!




7. Re: Shellshock, falha segurança no Bash

Perfil removido
removido

(usa Nenhuma)

Enviado em 26/09/2014 - 21:53h

Boa noite,

Manjaro fez a correção ontem.

Até...


8. Re: Shellshock, falha segurança no Bash

Perfil removido
removido

(usa Nenhuma)

Enviado em 26/09/2014 - 22:16h

jbaf escreveu:

Boa noite,

Manjaro fez a correção ontem.

Até...


Meu kubuntu 12.04 lts também já está....

até...


9. Re: Shellshock, falha segurança no Bash

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 26/09/2014 - 22:23h

Meu LMDE-2014 está vulnerável mesmo após update && upgrade.

Alguém tem uma outra dica ??


10. Re: Shellshock, falha segurança no Bash

Fernando
phoemur

(usa FreeBSD)

Enviado em 27/09/2014 - 16:54h

clodoaldops escreveu:

Meu LMDE-2014 está vulnerável mesmo após update && upgrade.

Alguém tem uma outra dica ??


segundo o site https://shellshocker.net/#systemtest
experimenta compilar o bash com os patches de segurança


cd ~/
mkdir bash
cd bash
wget https://ftp.gnu.org/gnu/bash/bash-4.3.tar.gz
#download all patches
for i in $(seq -f "%03g" 0 26); do wget https://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-$i; done
tar zxvf bash-4.3.tar.gz
cd bash-4.3
for i in $(seq -f "%03g" 0 26);do patch -p0 < ../bash43-$i; done
./configure && make && make install



11. Re: Shellshock, falha segurança no Bash

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 27/09/2014 - 17:26h

Compilar ???
http://i.imgur.com/mulFfRk.jpg


12. Re: Shellshock, falha segurança no Bash

Edson Harder
harder

(usa Deepin)

Enviado em 27/09/2014 - 18:06h

Clodoaldo,

é para atualizar, Shellshock Bash bug

http://www.troyhunt.com/2014/09/everything-you-need-to-know-about.html

O Cara aí manda treinar o “Curinthias pôlista”



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts