não consigo instalar beersmtih2

1. não consigo instalar beersmtih2

marcelo pias
mpias

(usa Ubuntu)

Enviado em 16/04/2020 - 14:47h

boa tarde,
sempre consegui usar o beersmith2 no ubuntu mas troquei pelo ubuntu studio e nãoestou conseguindo instalar agora..
[email protected]:~/Downloads$ sudo dpkg -i BeerSmith-2.3.12_17_04amd64.deb
[sudo] senha para marcelo:
A seleccionar pacote anteriormente não seleccionado beersmith2.
(Lendo banco de dados ... 410374 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar BeerSmith-2.3.12_17_04amd64.deb ...
A descompactar beersmith2 (2.3.12) ...
dpkg: problemas com dependências impedem a configuração de beersmith2:
beersmith2 depende de libwebkitgtk-1.0-0; porém:
Pacote libwebkitgtk-1.0-0 não está instalado.

dpkg: erro ao processar o pacote beersmith2 (--install):
problemas de dependência - deixando desconfigurado
A processar 'triggers' para desktop-file-utils (0.24-1ubuntu1) ...
A processar 'triggers' para mime-support (3.63ubuntu1) ...
A processar 'triggers' para hicolor-icon-theme (0.17-2) ...
Erros foram encontrados durante o processamento de:
beersmith2
[email protected]:~/Downloads$ sudo dpkg -i BeerSmith-2.3.12_14_amd64.deb
(Lendo banco de dados ... 411742 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar BeerSmith-2.3.12_14_amd64.deb ...
A descompactar beersmith2 (2.3.12) sobre (2.3.12) ...
dpkg: problemas com dependências impedem a configuração de beersmith2:
beersmith2 depende de libwebkitgtk-1.0-0; porém:
Pacote libwebkitgtk-1.0-0 não está instalado.

dpkg: erro ao processar o pacote beersmith2 (--install):
problemas de dependência - deixando desconfigurado
A processar 'triggers' para hicolor-icon-theme (0.17-2) ...
A processar 'triggers' para desktop-file-utils (0.24-1ubuntu1) ...
A processar 'triggers' para mime-support (3.63ubuntu1) ...
Erros foram encontrados durante o processamento de:
beersmith2

estou com esse problema.. o que posso fazer?



  


2. Re: não consigo instalar beersmtih2

Ricardo Groetaers
ricardogroetaers

(usa Linux Mint)

Enviado em 19/04/2020 - 18:36h

Não achei esse cara em versão estável:
BeerSmith-2.3.12_17_04amd64.deb
No site do Beersmtih:
http://beersmith.com/
Tem beersmith 3 para Ubuntu 16.04 e 18.04 e beersmith 2 para Ubuntu 16.04 e 14.04.
O que voce está tentando instalar é um beta.

Faça o download da versão estável de acordo com sua versão do Ubuntu.
Eu baixei a versão 3 para Ubuntu 16.04 (Mint 18.x) e simulei a instalação (sem instalar).
O instalador de pacotes deb do Mint não chiou.


3. Re: não consigo instalar beersmtih2

Adriano Siqueira
adrisiq

(usa KDE Neon)

Enviado em 19/04/2020 - 19:48h

Isso aí é problema de dependência. Executa isso:
sudo apt-get update
sudo apt-get install --yes --fix-broken
sudo dpkg --configure -a



4. Re: não consigo instalar beersmtih2

marcelo pias
mpias

(usa Ubuntu)

Enviado em 19/04/2020 - 19:56h

boa noite.
não funcionou.. na verdade acho que eles querem vender o beersmith3.. esse eu baixei e rodou.. mas não quero comprar outro o beermith2 me supre bem..

[email protected]:~/Downloads$ sudo dpkg -i BeerSmith-2.3.12_17_04amd64.deb
(Lendo banco de dados ... 422128 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar BeerSmith-2.3.12_17_04amd64.deb ...
A descompactar beersmith2 (2.3.12) sobre (2.3.12) ...
dpkg: problemas com dependências impedem a configuração de beersmith2:
beersmith2 depende de libwebkitgtk-1.0-0; porém:
Pacote libwebkitgtk-1.0-0 não está instalado.

dpkg: erro ao processar o pacote beersmith2 (--install):
problemas de dependência - deixando desconfigurado
A processar 'triggers' para desktop-file-utils (0.24-1ubuntu1) ...
A processar 'triggers' para mime-support (3.63ubuntu1) ...
A processar 'triggers' para hicolor-icon-theme (0.17-2) ...
Erros foram encontrados durante o processamento de:
beersmith2


obrigado pela ajuda.


5. Re: não consigo instalar beersmtih2

Adriano Siqueira
adrisiq

(usa KDE Neon)

Enviado em 20/04/2020 - 10:35h

sudo apt-get install libwebkitgtk-1.0-0
sudo dpkg --configure -a



6. Re: não consigo instalar beersmtih2

marcelo pias
mpias

(usa Ubuntu)

Enviado em 20/04/2020 - 11:35h

obrigado pela ajuda

[email protected]:~$ sudo apt-get install libwebkitgtk-1.0-0
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
O pacote libwebkitgtk-1.0-0 não está disponível, mas é referenciado por outro pacote.
Isto pode significar que o pacote está faltando, ficou obsoleto ou
está disponível somente a partir de outra fonte

E: O pacote 'libwebkitgtk-1.0-0' não tem candidato para instalação



7. Re: não consigo instalar beersmtih2

Ricardo Groetaers
ricardogroetaers

(usa Linux Mint)

Enviado em 20/04/2020 - 16:25h

mpias escreveu:
E: O pacote 'libwebkitgtk-1.0-0' não tem candidato para instalação

Se o problema é esse pacote, baixe-o de:
http://archive.ubuntu.com/ubuntu/pool/universe/w/webkitgtk/libwebkitgtk-1.0-0_2.4.11-0ubuntu0.1_amd6...


8. Re: não consigo instalar beersmtih2

marcelo pias
mpias

(usa Ubuntu)

Enviado em 20/04/2020 - 22:49h

[email protected]:~/Downloads$ sudo dpkg -i libwebkitgtk-1.0-0_2.4.11-0ubuntu0.1_amd64.deb
[sudo] senha para marcelo:
A seleccionar pacote anteriormente não seleccionado libwebkitgtk-1.0-0:amd64.
(Lendo banco de dados ... 420760 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar libwebkitgtk-1.0-0_2.4.11-0ubuntu0.1_amd64.deb ...
A descompactar libwebkitgtk-1.0-0:amd64 (2.4.11-0ubuntu0.1) ...
dpkg: problemas com dependências impedem a configuração de libwebkitgtk-1.0-0:amd64:
libwebkitgtk-1.0-0:amd64 depende de libjavascriptcoregtk-1.0-0 (= 2.4.11-0ubuntu0.1); porém:
Pacote libjavascriptcoregtk-1.0-0 não está instalado.
libwebkitgtk-1.0-0:amd64 depende de libgeoclue0 (>= 0.11.1+git20091217); porém:
Pacote libgeoclue0 não está instalado.
libwebkitgtk-1.0-0:amd64 depende de libicu55 (>= 55.1-1~); porém:
Pacote libicu55 não está instalado.
libwebkitgtk-1.0-0:amd64 depende de libpng12-0 (>= 1.2.13-4); porém:
Pacote libpng12-0 não está instalado.
libwebkitgtk-1.0-0:amd64 depende de libwebp5 (>= 0.4.3); porém:
Pacote libwebp5 não está instalado.
libwebkitgtk-1.0-0:amd64 depende de libwebkitgtk-1.0-common (>= 2.4.11); porém:
Pacote libwebkitgtk-1.0-common não está instalado.

dpkg: erro ao processar o pacote libwebkitgtk-1.0-0:amd64 (--install):
problemas de dependência - deixando desconfigurado
A processar 'triggers' para libc-bin (2.30-0ubuntu2.1) ...
Erros foram encontrados durante o processamento de:
libwebkitgtk-1.0-0:amd64
não rolou.. mas valeu a tentativa...

obrigado


9. Re: não consigo instalar beersmtih2

Ricardo Groetaers
ricardogroetaers

(usa Linux Mint)

Enviado em 21/04/2020 - 00:59h

Não uso Ubuntu, uso Mint.
Acredito que Ubuntu deve ter um "Instalador de pacotes" que resolva (ou tente) resolver as dependências, Como por exemplo o Gdeb.
Não entendo porque usas o programa dpkg que não resolve as dependências.

Anote as dependências faltantes e instale-as, pelo Synaptic, por exemplo.



10. Re: não consigo instalar beersmtih2

Adriano Siqueira
adrisiq

(usa KDE Neon)

Enviado em 21/04/2020 - 11:17h

Acesse essa página: https://raw.githubusercontent.com/AdrianoSiqueira/ShellScript/master/self_maintenance.sh
Clique com o botão direito > Salvar como > salve em um lugar de fácil acesso. Deixe o nome como self_maintenance.sh
Abra o terminal na pasta onde salvou e digite o seguinte:
sudo chmod 777 self_maintenance.sh
./self_maintenance.sh --all

Isso vai rodar uma sequência de tarefas de manutenção na sua máquina que envolve: atualização completa, limpeza de lixo de sistema, reparação de pacotes quebrados e atualização do grub.


11. Re: não consigo instalar beersmtih2

marcelo pias
mpias

(usa Ubuntu)

Enviado em 13/05/2020 - 21:50h

[email protected]:~$ sudo chmod 777 self_maintenance.sh ./self_maintenance.sh --all
chmod: opção não reconhecida “--all”
Tente "chmod --help" para mais informações.


12. Re: não consigo instalar beersmtih2

Adriano Siqueira
adrisiq

(usa KDE Neon)

Enviado em 13/05/2020 - 21:57h

Primeiro execute a linha do chmod e depois execute.



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts