.mdt ou .DCM

1. .mdt ou .DCM

WGuedes
wguedes

(usa Ubuntu)

Enviado em 20/12/2012 - 21:21h

Tenho imagens médicas, mas precisamente radiografias num CD. A extensão é .mdt.DCM.
Tentei abrir no Ubuntu Studio e veio a mensagem:
"Não foi possível exibir "/media/wguedes/2012_11_27/I_...2520.1319492340.22547.mdt.DCM"." e
"Não existe aplicativo instalado para os arquivos Imagem DICOM.
Você deseja pesquisar por um aplicativo capaz de abrir estes arquivos?"

Alguém saberia o que fazer para conseguir abrir as imagens?

Grato,
WGuedes


  


2. Re: .mdt ou .DCM

Luís Fernando C. Cavalheiro
lcavalheiro

(usa Slackware)

Enviado em 20/12/2012 - 21:45h

wguedes escreveu:

Tenho imagens médicas, mas precisamente radiografias num CD. A extensão é .mdt.DCM.
Tentei abrir no Ubuntu Studio e veio a mensagem:
"Não foi possível exibir "/media/wguedes/2012_11_27/I_...2520.1319492340.22547.mdt.DCM"." e
"Não existe aplicativo instalado para os arquivos Imagem DICOM.
Você deseja pesquisar por um aplicativo capaz de abrir estes arquivos?"

Alguém saberia o que fazer para conseguir abrir as imagens?

Grato,
WGuedes


Abre o terminal e roda:
 $ sudo apt-get install imagemagick*  

Para instalar o ImageMagick. Ele vai pedir sua senha, normal. Após instalar, e ainda no terminal, roda:
 $ display caminhoparaimagem.dcm  

Para sair da visualização, use o "q".


3. O mago

WGuedes
wguedes

(usa Ubuntu)

Enviado em 23/12/2012 - 10:54h

Grande Icavalheiro

Ótimo!
Segui suas instruções e instalei o ImageMagick, mas ficaram algumas dúvidas:

1
# apt-get install imagemagick
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
imagemagick já é a versão mais nova.

Os seguintes pacotes foram automaticamente instalados e não são mais necessários:
hyphen-en-us linux-headers-3.5.0-17 linux-headers-3.5.0-17-lowlatency
linux-headers-3.5.0-19 linux-headers-3.5.0-19-generic myspell-pt
mythes-en-au openoffice.org-hyphenation
Use 'apt-get autoremove' para removê-los.

0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

Tá vendo o texto em separado, aquele que diz os pacotes que foram instalados automaticamente e que não são mais necessários? Depois diz: "Use 'apt-get autoremove' para removê-los."

As dúvidas são: Devo removê-los? Nunca usei o autoremove. Sabe qual é a sintaxe?

2
Quando, durante a instalação, o sistema diz "Pronto", significa que terminou a tarefa que estava implementando? É o que me parece.

E, quando diz: "imagemagick já é a versão mais nova." significa que acabou de instalar a versão mais nova ou significa que essa "versão mais nova" já estava instalada quando comandei "apt-get install imagemagick"?

Me parece ser a segunda opção já que, ao final, diz: "0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados."

Ora, se nada (0) foi atualizado ou instalado e se nada (0) há a ser removido, então o sistema não fez nada, a não ser informar que nada fez porque nada era necessário fazer, concorda?

3
Toda e qualquer tentativa que faço de abrir uma imagem do CD resulta na abertura da imagem de um pequeno velho mago que, estendendo sua varinha de condão, escreve no ar "Image Magick", fagulhando em cores. É um desenho estático, não um animado, muito embora nos deixe bastante animados com o que nos promete o marketing.

Tô pisando na bola?

Grato,
WGuedes


4. Re: .mdt ou .DCM

Luís Fernando C. Cavalheiro
lcavalheiro

(usa Slackware)

Enviado em 23/12/2012 - 11:18h

Vamos por partes:

wguedes escreveu:

Grande Icavalheiro

Ótimo!
Segui suas instruções e instalei o ImageMagick, mas ficaram algumas dúvidas:

1
# apt-get install imagemagick
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
imagemagick já é a versão mais nova.

Os seguintes pacotes foram automaticamente instalados e não são mais necessários:
hyphen-en-us linux-headers-3.5.0-17 linux-headers-3.5.0-17-lowlatency
linux-headers-3.5.0-19 linux-headers-3.5.0-19-generic myspell-pt
mythes-en-au openoffice.org-hyphenation
Use 'apt-get autoremove' para removê-los.

0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

Tá vendo o texto em separado, aquele que diz os pacotes que foram instalados automaticamente e que não são mais necessários? Depois diz: "Use 'apt-get autoremove' para removê-los."

As dúvidas são: Devo removê-los? Nunca usei o autoremove. Sabe qual é a sintaxe?


Normalmente você não é obrigado a remover esses pacotes, não há problema em deixá-los instalados. Removê-los só tem função para liberar espaço no disco, e nesse caso a sintaxe fica
 # apt-get autoremove  

Sem parâmetros mesmo.


2
Quando, durante a instalação, o sistema diz "Pronto", significa que terminou a tarefa que estava implementando? É o que me parece.

E, quando diz: "imagemagick já é a versão mais nova." significa que acabou de instalar a versão mais nova ou significa que essa "versão mais nova" já estava instalada quando comandei "apt-get install imagemagick"?

Me parece ser a segunda opção já que, ao final, diz: "0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados."

Ora, se nada (0) foi atualizado ou instalado e se nada (0) há a ser removido, então o sistema não fez nada, a não ser informar que nada fez porque nada era necessário fazer, concorda?


Sim. Se ele retornou essa mensagem é porque você já tinha o ImageMagick instalado ;-)

3
Toda e qualquer tentativa que faço de abrir uma imagem do CD resulta na abertura da imagem de um pequeno velho mago que, estendendo sua varinha de condão, escreve no ar "Image Magick", fagulhando em cores. É um desenho estático, não um animado, muito embora nos deixe bastante animados com o que nos promete o marketing.

Tô pisando na bola?

Grato,
WGuedes


O splash da inicialização do ImageMagick é esse mesmo. Isso vem desde os primórdios do pacote que, não se engane, ele é muito poderoso e versátil. Aqui no VOL mesmo há uma dica que ensina como criar .gifs animados pelo ImageMagick. O programa se integra bem ao ambiente gráfico, mas o poder dele mesmo é a linha de comando, e foi por isso que eu recomendei visualizar os arquivos usando o terminal ;-)


5. Porque não abre?

WGuedes
wguedes

(usa Ubuntu)

Enviado em 23/12/2012 - 12:09h

Icavalheiro


"O splash da inicialização do ImageMagick é esse mesmo. Isso vem desde os primórdios do pacote que, não se engane, ele é muito poderoso e versátil. Aqui no VOL mesmo há uma dica que ensina como criar .gifs animados pelo ImageMagick."

Pô, legal, mas porque a imagem do velho mago é única coisa que acontece quando peço a abertura de uma imagem? Porque a imagem indicada no comando não abre?

"O programa se integra bem ao ambiente gráfico, mas o poder dele mesmo é a linha de comando, e foi por isso que eu recomendei visualizar os arquivos usando o terminal ;-)"

Na linha de comando digitei: # display /media/wguedes/2012_11_27
Olha só no que deu:
display.im6: no decode delegate for this image format `/media/wguedes/2012_11_27' @ error/constitute.c/ReadImage/544.

Que loko, meu!
WGuedes



6. Re: .mdt ou .DCM

Luís Fernando C. Cavalheiro
lcavalheiro

(usa Slackware)

Enviado em 24/12/2012 - 04:24h

wguedes escreveu:

Icavalheiro


"O splash da inicialização do ImageMagick é esse mesmo. Isso vem desde os primórdios do pacote que, não se engane, ele é muito poderoso e versátil. Aqui no VOL mesmo há uma dica que ensina como criar .gifs animados pelo ImageMagick."

Pô, legal, mas porque a imagem do velho mago é única coisa que acontece quando peço a abertura de uma imagem? Porque a imagem indicada no comando não abre?

"O programa se integra bem ao ambiente gráfico, mas o poder dele mesmo é a linha de comando, e foi por isso que eu recomendei visualizar os arquivos usando o terminal ;-)"

Na linha de comando digitei: # display /media/wguedes/2012_11_27
Olha só no que deu:
display.im6: no decode delegate for this image format `/media/wguedes/2012_11_27' @ error/constitute.c/ReadImage/544.

Que loko, meu!
WGuedes


Não roda como root não, isso dá problema às vezes.

EDIT: eu tive que testar aqui para conferir. Isso está acontecendo porque você não está passando para o comando o nome completo do arquivo, e por isso ele está sendo invocado sem parâmetros. Por isso que você recebe a imagem desse velhinho fazendo magia.
Dessa janela, você pode clicar e segurar o botão direito do mouse em cima do velhinho para abrir um menu. Solte o botão direito sobre o comando "Open" desse menu. Na janela que aparecer, clique até o caminho do arquivo e depois no botão "Open".


7. Isto feito...

WGuedes
wguedes

(usa Ubuntu)

Enviado em 03/01/2013 - 23:10h

Icavalheiro

Feito isto:
~$ display /media/wguedes/2012_11_27display.im6: unable to open image `/media/wguedes/2012_11_27': Arquivo ou diretório não encontrado @ error/blob.c/OpenBlob/2638.
display.im6: no decode delegate for this image format `/media/wguedes/2012_11_27' @ error/constitute.c/ReadImage/544.

Isto feito:
Botão direito no velhinho, solto em open + caminho + arquivo e surge uma caixa com uma mensagem que não se permite ser copiada e colada e torna-se uma outra caixa com um botão onde se lê "DISMISS".

O pior é que não consigo nem "fechar" o velhinho que insiste em comandar o negro espetáculo (não fecha).

WGuedes


8. Só pra atualizar

WGuedes
wguedes

(usa Ubuntu)

Enviado em 12/01/2013 - 21:01h

Esta é só pra atualizar os que perderam as cenas dos últimos capítulos e trazer novamente à baila esta questão que é muito importante, mas ainda encontra-se à espera de um milagre.

Vai que aparece um São Linuxer e...

WGuedes


9. Re: .mdt ou .DCM

Luís Fernando C. Cavalheiro
lcavalheiro

(usa Slackware)

Enviado em 13/01/2013 - 02:01h

wguedes escreveu:

Esta é só pra atualizar os que perderam as cenas dos últimos capítulos e trazer novamente à baila esta questão que é muito importante, mas ainda encontra-se à espera de um milagre.

Vai que aparece um São Linuxer e...

WGuedes


Procura o pacote aeskulap (http://aeskulap.nongnu.org/), vê se é isso que você quer


10. Aeskulacho?

WGuedes
wguedes

(usa Ubuntu)

Enviado em 13/01/2013 - 12:03h

Icavalheiro

Lá, naquele post sobre a fonte, disse-lhe o seguinte:

Cara, você é demais! Valeu aí, pela atenção em relação às imagens.
Sempre que encaro um problema cuja solução é demorada, acabo me desviando do assunto
porque outros estímulos surgem e não dá pra viver em função de uma só questão por muito tempo,
frente ao emaranhado de coisas que a vida nos traz a cada momento.

Sempre volto a buscar a solução que ficou em stand by,
mas às vezes demora um pouco até recuperar a necessária disponibilidade.

Neste momento seu comentário foi muito bem vindo!
Acabo de instalar o tal pacote aeskulap, entretanto, também não consegui que ele abrisse as imagens.

Com relação à fonte, tem certeza? Está zerada! Será que já nasceu com defeito? Nunca aconteceu.

Agora, complementando minha resposta, fui ao site que me indicou e vi que a versão para download do aeskulap é inferior à que instalei ontem: 0.2.2b1-11ubuntu1.

Acho que não vai adiantar baixar versão mais antiga, concorda?

Os arquivos cujos nomes têm o formato "1.2.840.113704.1.111.2520.1319492340.22547.mdt.DCM", estão em pastas nomeadas no formato "I_000001114608", por exemplo.

Bem, depois disto, abri o terminal e digitei aeskulap, assim, e veja o resultado:

:~$ aeskulap

(process:14798): GLib-GObject-CRITICAL **: g_object_newv: assertion `G_TYPE_IS_OBJECT (object_type)' failed
Gnome::Conf::init()
datadir: /usr/share

(aeskulap:14798): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(aeskulap:14798): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
trying to load '/usr/share/aeskulap/images/grid-1.png'
trying to load '/usr/share/aeskulap/images/grid-2h.png'
trying to load '/usr/share/aeskulap/images/grid-2v.png'
trying to load '/usr/share/aeskulap/images/grid-4.png'
trying to load '/usr/share/aeskulap/images/grid-16.png'
trying to load '/usr/share/aeskulap/images/stock-tool-scale-22.png'
trying to load '/usr/share/aeskulap/images/stock-layers-24.png'
trying to load '/usr/share/aeskulap/images/series-1x1.png'
trying to load '/usr/share/aeskulap/images/series-2x1.png'
trying to load '/usr/share/aeskulap/images/series-2x2.png'
trying to load '/usr/share/aeskulap/images/series-3x2.png'
trying to load '/usr/share/aeskulap/images/series-3x3.png'
trying to load '/usr/share/aeskulap/images/series-4x4.png'
trying to load '/usr/share/aeskulap/images/stock-tool-eraser-22.png'
trying to load '/usr/share/aeskulap/images/cursor_pan.png'
trying to load '/usr/share/aeskulap/images/stock-tool-color-picker-22.png'
trying to load '/usr/share/aeskulap/images/stock-tool-measure-22.png'
prescan: 0
on_windowlevels_modality_changed() - indexint: 0
StudyManager::on_filter_search()
turning cursor busy
NEW QUERY:

# Dicom-Data-Set
# Used TransferSyntax: Unknown Transfer Syntax
(0008,0005) CS [ISO_IR 100] # 10, 1 SpecificCharacterSet
(0008,0020) DA (no value available) # 0, 0 StudyDate
(0008,0030) TM (no value available) # 0, 0 StudyTime
(0008,0050) SH (no value available) # 0, 0 AccessionNumber
(0008,0052) CS [STUDY] # 6, 1 QueryRetrieveLevel
(0008,0061) CS (no value available) # 0, 0 ModalitiesInStudy
(0008,0062) UI (no value available) # 0, 0 SOPClassesInStudy
(0008,1030) LO (no value available) # 0, 0 StudyDescription
(0010,0010) PN [*] # 2, 1 PatientName
(0010,0020) LO (no value available) # 0, 0 PatientID
(0010,0030) DA (no value available) # 0, 0 PatientBirthDate
(0010,0040) CS (no value available) # 0, 0 PatientSex
(0020,000d) UI (no value available) # 0, 0 StudyInstanceUID
(0020,0010) SH (no value available) # 0, 0 StudyID
(0020,1206) IS (no value available) # 0, 0 NumberOfStudyRelatedSeries
(0020,1208) IS (no value available) # 0, 0 NumberOfStudyRelatedInstances
QueryServerGroup()
T::Drop()
T::Destroy()
cursor busy off
no results !!!

(aeskulap:14798): Gtk-WARNING **: gtk_file_chooser_remove_filter() called on filter not in list

Agora, 13:48:58, fui a uma das pastas, "cliquei direito" e pedi para executar. Veio o tal e inútil velhinho. Recusei-o e pedi para abrir com outro aplicativo. Achei curioso que o aeskulap não compareceu à lista dos aplicativos. Será que está com medo, ou será preguiça?. Ah, sei lá, talvez seja timidez. Uma hora ele aparece.

Pedi para procurar, on line, um outro aplicativo e me foi sugerido um tal de Ginkgo Cadx, visualizador de imagens médica DICOM. Mandei instalar. Vamos ver...

Pronto, Icavalheiro! A B R I U ! ! ! ! ! ! ! ! ! ! ! !

Fantástico!

Agora preciso desinstalar Image Magic e aeskulap. Isto se faz pelo Synaptic, certo? Ou há um modo melhor de desinstalar os dois?

Olha, meu amigo, você foi muito importante nesta jornada. Se não fosse por você, isto ainda ia rolar por muito tempo, viu?
Aguardo sua resposta para poder encerrar o tópico.

Epa, peraê! Isto não é um joelho! É... um... CRÂ-NE-O!?!?!?!
Como assim?

Já volto, deixa eu verificar o que não tá funfando...

Muito obrigado, MESMO!
WGuedes


11. Quanta incompetência!

WGuedes
wguedes

(usa Ubuntu)

Enviado em 15/01/2013 - 20:18h

Keridos Gurus

O pior é estava funfando, mas estava faltando o essencial: a imagem não era minha!
Pois, então?
Fiz uma radiografia de Joelho e recebi uma de crânio!!!
Pior: o crânio não era o meu, pode?!?!?!

Fiquei totalmente bolado, pois pedia ao sistema que abrisse a imagem de um joelho, mas ele só abria uma de crânio.
Achei que o sistema não estava abrindo o arquivo que eu indicava, mas um que, passei a supor, tivesse vindo junto com o programa quando o baixei. Fechei tudo - quase reiniciei o computador - e, no gerenciador de arquivos, cliquei direito num arquivo do CD que recebi e lá estava o maldito crânio do DELTON LUIZ MELO.

Não restaram mais dúvidas: recebi o joelho errado!

Hoje fui lá e trouxe o meu querido joelho para casa, são e salvo.

O problema, agora, é outro:
O tal programa GINKGO que baixei, único até agora que me permitiu abrir arquivos DICOM, é versão "2.alguma coisa" e o que encontrei no site http://sourceforge.net/projects/ginkgocadx/?source=dlp é versão "3.alguma outra coisa", ou seja, mais recente.

Baixei o pacote não como download, mas para que fosse aberto pelo gerenciador de pacotes. Ao final o tal gerenciador mostrou-me a lista de arquivos que compõem o pacote, mas não instalou, nem me deu essa opção. Baixei de novo, agora como download e está lá, tudo bunitim. E pra instalar? Chamei o Synaptic, mas ele só instala do repositório que só tem a versão "2.alguma coisa". Assim, estou ligeiramente enrolado. Como instalo um pacote que foi baixado? Até hoje, ainda não precisei fazer isto, exceto pelo próprio Linux que gravei em CD, pelo qual dei um boot para iniciar a instalação.

Quem sabe aquele crânio maldito faria isto com os pés nas costas? Ah, é... crânio não tem pés, nem costas. Talvez fizesse de cavidades dos olhos fechadas! Agora melhorou, né?

Opa! Já fiz essa titica sim, uai; é só entrar no terminal e digitar apt-get install > caminho > arquivo, né não?

Claro que não! O apt-get não encontrou o caminho. Então usei o CD > caminho e lá comandei apt-get install > pacote. Aí vai!

Não foi: o instal não encontrou o arquivo. Vejam:

# apt-get install /caminho/Ginkgo_CADx-3.1.0.496.22_linux_x86.tgz
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote /caminho

# cd /caminho
caminho# apt-get install /Ginkgo_CADx-3.1.0.496.22_linux_x86.tgz
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote

Acho que é porque o pacote está compactado, será?

Não, também não é, pois dentro da pasta downloads criei a pasta "Abre", descompactei lá o pacote, entrei na pasta (cd Abre) e foi assim:

Caminho# apt-get install /Ginkgo_CADx-3.1.0.496.22_linux_x86
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote

Caminho# apt-get install /ginkgocadx-x86
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote

Caminho# apt-get install ginkgocadx-x86
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote ginkgocadx-x86

Caminho# ls
Ginkgo_CADx-3.1.0.496.22_linux_x86

Caminho# apt-get install Ginkgo_CADx-3.1.0.496.22_linux_x86
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote Ginkgo_CADx-3.1.0.496.22_linux_x86
E: Não foi possível encontrar qualquer pacote pela expressão regular 'Ginkgo_CADx 3.1.0.496.22_linux_x86'

Diz aê, galera!

Obrigado!
WGuedes


12. Re: .mdt ou .DCM

Luís Fernando C. Cavalheiro
lcavalheiro

(usa Slackware)

Enviado em 15/01/2013 - 23:11h

Pra instalar uma versão diferente daquela dos repositórios você vai ter que desinstalar a versão dos repositórios, pegar o código-fonte e compilar o programa.



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts