Falha ao instalar o gnome-shell

1. Falha ao instalar o gnome-shell

Tk Oliveira
isaoliveira

(usa Ubuntu)

Enviado em 03/12/2014 - 00:21h

Boa noite, galera

Estou tentando instalar o gnome-shell. Após instalação por terminal e buscando os arquivos no ppa repositórios, não apareceu a opção do gnome na hora de logar no notebook.
Então desinstalei os repositórios que havia instalado e tentei instalar apenas por gnome-shell, porém agora está apresentando um erro, neste erro pedi para instalar mais arquivos que pedem outros e acaba sem pre com o erro.

Tem uma mensagem de pacote quebrado, já usei

apt-get autoremove
apt-get -f install

E não resolveu... abaixo o que aparece para mim.

Os pacotes a seguir têm dependências desencontradas:
gnome : Depende: gnome-core (= 1:3.8+4ubuntu3) mas não será instalado
Depende: evolution (>= 3.8) mas não será instalado
Depende: evolution-plugins (>= 3.8) mas não será instalado
Depende: tracker-gui mas não será instalado
Depende: gedit-plugins (>= 3.4) mas não será instalado
Depende: gnome-shell-extensions (>= 3.4) mas não será instalado
Recomenda: nautilus-sendto-empathy mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.


.........................................................................

Desde já agradeço a compreensão de todos.


  


2. Re: Falha ao instalar o gnome-shell

Zhu Sha Zang
zhushazang

(usa Gentoo)

Enviado em 09/01/2015 - 10:42h


Se entendi bem você fez adições e remoções ao seu sources.list. Neste processo pode ter deixado lixo pelo caminho.

Meu conselho para este tipo de operação é fazer backups do /etc/apt/sources.list antes de iniciar, durante e após registrando quais modificações foram feitas e anotando o resultado.

Você ainda pode fazer um backup de uma lista dos pacotes instalados antes e depois para comparar o que foi instalado com o novo ppa e saber o que retirar depois:

dpkg --get-selections > lista

Para resolver esse problema de dependências quebradas você pode reinstalar o sistema ou sair no braço com ele:

Cruze os dedos

1) Edite seu arquivo de sources com os ppas que você havia adicionado e tente atualizar tudo (pacotes/sistema)
2) Se o erro persistir, apt-get remove gnome-* --purge (hardcore)