Executar ImageMagick x86 em sistema x64 [RESOLVIDO]

1. Executar ImageMagick x86 em sistema x64 [RESOLVIDO]

Eduardo Alberto da Silva Amaral
flandatico

(usa Ubuntu)

Enviado em 17/03/2014 - 14:09h

Olá!
Tenho uma versão do ImageMagick (já compilado) executando num Linux x86 e gostaria de executá-lo num Linux x64.
Vocês saberiam me informar se eu tenho que instalar algum pacote adicional para conseguir que isso funcione?
Pois não está funcionando :-( O executável está no diretório /usr/local/bin, porém o sistema exibe a seguinte mensagem:
$ convert
-bash: /usr/local/bin/convert: No such file or directory.

Desde já agradeço pela força!


  


2. Re: Executar ImageMagick x86 em sistema x64 [RESOLVIDO]

Luís Fernando C. Cavalheiro
lcavalheiro

(usa Slackware)

Enviado em 17/03/2014 - 14:40h

flandatico escreveu:

Olá!
Tenho uma versão do ImageMagick (já compilado) executando num Linux x86 e gostaria de executá-lo num Linux x64.
Vocês saberiam me informar se eu tenho que instalar algum pacote adicional para conseguir que isso funcione?
Pois não está funcionando :-( O executável está no diretório /usr/local/bin, porém o sistema exibe a seguinte mensagem:
$ convert
-bash: /usr/local/bin/convert: No such file or directory.

Desde já agradeço pela força!


Só por curiosidade... por que você compilou o ImageMagick se ele é um pacote meio que padrão em todas as distros?


3. Re: Executar ImageMagick x86 em sistema x64 [RESOLVIDO]

Eduardo Alberto da Silva Amaral
flandatico

(usa Ubuntu)

Enviado em 17/03/2014 - 14:52h

Não compilei, só estou dizendo que peguei o diretório de instalação do ImageMagick de um servidor x86 e estou tentando executar num outro servidor cuja arquitetura é x64 :-)



lcavalheiro escreveu:

flandatico escreveu:

Olá!
Tenho uma versão do ImageMagick (já compilado) executando num Linux x86 e gostaria de executá-lo num Linux x64.
Vocês saberiam me informar se eu tenho que instalar algum pacote adicional para conseguir que isso funcione?
Pois não está funcionando :-( O executável está no diretório /usr/local/bin, porém o sistema exibe a seguinte mensagem:
$ convert
-bash: /usr/local/bin/convert: No such file or directory.

Desde já agradeço pela força!


Só por curiosidade... por que você compilou o ImageMagick se ele é um pacote meio que padrão em todas as distros?





4. Re: Executar ImageMagick x86 em sistema x64 [RESOLVIDO]

taiar
taiar

(usa Crunchbang)

Enviado em 17/03/2014 - 15:22h

Nunca fiz isso mas achei curioso e fiz uma busca...

http://superuser.com/questions/307064/how-to-enable-32-bit-binary-compatibility-on-linux-mint-11-x64

É para "ubuntu" então adeque à sua necessidade.

Como foi dito, o Imagemagick costuma ser um pacote já disponível nas distros. Se a sua realmente não tem (já que o comando convert não foi encontrado) eu recomendaria a você compilar para a sua plataforma (costuma ser um processo bem simples e se você vai entra mesmo no ambiente, seria bom se familiarizar com ele).

Outra coisa, segundo o erro que você colocou na sua primeira postagem, parece que o problema é que o sistema não está encontrado o binário que você copiou. Você deve fazer com que o sistema encontre o programa que está tentando executar (linká-lo simbólicamente no diretório /usr/bin OU disponibilizá-lo no seu path ou até mesmo criar um alias no seu .bashrc irão suprir essa necessidade). Em seguida se preocupar em executá-lo em modo de compatibilidade através do link que disponibilizie.

Creio que compilar ele na sua plataforma seria mais simples do que o que você terá que fazer.

Boa sorte!


5. Re: Executar ImageMagick x86 em sistema x64 [RESOLVIDO]

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 17/03/2014 - 15:24h

de inicio, creio que executa sim, pq as bibliotecas de compatibilidade devem estar presentes.

mas, Image Magick existe para todas as Distros. Não seria mais fácil, vc instalar nessa sua Distro, o Image Magick de 64 Bits, o que está nos repositórios?
Não precisaria nem compilar nada.


6. Resolvido!

Eduardo Alberto da Silva Amaral
flandatico

(usa Ubuntu)

Enviado em 17/03/2014 - 16:26h

Muito obrigado pelas dicas!
Eu tive que instalar algumas libs:
libjpeg62:i386 ia32-libs lib32asound2 lib32gcc1 lib32ncurses5 lib32stdc++6 lib32z1 libc6-i386

valeu pela força!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts