Erro ao instalar o skype no Debian Wheezy com gnome [RESOLVIDO]

1. Erro ao instalar o skype no Debian Wheezy com gnome [RESOLVIDO]

Matias Santana
mattsantana

(usa Debian)

Enviado em 21/03/2014 - 00:53h

Olá pessoal ^^
Estou tentando instalar o skype aqui no Debian 7 Wheezy com ambiente gnome e não está dando.
baixei o arquivo.deb do site oficial do skype para debian e ao executar com o dpkg -i <nomedoarquivo>.deb ele me mostra o segunte mensagem:

[email protected]:/home/matias# dpkg -i s.deb
A seleccionar pacote anteriormente não seleccionado skype.
(Lendo banco de dados ... 145677 ficheiros e directórios actualmente instalados.)
Desempacotando skype (de s.deb) ...
dpkg: problemas com dependências impedem a configuração de skype:
skype depende de libasound2-plugins.

dpkg: erro ao processar skype (--install):
problemas de dependência - deixando desconfigurado
Processando gatilhos para desktop-file-utils ...
Processando gatilhos para gnome-menus ...
Processando gatilhos para hicolor-icon-theme ...
Erros foram encontrados durante o processamento de:
skype
[email protected]:/home/matias#
____________________________________________________________________________________________

Se Executar o comando apt-get -f install é mostrado a seguinte mensagem:

[email protected]:/home/matias# apt-get -f install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
libdirac-encoder0:i386 libglib2.0-0:i386 libgsm1:i386
libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386 libmng1:i386
libmp3lame0:i386 libopenjpeg2:i386 liborc-0.4-0:i386 libpcre3:i386
libqt4-dbus:i386 libqt4-network:i386 libqt4-xml libqt4-xml:i386 libqtcore4
libqtcore4:i386 libqtdbus4 libqtdbus4:i386 libqtgui4:i386 libqtwebkit4:i386
libschroedinger-1.0-0:i386 libspeex1:i386 libspeexdsp1:i386 libtheora0:i386
libva1:i386 libvpx1:i386 libx264-123:i386 libxvidcore4:i386 qdbus
Utilize 'apt-get autoremove' para os remover.
Os pacotes a seguir serão REMOVIDOS:
skype:i386
0 pacotes atualizados, 0 pacotes novos instalados, 1 a serem removidos e 0 não atualizados.
1 pacotes não totalmente instalados ou removidos.
Depois desta operação, 37,4 MB de espaço em disco serão liberados.
Você quer continuar [S/n]?
[email protected]:/home/matias# ^
_____________________________________________________________________________________________

Se eu digitar "S" o skype é desinstalado. Estou sem saber o que fazer, visto que isso é apenas no ambiente gnome. No KDE não acontece isso (Instalei o skype agora a pouco no Debian 7 Wheeyzy com KDE e não deu erro nenhum). Alguém me ajuda?



  


2. MELHOR RESPOSTA

Pires
pinguintux

(usa Debian)

Enviado em 21/03/2014 - 20:55h

mattsantana escreveu:

Olá pessoal ^^
Estou tentando instalar o skype aqui no Debian 7 Wheezy com ambiente gnome e não está dando.
baixei o arquivo.deb do site oficial do skype para debian e ao executar com o dpkg -i <nomedoarquivo>.deb ele me mostra o segunte mensagem:

[email protected]:/home/matias# dpkg -i s.deb
A seleccionar pacote anteriormente não seleccionado skype.
(Lendo banco de dados ... 145677 ficheiros e directórios actualmente instalados.)
Desempacotando skype (de s.deb) ...
dpkg: problemas com dependências impedem a configuração de skype:
skype depende de libasound2-plugins.

dpkg: erro ao processar skype (--install):
problemas de dependência - deixando desconfigurado
Processando gatilhos para desktop-file-utils ...
Processando gatilhos para gnome-menus ...
Processando gatilhos para hicolor-icon-theme ...
Erros foram encontrados durante o processamento de:
skype
[email protected]:/home/matias#
____________________________________________________________________________________________

Se Executar o comando apt-get -f install é mostrado a seguinte mensagem:

[email protected]:/home/matias# apt-get -f install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
libdirac-encoder0:i386 libglib2.0-0:i386 libgsm1:i386
libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386 libmng1:i386
libmp3lame0:i386 libopenjpeg2:i386 liborc-0.4-0:i386 libpcre3:i386
libqt4-dbus:i386 libqt4-network:i386 libqt4-xml libqt4-xml:i386 libqtcore4
libqtcore4:i386 libqtdbus4 libqtdbus4:i386 libqtgui4:i386 libqtwebkit4:i386
libschroedinger-1.0-0:i386 libspeex1:i386 libspeexdsp1:i386 libtheora0:i386
libva1:i386 libvpx1:i386 libx264-123:i386 libxvidcore4:i386 qdbus
Utilize 'apt-get autoremove' para os remover.
Os pacotes a seguir serão REMOVIDOS:
skype:i386
0 pacotes atualizados, 0 pacotes novos instalados, 1 a serem removidos e 0 não atualizados.
1 pacotes não totalmente instalados ou removidos.
Depois desta operação, 37,4 MB de espaço em disco serão liberados.
Você quer continuar [S/n]?
[email protected]:/home/matias# ^
_____________________________________________________________________________________________

Se eu digitar "S" o skype é desinstalado. Estou sem saber o que fazer, visto que isso é apenas no ambiente gnome. No KDE não acontece isso (Instalei o skype agora a pouco no Debian 7 Wheeyzy com KDE e não deu erro nenhum). Alguém me ajuda?



Boa noite!

Prezado, a instalação do Skype está com problemas de dependências. Tente executar os procedimentos abaixo com o skype desinstalado:

a. Abra o terminal (usuário root)

# apt-get update

# apt-get build-dep libasound2-plugins

# apt-get install libasound2-plugins

b. Entre no diretório onde está o arquivo do skype e execute novamente:

# dpkg -i arquivo.deb (arquivo do skype)

c. Caso apareçam novas dependência, execute novamente os comandos para todas elas, conforme exemplo abaixo:

OBS: Você pode inserir várias dependências em uma mesma linha (Ex: apt-get build-dep dependência-01 dependência-02 ..., onde o mesmo se aplica ao apt-get install dependência-01 dependência-02...):

# apt-get build-dep nomedadependência (Ex: apt-get build-dep libxos-plug);

# apt-get install nomedadependência (Ex: apt-get install libxos-plug);

OBS:. Caso o seu problema seja solucionado, não esqueça de marcar o tópico como RESOLVIDO e a MELHOR RESPOSTA. Dentro do possível, descreva a solução para que outras pessoas também possam se beneficiar!

Boa sorte!



3. Re: Erro ao instalar o skype no Debian Wheezy com gnome [RESOLVIDO]

Alisson
AlissonDeOz

(usa Manjaro Linux)

Enviado em 21/03/2014 - 21:06h

Só pra completar, o skype é arquitetura i386, se vc estiver usando um x64 vc tem que habilitar o suporte para i386 no debian.
Nesse tópico explica como:
http://www.vivaolinux.com.br/dica/Instalacao-Skype-no-Debian-Wheezy-Ultima-versao-Debian-MultiArch
Tem outra forma de instalar por repositório:
http://www.vivaolinux.com.br/dica/Instalando-Skype-no-Debian-e-derivados


4. Re: Erro ao instalar o skype no Debian Wheezy com gnome [RESOLVIDO]

Matias Santana
mattsantana

(usa Debian)

Enviado em 21/03/2014 - 21:56h

O meu muito obrigado a vocês dois.
O problema foi resolvido com as dicas do pinguintux. Fui instalando as dependencias que surgiam. Muito obrigado, me ajudaram muito.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts