Problemas de gerenciador de pacotes após tentar atualizar meu Gimp [RESOLVIDO]

1. Problemas de gerenciador de pacotes após tentar atualizar meu Gimp [RESOLVIDO]

Ana Paula
Karenina

(usa Arch Linux)

Enviado em 05/05/2018 - 21:09h

Olá, camaradas do Viva o Linux. Por favor, será que alguém pode me ajudar?

Li a uns dias atrás em uma página da comunidade no Facebook que estava disponível a nova versão do Gimp.

Porém, eu não encontrei em nenhum lugar como atualizar quem já tem a versão antiga do Gimp para esta nova.

Entrei no blog do Edivaldo Brito onde se ensina como instalar a última versão do Gimp e seus derivados; http://www.edivaldobrito.com.br/ultima-versao-gimp-no.../

Fiz os procedimentos para instalar a última versão de desenvolvimento do GIMP no Ubuntu e seus derivados, e aí tudo degringolou…

Houve um problema de contador de pacotes quebrados e o Gimp não atualizou. Pior que isso, minha versão antiga não abria mais, no lugar dela recebi a mensagem:

"Libgimp version mismatch!
The GIMP binary cannot run with a libgimp version
other than its own. This is GIMP 2.8.16, but the
libgimp version is 2.9.9.
Maybe you have GIMP versions in both /usr and /usr/local ?"

Quanto aos pacotes quebrados, tentei usar as informações de um outro blog o do Diolinux, “3 Maneiras de Reparar Pacotes Quebrados no Ubuntu”: https://www.diolinux.com.br/.../3-maneira-de-reparar...

Geralmente estas instruções resolviam meus problemas, mas agora tenho a mensagem no canto superior direito em minha tela dentro de um ícone de bola vermelha com um traço branco: “”Um erro ocorreu, por favor, use o Gerenciador de Pacotes a partir do menu com clique direto ou apt-get em um terminal para ver o que está errado. A mensagem de erro foi: Erro contador de pacotes quebrados >0”. Isso geralmente significa que os pacotes instalados possuem dependências não resolvidas.”

Aí tive a brilhante ideia de desinstalar o Gimp e reinstalá-lo... Agora não consigo abrir meu Gimp e nem mesmo atualizar o meu sistema... já tentei usar "sudo apt-get -f install" para corrigir os meus pacotes mas não adiantou...

Se alguém puder me ajudar, agradeço desde já.

Muito obrigado.

[Solução]- Olá amigos! Mais uma vez muitíssimo obrigado pelo apoio! Fiz a recomendação do Chapéu de Palha e instalei meu Ubuntu Studio por cima do Ubuntu antigo com problema. Ele desinstala e já atualiza o sistema. Tudo perfeito! Valeu galera!!!


  


2. Re: Problemas de gerenciador de pacotes após tentar atualizar meu Gimp [RESOLVIDO]

Guilherme Machado
Ma-chan

(usa Arch Linux)

Enviado em 06/05/2018 - 15:47h

Não fique usando esses tutoriais inúteis. Sempre atualize pelo repositório oficial.
Evite o uso de PPA's. A não ser que seja realmente preciso.




# nano /etc/pacman.conf



3. Re: Problemas de gerenciador de pacotes após tentar atualizar meu Gimp [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 06/05/2018 - 15:57h

Concordo plenamente com
ochapeudepalha.
Não use PPA para programas disponíveis nos repositórios oficiais.
Para tentar resolver seu problema remova gimp e desative PPA.
Depois atualize e reinstale GIMP oficial dos repositórios.


4. Re: Problemas de gerenciador de pacotes após tentar atualizar meu Gimp [RESOLVIDO]

Eric
Grinder

(usa Slackware)

Enviado em 06/05/2018 - 17:01h

Compilar o gimp não é problema, problema é usar o gimp compilado numa distro toda binária e com resolução de dependências.
Na minha opnião o correto seria você tentar criar um pacote .deb da sua compilação para que sua distro entenda que exista o teu gimp.
- - - - -
www.github.com/ericfernandesferreira
www.youtube.com/candelabrus1


5. Re: Problemas de gerenciador de pacotes após tentar atualizar meu Gimp [RESOLVIDO]

Ana Paula
Karenina

(usa Arch Linux)

Enviado em 06/05/2018 - 20:09h

SamL escreveu:

Ops agora lendo tudo com calma vejo que o problema é bem mais grave. Espero que alguém apareça pra lhe ajudar, mas aquele erro ali do gimp não abrir é porque tem duas libs conflitantes no mesmo diretório (no /usr/lib) se remover uma delas pode ser que abra de novo um dos gimps porque tem dois instalados ai.
____________________________________________
https://nerdki.blogspot.com/ acessa aí vai lá, é grátis!


Obrigado por se dispor a me ajudar de qualquer forma SamL. Foi um completo descuido meu mesmo. Inclusive a nova versão do Gimp não esta disponível para minha versão do Ubuntu a 16.04LTS. Descuido foi pouco para o que eu fiz camarada.


6. Re: Problemas de gerenciador de pacotes após tentar atualizar meu Gimp [RESOLVIDO]

Ana Paula
Karenina

(usa Arch Linux)

Enviado em 06/05/2018 - 20:15h

Grinder escreveu:

Compilar o gimp não é problema, problema é usar o gimp compilado numa distro toda binária e com resolução de dependências.
Na minha opnião o correto seria você tentar criar um pacote .deb da sua compilação para que sua distro entenda que exista o teu gimp.
- - - - -
www.github.com/ericfernandesferreira
www.youtube.com/candelabrus1


Grinder, obrigado por vir até aqui tentar me ajudar. Então, eu já exclui um Gimp do meu computador mas continuo com um problema de pacotes quebrados que não se resolvem mesmo tendo usado "sudo apt-get install -f", acredito que devido a isso é que nem mesmo consigo atualizar meu sistema... Não quero mais a nova versão do Gimp, ela não serve para minha versão ubuntu 16.04LTS, quero resolver o problema de pacotes quebrados e depois tento reinstalar a versão antiga do Gimp mesmo mano...

Ps.: Quando abro "pesquisa no meu computador" ainda vejo o ícone do Gimp. Se clicar nele aparece a seguinte mensagem:

Libgimp version mismatch!

The GIMP binary cannot run with a libgimp version
other than its own. This is GIMP 2.8.16, but the
libgimp version is 2.9.9.

Maybe you have GIMP versions in both /usr and /usr/local ?

Tradução (sei que muito provavelmente vc sabe inglês, mas é para outras pessoas que possam querer vir me ajudar): Desaprovação da versão do Libgimp!

O binário do GIMP não pode ser executado com uma versão libgimp
diferente da sua. Este é o GIMP 2.8.16, mas o
versão libgimp é 2.9.9.

Talvez você tenha versões do GIMP em / usr e / usr / local?


7. Re: Problemas de gerenciador de pacotes após tentar atualizar meu Gimp [RESOLVIDO]

Ana Paula
Karenina

(usa Arch Linux)

Enviado em 06/05/2018 - 20:16h

ochapeudepalha escreveu:

Não fique usando esses tutoriais inúteis. Sempre atualize pelo repositório oficial.
Evite o uso de PPA's. A não ser que seja realmente preciso.




# nano /etc/pacman.conf


Obrigado por me responder. Bom de fato vc esta certo. Mas acredito que a culpa maior foi minha. Deveria ter pesquisado mais MUITO mais...


8. Re: Problemas de gerenciador de pacotes após tentar atualizar meu Gimp [RESOLVIDO]

Ana Paula
Karenina

(usa Arch Linux)

Enviado em 06/05/2018 - 20:18h

SamL escreveu:

clodoaldops escreveu:

Concordo plenamente com
ochapeudepalha.
Não use PPA para programas disponíveis nos repositórios oficiais.
Para tentar resolver seu problema remova gimp e desative PPA.
Depois atualize e reinstale GIMP oficial dos repositórios.

Clodoaldo, é que o gimp que ele quer desse PPA é o mais atualizado, o mais simples mesmo seria compilar do src e ter a ultima versão da ponta do dedo. Acho que um tutorial de como compilar o gimp cairia bem, vou anotar aqui caso crie coragem pra fazer.
____________________________________________
https://nerdki.blogspot.com/ acessa aí vai lá, é grátis!


Obrigado por me responder. Por favor quando vc tiver disponibilidade e vontade faça isso. Iniciantes e leigos como eu ficaremos imensamente gratos!



9. Re: Problemas de gerenciador de pacotes após tentar atualizar meu Gimp [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 06/05/2018 - 22:35h

Veja dica
https://www.omgubuntu.co.uk/2018/05/gimp-2-10-ubuntu-download


10. Re: Problemas de gerenciador de pacotes após tentar atualizar meu Gimp

Ana Paula
Karenina

(usa Arch Linux)

Enviado em 13/05/2018 - 00:28h




Oi clodoaldops. Obrigado mais uma vez por aqui estar tentando me ajudar mano. Então, eu já tentei "consertar" a zica que fiz mas agora não adianta colocar o Gimp correto. Meu sistema não atualiza e eu não consigo abrir o Gimp, (eliminei um, ou pelo menos fiz os comandos para eliminar). Agora estou baixando uma nova distro a Ubuntu Studio. O objetivo é substituir este meu sistema bugado (por irresponsabilidade e inoperância minha), e colocar um sistema mais de acordo com meus trabalhos e estudos.
Alias, por favor, vc sabe se posso simplesmente colocar uma distro "acima" da outra? Não quero mais este Ubuntu, quero só usar o Studio. É só baixar a iso e instalar por cima ou tem mais algum procedimento? Pode me ajudar?



11. Re: Problemas de gerenciador de pacotes após tentar atualizar meu Gimp [RESOLVIDO]

Guilherme Machado
Ma-chan

(usa Arch Linux)

Enviado em 13/05/2018 - 17:53h

No instalador do Ubuntu tem uma parte que pergunta como você quer particionar o disco. Escolha a opção de apagar o disco inteiro e passar por cima.




# nano /etc/pacman.conf







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts