como instalarno linux fedora configure: error: gobject is required to build pygtk? [RESOLVIDO]

1. como instalarno linux fedora configure: error: gobject is required to build pygtk? [RESOLVIDO]

rafae
rafah00

(usa Fedora)

Enviado em 08/02/2016 - 21:05h

tava tentando dar ./configure no cpu-g e apareceu isso

No package 'gthread-2.0' found
no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error: gobject is required to build pygtk?


Depois tentei dar make pra ver se instalava mais nao ia to com problemas para instalar o cpu-g


  


2. Re: como instalarno linux fedora configure: error: gobject is required to build pygtk?

Perfil removido
removido

(usa Nenhuma)

Enviado em 08/02/2016 - 21:21h

Bom, a própria mensagem de erro está dizendo qual o problema:

No package 'gthread-2.0' found

O pacote gthread-2.0 não foi encontrado

Você precisa instalar esse pacote glib2-devel
___________________________________________________________________
4c 69 6e 75 78 20 c3 a9 20 6d 65 6c 68 6f 72 20 71 75 65 20 57 69 6e 64 6f 77 73


3. valeu

rafae
rafah00

(usa Fedora)

Enviado em 08/02/2016 - 21:37h

consegui mas apareceu denovo outro erro

configure: error: Package requirements (pygobject-2.0 >= 2.21.3) were not met:

No package 'pygobject-2.0' found


pelo que eu entendi eu tenho que instalar esse tal pygobject2.0 (só que eu nao faço ideia de como instalar, baixar ou qual comando que é)

eu estava instalado primeiro o cpu-g e deu essa msg

$ ./cpu-g
You need to have PyGTK 2.10.0, GTK.Glade and GTK+ 2.10.0 or higher installed in your system in order to run CPU-G.


ai eu to tentando instalar esse tal PyGTK 2.10.0 e ai vem um erro atras do outro, o problema do topico ja foi resolvido mais aparece esse tal de 'pygobject-2.0, incialmente eu queria instalar o cpu-g no fedora


4. Re: como instalarno linux fedora configure: error: gobject is required to build pygtk? [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 08/02/2016 - 21:43h

rafah00 escreveu:

consegui mas apareceu denovo outro erro

configure: error: Package requirements (pygobject-2.0 >= 2.21.3) were not met:

No package 'pygobject-2.0' found


pelo que eu entendi eu tenho que instalar esse tal pygobject2.0 (só que eu nao faço ideia de como instalar, baixar ou qual comando que é)

eu estava instalado primeiro o cpu-g e deu essa msg

$ ./cpu-g
You need to have PyGTK 2.10.0, GTK.Glade and GTK+ 2.10.0 or higher installed in your system in order to run CPU-G.


ai eu to tentando instalar esse tal PyGTK 2.10.0 e nesse instalação que estou com problema que é o primeiro problema ja resolvido do topico


Isso mesmo, você tem que instalar o pygobject2.0.

Você disse que não tem ideia de como instalar esse pacote. Você conhece o yum ou o dnf, os gerenciadores de pacotes do fedora? Qual o seu nível de conhecimento em Linux?

___________________________________________________________________
4c 69 6e 75 78 20 c3 a9 20 6d 65 6c 68 6f 72 20 71 75 65 20 57 69 6e 64 6f 77 73


5. isso

rafae
rafah00

(usa Fedora)

Enviado em 08/02/2016 - 21:55h

Isso mesmo, você tem que instalar o pygobject2.0.

Você disse que não tem ideia de como instalar esse pacote. Você conhece o yum ou o dnf, os gerenciadores de pacotes do fedora? Qual o seu nível de conhecimento em Linux?


instalar até que poderia fazer com ajuda de comandos, ou seja sei dar comandos e talz, mas conhecer a mecanica de como funciona tudo assim nao do yum nem dnf nem sei o que direito, e nao entendo tambem de gerenciador de pacote rsrsrs... só sei dar comandos mesmo e instalar alguns programas geral ./configure, make e make install, mas quando aparece esses erros assim fica complicado, senao me engano eu instalei o gparted por comando e foi de boas.... eu tenho o fedora faz menos de 1 mes ...enfim ....acho q da pra entener meu nivel de linux....

a questao é que eu nao sei onde procurar se da um erro desse pygobect2.0 qual é o comando dele que eu nao sei? OBS: achei um site que baixa esse arquivo mas quando fui dar o ./configure outro erro

@localhost pygtk-2.24.0]$ ./configure
.....
configure: error: Package requirements (glib-2.0 >= 2.24.0
gobject-introspection-1.0 >= 0.10.2
) were not met:

No package 'gobject-introspection-1.0' found


quando você tinha me passado o comando eu nem precisei de baixar foi direto sem ter que baixar um arquivo e dar outro erro pra instalar isso

enfim instalar o comando é muito mais simples porque toda vez que vou instalar um pacote que um erro mostra, eu encontro outro erro ai o negocio fica meio doido, não sei se é so comigo


6. Re: como instalarno linux fedora configure: error: gobject is required to build pygtk? [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 08/02/2016 - 22:15h

Então amigo, pelo que eu entendi você está instalando todos os pacotes a partir do código-fonte. Dessa forma que está fazendo é difícil para um iniciante e vai te dar muitas dores de cabeça. Eu sugiro a você dar uma lida básica sobre o funcionamento do Linux em geral. Aqui mesmo temos vários tutoriais voltados para iniciantes.

Um gerenciador de pacotes é um programa que instala os programas pra você. Ao invés de fazer como está fazendo (./configure, make e make install), basta dar um comando e o gerenciador de pacotes instala o pacote que você quer e suas dependências. O que está acontecendo com você é um problema com dependências (um programa precisa de outros programas para funcionar, se você está instalando o programa X e ele precisa do programa Y pra funcionar, enquanto você não instalar o programa Y, você não conseguirá instalar o programa X).

No Fedora o gerenciador de pacotes é o rpm e você consegue instalar pacotes utilizando o yum. Por exemplo:

yum install pacote-de-exeplo 


E pronto, pacote instalado!

Veja esse tutorial dos comandos mais utilizados no yum:

http://dailson.blogspot.com.br/2011/08/guia-de-comandos-do-yum.html

Após entender o funcionamento básico do sistema comece a se aventurar nele. Se você continuar instalando os pacotes por meio de compilação (./configure, make e make install) só terá dores de cabeça

___________________________________________________________________
4c 69 6e 75 78 20 c3 a9 20 6d 65 6c 68 6f 72 20 71 75 65 20 57 69 6e 64 6f 77 73


7. ahhh

rafae
rafah00

(usa Fedora)

Enviado em 08/02/2016 - 22:39h

ahh simmm valeu ajudou a entender bem ja, valeu..... só tem uma coisinha o problema que eu nao entendi é que toda vez que baixo um programa eu nem sempre acho ele em .rpm ele vem .tar.gz, por exemplo, que é ai que eu começo a instalar em codigo fonte, pelo que eu entendi. por exemplo baixei o cpu-g tem esses arquivos depois de extrair

ocalhost cpu-g-0.9.0]$ ls
COPYING [green]cpu-g[/green] cpu-g.glade [blue]data doc[/blue] README


se nao tem arquivo em .rpm eu usei no caso ./cpu-g e deu

You need to have PyGTK 2.10.0, GTK.Glade and GTK+ 2.10.0 or higher installed in your system in order to run CPU-G.


é ai que complica quando nao tem .rpm

sou grato por toda ajuda até agora valeu mesmo....


8. Re: como instalarno linux fedora configure: error: gobject is required to build pygtk? [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 09/02/2016 - 11:55h

Entendi amigo, as vezes é necessário instalar pacotes pelo código-fonte mesmo, mas são casos bem raros ou específicos (no caso do Fedora). Eu encontrei esse pacote que quer instalar em rpm, segue o link:

http://pkgs.org/fedora-23/rpm-sphere/cpug-0.9.0-9.1.noarch.rpm.html

No site acima, também exibe as dependências necessárias, então instale todas antes de instalar o cpug.
___________________________________________________________________
4c 69 6e 75 78 20 c3 a9 20 6d 65 6c 68 6f 72 20 71 75 65 20 57 69 6e 64 6f 77 73


9. Valeu

rafae
rafah00

(usa Fedora)

Enviado em 13/02/2016 - 17:01h

conseui instalar os pacotes necessários mais nao consegui abrir ainda o programa

cpu-g-0.9.0]$ ls
COPYING cpu-g cpu-g.glade data doc README

localhost cpu-g-0.9.0]$ ./cpu-g
cpu set to #0
Traceback (most recent call last):
File "./cpu-g", line 344, in <module>
CPUG()
File "./cpu-g", line 279, in __init__
self.wTree.get_object("xorg").set_text(main().xver())
File "./cpu-g", line 184, in xver
return re.findall("X\.Org X Server (.*)", stderr)[0]
IndexError: list index out of range

mais ta bom outro dia vou tentar instalar


10. Re: como instalarno linux fedora configure: error: gobject is required to build pygtk? [RESOLVIDO]

IceStorms
IceStorms

(usa Sabayon)

Enviado em 13/02/2016 - 23:22h

Procure um programa chamado Yumex Package Manager, ele é um gerenciador para instalação, atualização e desinstalação de pacotes nativo do Fedora. Com o Yumex você pode fazer a instalação simplesmente digitando na busca e marcando para instalação tudo em modo gráfico.

Se for usar o terminal para instalar qualquer coisa, utilize sempre o dnf, só em último caso use o yum.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts