Problema instalação amdgpu.

1. Problema instalação amdgpu.

Marcos Pinheiro Moura
cocas

(usa Ubuntu)

Enviado em 24/11/2019 - 09:08h

Fiz a instalação do driver amd (aparentemente havia rodado normal), mas após a instalação/reinicialização do computador todo e qualquer comando que eu uso no meu terminal me retorna essa msg de erro... Não sei o que fazer.

PS: usei a instação do clamav como exemplo mas o erro ocorre praticamente em qualquer operação pelo terminal.

marcos@marcos-Default-string:~$ sudo apt install clamav
[sudo] senha para marcos:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
clamav is already the newest version (0.101.4+dfsg-1ubuntu1).
clamav configurado para instalar manualmente.
Você pode querer executar 'apt --fix-broken install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
amdgpu-dkms : Depende: amdgpu-core mas não será instalado
amdgpu-lib : Depende: amdgpu-core (= 19.30-934563) mas não será instalado
glamor-amdgpu : Depende: amdgpu-core mas não será instalado
gst-omx-amdgpu : Depende: amdgpu-core mas não será instalado
libdrm-amdgpu-common : Depende: amdgpu-core mas não será instalado
libdrm2-amdgpu:i386 : Depende: amdgpu-core:i386
libdrm2-amdgpu : Depende: amdgpu-core mas não será instalado
libegl1-amdgpu-mesa:i386 : Depende: amdgpu-core:i386
libegl1-amdgpu-mesa : Depende: amdgpu-core mas não será instalado
libgbm1-amdgpu:i386 : Depende: amdgpu-core:i386
libgbm1-amdgpu : Depende: amdgpu-core mas não será instalado
libgl1-amdgpu-mesa-dri:i386 : Depende: amdgpu-core:i386
Recomenda: libtxc-dxtn-s2tc0:i386 mas não é instalável ou
libtxc-dxtn0:i386 mas não é instalável
libgl1-amdgpu-mesa-dri : Depende: amdgpu-core mas não será instalado
Recomenda: libtxc-dxtn-s2tc0 mas não é instalável ou
libtxc-dxtn0 mas não é instalável
libglapi-amdgpu-mesa:i386 : Depende: amdgpu-core:i386
libglapi-amdgpu-mesa : Depende: amdgpu-core mas não será instalado
libllvm9.0-amdgpu:i386 : Depende: amdgpu-core:i386
libllvm9.0-amdgpu : Depende: amdgpu-core mas não será instalado
libwayland-amdgpu-client0:i386 : Depende: amdgpu-core:i386
libwayland-amdgpu-client0 : Depende: amdgpu-core mas não será instalado
libwayland-amdgpu-egl1:i386 : Depende: amdgpu-core:i386
libwayland-amdgpu-egl1 : Depende: amdgpu-core mas não será instalado
libwayland-amdgpu-server0:i386 : Depende: amdgpu-core:i386
libwayland-amdgpu-server0 : Depende: amdgpu-core mas não será instalado
mesa-amdgpu-va-drivers:i386 : Depende: amdgpu-core:i386
mesa-amdgpu-va-drivers : Depende: amdgpu-core mas não será instalado
mesa-amdgpu-vdpau-drivers:i386 : Depende: amdgpu-core:i386
mesa-amdgpu-vdpau-drivers : Depende: amdgpu-core mas não será instalado
xserver-xorg-amdgpu-video-amdgpu : Depende: amdgpu-core mas não será instalado
E: Dependências desencontradas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).



  


2. Re: Problema instalação amdgpu.

Izaias
izaias

(usa LMDE)

Enviado em 24/11/2019 - 18:46h

cocas escreveu:

Fiz a instalação do driver amd (aparentemente havia rodado normal), mas após a instalação/reinicialização do computador todo e qualquer comando que eu uso no meu terminal me retorna essa msg de erro... Não sei o que fazer.

PS: usei a instação do clamav como exemplo mas o erro ocorre praticamente em qualquer operação pelo terminal.

marcos@marcos-Default-string:~$ sudo apt install clamav
[sudo] senha para marcos:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
clamav is already the newest version (0.101.4+dfsg-1ubuntu1).
clamav configurado para instalar manualmente.
Você pode querer executar 'apt --fix-broken install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
amdgpu-dkms : Depende: amdgpu-core mas não será instalado
amdgpu-lib : Depende: amdgpu-core (= 19.30-934563) mas não será instalado
glamor-amdgpu : Depende: amdgpu-core mas não será instalado
gst-omx-amdgpu : Depende: amdgpu-core mas não será instalado
libdrm-amdgpu-common : Depende: amdgpu-core mas não será instalado
libdrm2-amdgpu:i386 : Depende: amdgpu-core:i386
libdrm2-amdgpu : Depende: amdgpu-core mas não será instalado
libegl1-amdgpu-mesa:i386 : Depende: amdgpu-core:i386
libegl1-amdgpu-mesa : Depende: amdgpu-core mas não será instalado
libgbm1-amdgpu:i386 : Depende: amdgpu-core:i386
libgbm1-amdgpu : Depende: amdgpu-core mas não será instalado
libgl1-amdgpu-mesa-dri:i386 : Depende: amdgpu-core:i386
Recomenda: libtxc-dxtn-s2tc0:i386 mas não é instalável ou
libtxc-dxtn0:i386 mas não é instalável
libgl1-amdgpu-mesa-dri : Depende: amdgpu-core mas não será instalado
Recomenda: libtxc-dxtn-s2tc0 mas não é instalável ou
libtxc-dxtn0 mas não é instalável
libglapi-amdgpu-mesa:i386 : Depende: amdgpu-core:i386
libglapi-amdgpu-mesa : Depende: amdgpu-core mas não será instalado
libllvm9.0-amdgpu:i386 : Depende: amdgpu-core:i386
libllvm9.0-amdgpu : Depende: amdgpu-core mas não será instalado
libwayland-amdgpu-client0:i386 : Depende: amdgpu-core:i386
libwayland-amdgpu-client0 : Depende: amdgpu-core mas não será instalado
libwayland-amdgpu-egl1:i386 : Depende: amdgpu-core:i386
libwayland-amdgpu-egl1 : Depende: amdgpu-core mas não será instalado
libwayland-amdgpu-server0:i386 : Depende: amdgpu-core:i386
libwayland-amdgpu-server0 : Depende: amdgpu-core mas não será instalado
mesa-amdgpu-va-drivers:i386 : Depende: amdgpu-core:i386
mesa-amdgpu-va-drivers : Depende: amdgpu-core mas não será instalado
mesa-amdgpu-vdpau-drivers:i386 : Depende: amdgpu-core:i386
mesa-amdgpu-vdpau-drivers : Depende: amdgpu-core mas não será instalado
xserver-xorg-amdgpu-video-amdgpu : Depende: amdgpu-core mas não será instalado
E: Dependências desencontradas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).


Não sei como instalou esse drive com tantas dependências faltando.
Remova o drive e aplique os comandos abaixo como root:


# dpkg --configure -a
# apt -f install
# apt -f remove
# apt update



3. Problema instalação amdgpu.

Marcos Pinheiro Moura
cocas

(usa Ubuntu)

Enviado em 25/11/2019 - 07:03h

Infelizmente não consigo tentar a sua solução, pois o mesmo erro que printei a cima aconteceu quando tento rodar o comando "amdgpu-uninstall".
Tentei também sem sucesso só rodar os comandos que você sugeriu. (Com a gpu instalada)
Alguma sugestão de como desinstalar a gpu por completo? e voltar a usar o driver nativo do ubuntu?


4. Re: Problema instalação amdgpu.

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 25/11/2019 - 12:35h

E cade o link do tutorial que você seguiu?

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.


5. Re: Problema instalação amdgpu.

Izaias
izaias

(usa LMDE)

Enviado em 25/11/2019 - 15:31h

cocas escreveu:

Infelizmente não consigo tentar a sua solução, pois o mesmo erro que printei a cima aconteceu quando tento rodar o comando "amdgpu-uninstall".
Tentei também sem sucesso só rodar os comandos que você sugeriu. (Com a gpu instalada)
Alguma sugestão de como desinstalar a gpu por completo? e voltar a usar o driver nativo do ubuntu?


No Ubuntu, certo? Veja se consegue remover graficamente:
1- Procure por Drivers adicionais
2- https://imgur.com/u9wgCC9

Esse driver proprietário no meu PC é o da Nvidia.
Não sei como está no seu, o importante é usar Nouveau (o último). Após mudar, reinicie e veja como o sistema se comporta.


6. instalação amdgpu

marcos antonio domingues do amaral
marcolinocevada

(usa Debian)

Enviado em 27/11/2019 - 22:26h

caro colega, não é necessário instalar o driver proprietário da AMD no Linux, pois o amdgpu já vem em seu kernel.
vc pode conferir que ele está instalado usando esse comando:

lspci -k | grep amdgpu

vc pode testar sua placa grafica usando o comando:

sudo apt-get install mesa-utils
glxinfo -i | grep openGL
glxgears

pra solucionar o problema de pacote quebrado, vc segue essa orientação:
sudo rm -r /var/opt/amdgpu-pro-local
sudo rm /etc/apt/sources.list.d/amdgpu-pro.list
sudo apt update
sudo apt upgrade

vai dar uma saída de erro, com a mensagem pra usar o comando: apt --fix-broken install
aplica esse comando e depois utilize outro:
sudo apt autoremove

pronto!
o driver disponivel na AMD é instalavel na versdão ubuntu 18.04

eu tentei no ubuntu 19.10 e nao deu certo pq o pacote amdgpu-core não instala.

Outra coisa legal é vc instalar suporte vulkan, já q sua placa de vídeo é AMD. O vulkan pode ser instalado usando os seguintes comandos:

sudo apt install mesa-vulkan-drivers vulkan-utils libassimp4

No processo de instalação vai instalar a dependência libiminizip1

Depois vc testa o vulkan com o comando

vulkaninfo

referencias:

https://askubuntu.com/questions/987778/how-to-fix-broken-packages-after-amdgpu-pro-install-fail

https://www.diolinux.com.br/2019/09/tudo-sobre-drivers-amd-no-linux.html

https://www.edivaldobrito.com.br/testar-a-aceleracao-3d-no-ubuntu/

https://www.linuxbuzz.com.br/2018/05/veja-como-instalar-driver-vulkan-no-ubuntu-18-04-lts-com-hardwa...









Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts