Pacotes quebrados [RESOLVIDO]

1. Pacotes quebrados [RESOLVIDO]

Fabiano de Souza Pereira
fabianospdev

(usa Ubuntu)

Enviado em 20/05/2020 - 16:13h

Já tentei os seguintes comandos:

sudo dpkg --remove -force --force-remove-reinstreq NOME_DO_PACOTE_VAI_AQUI


COMANDO 1
sudo apt-get --fix-broken install

COMANOD 2
sudo apt-get clean

sudo apt-get install -f

sudo dpkg --configure -a

COMANDO 3
sudo rm /var/lib/apt/lists/* -vf

sudo apt-get update

COMANDO 4
sudo apt-get clean

sudo apt-get autoclean

sudo apt-get autoremove

COMANDO 5
sudo dpkg --configure -a

sudo apt-get update


Obtendo respostas como esta:

Os pacotes a seguir têm dependências desencontradas:
anydesk : Depende: libgtk2.0-0 (>= 2.20.1) mas não está instalado
Depende: libpango-1.0-0 mas não está instalado
Depende: libcairo2 mas não está instalado
Depende: libxrandr2 (>= 1.3) mas não está instalado
Depende: libxkbfile1 mas não está instalado
Depende: libgtkglext1 mas não está instalado
Recomenda: xdg-utils mas não está instalado
autoconf : Depende: m4 (>= 1.4.13)
automake : Depende: autotools-dev (>= 20020320.1) mas não está instalado
bison : Depende: m4
console-setup : Depende: console-setup-linux mas não está instalado ou
console-setup-freebsd mas não é instalável ou
hurd mas não é instalável
curl : Depende: libcurl4 (= 7.68.0-1ubuntu2) mas não está instalado
default-jdk : Depende: default-jre (= 2:1.11-72) mas não está instalado
Depende: default-jdk-headless (= 2:1.11-72) mas não está instalado
Depende: openjdk-11-jdk mas não está instalado
e2fsprogs : Pré-Depende: libext2fs2 (= 1.45.5-2ubuntu1) mas não está instalado
Pré-Depende: libss2 (>= 1.38) mas não está instalado
Depende: logsave
Recomenda: e2fsprogs-l10n mas não está instalado
fonts-indic : Depende: fonts-beng mas não está instalado
Depende: fonts-deva mas não está instalado
Depende: fonts-gujr mas não está instalado
Depende: fonts-guru mas não está instalado
Depende: fonts-knda mas não está instalado
Depende: fonts-mlym mas não está instalado
Depende: fonts-orya mas não está instalado
Depende: fonts-pagul mas não está instalado
Depende: fonts-taml mas não está instalado
Depende: fonts-telu mas não está instalado
g++ : Depende: cpp (= 4:9.3.0-1ubuntu2) mas não está instalado
Depende: g++-9 (>= 9.3.0-3~) mas não está instalado
gawk : Pré-Depende: libsigsegv2 (>= 2.9) mas não está instalado
gcc : Depende: cpp (= 4:9.3.0-1ubuntu2) mas não está instalado
gdebi : Depende: gdebi-core (= 0.9.5.7+nmu3) mas não está instalado
Depende: gir1.2-gtk-3.0 mas não está instalado
Depende: gir1.2-vte-2.91 mas não está instalado
Depende: python3-gi mas não está instalado
Depende: policykit-1
Depende: gnome-icon-theme mas não está instalado
Recomenda: libgtk2-perl mas não está instalado
Recomenda: shared-mime-info
Recomenda: lintian mas não está instalado
git : Depende: libcurl3-gnutls (>= 7.56.1) mas não está instalado
Depende: liberror-perl mas não está instalado
Depende: git-man (> 1:2.25.1) mas não está instalado
Depende: git-man (< 1:2.25.1-.) mas não está instalado
Recomenda: ca-certificates mas não está instalado
Recomenda: less
Recomenda: ssh-client
gnome-getting-started-docs-pt : Depende: gnome-getting-started-docs (= 3.36.1-0ubuntu1) mas não está instalado
gnome-user-docs-pt : Depende: gnome-user-docs (= 3.36.1-0ubuntu1) mas não está instalado
grub-common : Depende: libefiboot1 (>= 37) mas não está instalado
Depende: libefivar1 (>= 37) mas não está instalado
Depende: gettext-base
grub2-common : Depende: libefiboot1 (>= 37) mas não está instalado
Depende: libefivar1 (>= 37) mas não está instalado
hunspell-en-us : Depende: dictionaries-common (>= 0.10) mas não está instalado
hunspell-pt-br : Depende: dictionaries-common mas não está instalado
hyphen-en-us : Depende: dictionaries-common mas não está instalado
hyphen-pt-br : Depende: dictionaries-common mas não está instalado
libcurl4-openssl-dev : Depende: libcurl4 (= 7.68.0-1ubuntu2) mas não está instalado
libncurses5-dev : Depende: libncurses-dev (= 6.2-0ubuntu2) mas não está instalado
libreadline-dev : Depende: libncurses-dev mas não está instalado
libreoffice-help-common : Depende: libreoffice-common mas não está instalado
libreoffice-help-en-us : Depende: libreoffice-common (>= 1:6.1.0~) mas não está instalado
Depende: libreoffice-l10n-en-us
Recomenda: libreoffice-core (> 1:6.4.3) mas não está instalado
libreoffice-help-pt : Depende: libreoffice-common (>= 1:6.1.0~) mas não está instalado
Recomenda: libreoffice-core (> 1:6.4.3) mas não está instalado
libreoffice-help-pt-br : Depende: libreoffice-common (>= 1:6.1.0~) mas não está instalado
Recomenda: libreoffice-core (> 1:6.4.3) mas não está instalado
libreoffice-l10n-pt : Depende: libreoffice-common mas não está instalado
Recomenda: libreoffice-core (> 1:6.4.3) mas não está instalado
libreoffice-l10n-pt-br : Depende: libreoffice-common mas não está instalado
Recomenda: libreoffice-core (> 1:6.4.3) mas não está instalado
libtool : Depende: cpp mas não está instalado
Depende: file
Depende: autotools-dev mas não está instalado
Recomenda: libltdl-dev mas não está instalado
libyaml-dev : Depende: libyaml-0-2 (= 0.2.2-1) mas não está instalado
linux-image-generic-hwe-20.04 : Depende: linux-firmware mas não está instalado
Depende: intel-microcode mas não está instalado
Depende: amd64-microcode mas não está instalado
Recomenda: thermald mas não está instalado
linux-modules-extra-5.4.0-31-generic : Depende: crda mas não está instalado ou
wireless-crda mas não está instalado
lxqt-sudo : Depende: liblxqt0 (>= 0.9.0+20150911) mas não está instalado
Recomenda: lxqt-qtplugin mas não está instalado
Recomenda: lxqt-sudo-l10n mas não está instalado
mythes-en-us : Depende: dictionaries-common mas não está instalado
npm : Depende: nodejs (>= 6.11~)
Depende: ca-certificates mas não está instalado
Depende: node-abbrev (>= 1.1.1~) mas não está instalado
Depende: node-ajv mas não está instalado

etc..

os-prober : Depende: dmsetup
pciutils : Depende: libpci3 (= 1:3.6.4-1) mas não está instalado
php-dev : Depende: php7.4-dev mas não está instalado
ruby : Depende: ruby2.7 mas não está instalado
ruby-bundler : Depende: ruby-molinillo (>= 0.6~) mas não está instalado
Depende: ruby-net-http-persistent mas não está instalado
Depende: ruby-thor (>= 0.19.4~) mas não está instalado
Depende: rubygems-integration mas não está instalado
ruby-dev : Depende: ruby2.7-dev mas não está instalado
thunderbird-locale-en : Depende: thunderbird (>= 1:68.7.0+build1-0ubuntu2) mas não está instalado
Depende: thunderbird (< 1:68.7.0+build1-0ubuntu2.1~) mas não está instalado
thunderbird-locale-pt : Depende: thunderbird (>= 1:68.7.0+build1-0ubuntu2) mas não está instalado
Depende: thunderbird (< 1:68.7.0+build1-0ubuntu2.1~) mas não está instalado
ubuntu-desktop : Depende: alsa-base mas não está instalado
Depende: alsa-utils
Depende: anacron
Depende: at-spi2-core
Depende: bc
Depende: ca-certificates mas não está instalado

etc...

ubuntu-desktop-minimal : Depende: alsa-base mas não está instalado
Depende: alsa-utils
Depende: anacron
Depende: at-spi2-core
Depende: bc
Depende: ca-certificates mas não está instalado

etc...

ubuntu-minimal : Depende: apt-utils mas não está instalado
Depende: debconf-i18n mas não está instalado
Depende: iproute2
Depende: iputils-ping mas não está instalado
Depende: isc-dhcp-client mas não está instalado
Depende: kbd mas não está instalado
Depende: less
Depende: mawk
Depende: netbase mas não está instalado
Depende: netcat-openbsd mas não está instalado
Depende: netplan.io mas não está instalado
Depende: procps
Depende: sudo
Depende: ubuntu-advantage-tools mas não está instalado
Depende: vim-tiny mas não está instalado
Depende: whiptail
Recomenda: rsyslog mas não está instalado
ubuntu-restricted-extras : Depende: ubuntu-restricted-addons mas não está instalado
Recomenda: libavcodec-extra mas não está instalado
Recomenda: ttf-mscorefonts-installer mas não está instalado
Recomenda: unrar mas não está instalado
ubuntu-standard : Depende: busybox-static mas não está instalado
Depende: cpio
Depende: dmidecode
Depende: dnsutils
Depende: dosfstools mas não está instalado
Depende: ed
Depende: file
Depende: ftp
Depende: hdparm mas não está instalado
Depende: info
Depende: iptables
Depende: logrotate mas não está instalado
Depende: lshw mas não está instalado
Depende: lsof mas não está instalado
Depende: ltrace mas não está instalado
Depende: parted
Depende: psmisc
Depende: strace mas não está instalado
Depende: time
Depende: wget
Recomenda: apparmor mas não está instalado
Recomenda: bash-completion mas não está instalado
Recomenda: command-not-found mas não está instalado
Recomenda: friendly-recovery mas não está instalado
Recomenda: iputils-tracepath mas não está instalado
Recomenda: irqbalance
Recomenda: manpages mas não está instalado
Recomenda: mtr-tiny mas não está instalado
Recomenda: nano mas não está instalado
Recomenda: openssh-client
Recomenda: plymouth mas não está instalado
Recomenda: plymouth-theme-ubuntu-text mas não está instalado
Recomenda: tcpdump mas não está instalado
Recomenda: telnet mas não está instalado
Recomenda: ufw mas não está instalado
Recomenda: update-manager-core mas não está instalado
Recomenda: uuid-runtime
ubuntu-wallpapers : Depende: ubuntu-wallpapers-focal mas não está instalado
usbutils : Depende: libusb-1.0-0 (>= 2:1.0.22) mas não está instalado
Depende: usb.ids mas não está instalado
wbrazilian : Depende: dictionaries-common (>= 1.0) mas não está instalado
wbritish : Depende: dictionaries-common (>= 0.20) mas não está instalado
wportuguese : Depende: dictionaries-common (>= 1.0) mas não está instalado
E: Dependências desencontradas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).
[email protected]:/home/fsp#

NADA RESOLVEU.

Não consigo instalar nada e nem desinstalar.

Senão instalaria o aptitude e resolveria, pois vi um poste de um cara que resolveu com aptitude que aborda o problema de forma alternativa.

ALguma ideia ? Que não seja reinstalar o ubuntu.
Na boa já reinstalei em outras demandas que eu tive aqui.
E eu realmente acredito que tudo tem solução sem reinstalar.

Obrigado.


  


2. Pacotes quebrados [RESOLVIDO]

Fabiano de Souza Pereira
fabianospdev

(usa Ubuntu)

Enviado em 29/05/2020 - 16:23h

Era o hd que estava com muitos badblocks.
Após reinstalar o ubuntu 6 vezes.

Fiz o certo e comprei um HD SSD novo.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts